aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-Starman
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2010-03-29 18:36:48 +0800
committerkuriyama <kuriyama@FreeBSD.org>2010-03-29 18:36:48 +0800
commita45e6a487762aa81776906e1e0098b0fbb17506a (patch)
treeab05d2e2d3d9d4aa83f72b494d700abc9bdfd491 /www/p5-Starman
parentca6db303a0480323f69d4e16260dabe7d9713fd2 (diff)
downloadfreebsd-ports-gnome-a45e6a487762aa81776906e1e0098b0fbb17506a.tar.gz
freebsd-ports-gnome-a45e6a487762aa81776906e1e0098b0fbb17506a.tar.zst
freebsd-ports-gnome-a45e6a487762aa81776906e1e0098b0fbb17506a.zip
High-performance preforking PSGI web server.
WWW: http://search.cpan.org/dist/Starman/
Diffstat (limited to 'www/p5-Starman')
-rw-r--r--www/p5-Starman/Makefile32
-rw-r--r--www/p5-Starman/distinfo3
-rw-r--r--www/p5-Starman/pkg-descr3
-rw-r--r--www/p5-Starman/pkg-plist13
4 files changed, 51 insertions, 0 deletions
diff --git a/www/p5-Starman/Makefile b/www/p5-Starman/Makefile
new file mode 100644
index 000000000000..9c376794bfa6
--- /dev/null
+++ b/www/p5-Starman/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Starman
+# Date created: 29 Mar 2010
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Starman
+PORTVERSION= 0.1005
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/M/MI/MIYAGAWA
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for high-performance preforking PSGI web server
+
+RUN_DEPENDS= \
+ p5-Data-Dump>0:${PORTSDIR}/devel/p5-Data-Dump \
+ p5-HTTP-Parser-XS>0:${PORTSDIR}/www/p5-HTTP-Parser-XS \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww \
+ p5-Net-Server>=0.91:${PORTSDIR}/net/p5-Net-Server \
+ p5-Plack>=0.9925:${PORTSDIR}/www/p5-Plack
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= starman.1
+MAN3= Plack::Handler::Starman.3 \
+ Starman.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Starman/distinfo b/www/p5-Starman/distinfo
new file mode 100644
index 000000000000..544d4141a651
--- /dev/null
+++ b/www/p5-Starman/distinfo
@@ -0,0 +1,3 @@
+MD5 (Starman-0.1005.tar.gz) = 698ae546af361a1c4fc13553a3a5c22e
+SHA256 (Starman-0.1005.tar.gz) = 519a35496bbc94c07e9a28cb50af8e2918fc5aa37bf0f93435674a87d88f4337
+SIZE (Starman-0.1005.tar.gz) = 34753
diff --git a/www/p5-Starman/pkg-descr b/www/p5-Starman/pkg-descr
new file mode 100644
index 000000000000..e9f1ed61185e
--- /dev/null
+++ b/www/p5-Starman/pkg-descr
@@ -0,0 +1,3 @@
+High-performance preforking PSGI web server.
+
+WWW: http://search.cpan.org/dist/Starman/
diff --git a/www/p5-Starman/pkg-plist b/www/p5-Starman/pkg-plist
new file mode 100644
index 000000000000..c0e5a8bdcf32
--- /dev/null
+++ b/www/p5-Starman/pkg-plist
@@ -0,0 +1,13 @@
+bin/starman
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Starman/.packlist
+%%SITE_PERL%%/HTTP/Server/PSGI/Net/Server/PreFork.pm
+%%SITE_PERL%%/Plack/Handler/Starman.pm
+%%SITE_PERL%%/Starman.pm
+%%SITE_PERL%%/Starman/Server.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Starman
+@dirrmtry %%SITE_PERL%%/HTTP/Server/PSGI/Net/Server
+@dirrmtry %%SITE_PERL%%/HTTP/Server/PSGI/Net
+@dirrmtry %%SITE_PERL%%/HTTP/Server/PSGI
+@dirrmtry %%SITE_PERL%%/Plack/Handler
+@dirrmtry %%SITE_PERL%%/Plack
+@dirrm %%SITE_PERL%%/Starman