aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-URI-Fetch
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-05-31 19:19:32 +0800
committerbapt <bapt@FreeBSD.org>2012-05-31 19:19:32 +0800
commit68b530317704ed344f567080786046479ed054fb (patch)
tree93fe9eebc56e2451ba426603948adb8749cb38e9 /www/p5-URI-Fetch
parentaedee365f6b7833ae31d4b673dcd979c369e4ac2 (diff)
downloadfreebsd-ports-gnome-68b530317704ed344f567080786046479ed054fb.tar.gz
freebsd-ports-gnome-68b530317704ed344f567080786046479ed054fb.tar.zst
freebsd-ports-gnome-68b530317704ed344f567080786046479ed054fb.zip
Convert to new options framework
Diffstat (limited to 'www/p5-URI-Fetch')
-rw-r--r--www/p5-URI-Fetch/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/www/p5-URI-Fetch/Makefile b/www/p5-URI-Fetch/Makefile
index 583d9bf873ae..cacf84acee63 100644
--- a/www/p5-URI-Fetch/Makefile
+++ b/www/p5-URI-Fetch/Makefile
@@ -20,8 +20,11 @@ RUN_DEPENDS= p5-Class-ErrorHandler>=0:${PORTSDIR}/devel/p5-Class-ErrorHandler \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
BUILD_DEPENDS= ${RUN_DEPENDS}
-OPTIONS= ZLIB "GZIP Support" on \
- CACHE "Caching Support" off
+OPTIONS_DEFINE= ZLIB CACHE
+OPTIONS_DEFAULT= ZLIB
+
+ZLIB_DESC= GZIP Support
+CACHE_DESC= Caching Support
PERL_CONFIGURE= yes
@@ -30,13 +33,13 @@ MAN3= URI::Fetch.3 \
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_ZLIB)
+.if ${PORT_OPTIONS:MZLIB}
. if ${PERL_LEVEL} < 500903
RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
. endif
.endif
-.if defined(WITH_CACHE)
+.if ${PORT_OPTIONS:MCACHE}
RUN_DEPENDS+= p5-Cache>=0:${PORTSDIR}/devel/p5-Cache
.endif