aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-WWW-Dilbert
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2004-08-15 21:58:08 +0800
committervanilla <vanilla@FreeBSD.org>2004-08-15 21:58:08 +0800
commit8cc5d0909ccd97970592cd03f5d4af5482e7a9e1 (patch)
tree9e719174973bb2883f26556f67b708aef6c5041b /www/p5-WWW-Dilbert
parentae53aa3a5c7affbaeda8f24d105cdceb168cfeee (diff)
downloadfreebsd-ports-gnome-8cc5d0909ccd97970592cd03f5d4af5482e7a9e1.tar.gz
freebsd-ports-gnome-8cc5d0909ccd97970592cd03f5d4af5482e7a9e1.tar.zst
freebsd-ports-gnome-8cc5d0909ccd97970592cd03f5d4af5482e7a9e1.zip
Add p5-WWW-Dilbert 1.02, dilbert of the day comic strip archive and
retieval module. PR: ports/70442 Submitted by: Cheng-Lung Sung <clsung@dragon2.net>
Diffstat (limited to 'www/p5-WWW-Dilbert')
-rw-r--r--www/p5-WWW-Dilbert/Makefile36
-rw-r--r--www/p5-WWW-Dilbert/distinfo2
-rw-r--r--www/p5-WWW-Dilbert/pkg-descr10
-rw-r--r--www/p5-WWW-Dilbert/pkg-plist5
4 files changed, 53 insertions, 0 deletions
diff --git a/www/p5-WWW-Dilbert/Makefile b/www/p5-WWW-Dilbert/Makefile
new file mode 100644
index 000000000000..c4d7632d177c
--- /dev/null
+++ b/www/p5-WWW-Dilbert/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-WWW-Dilbert
+# Date created: Aug 14 2004
+# Whom: Cheng-Lung Sung <clsung@dragon2.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-Dilbert
+PORTVERSION= 1.02
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WWW
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Dilbert of the day comic strip archive and retieval module
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP/Simple.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+ ${SITE_PERL}/Image/Info.pm:${PORTSDIR}/graphics/p5-Image-Info
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= WWW::Dilbert.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-WWW-Dilbert/distinfo b/www/p5-WWW-Dilbert/distinfo
new file mode 100644
index 000000000000..84818213ec48
--- /dev/null
+++ b/www/p5-WWW-Dilbert/distinfo
@@ -0,0 +1,2 @@
+MD5 (WWW-Dilbert-1.02.tar.gz) = cd300adbed800cc86642486232d5afd8
+SIZE (WWW-Dilbert-1.02.tar.gz) = 10661
diff --git a/www/p5-WWW-Dilbert/pkg-descr b/www/p5-WWW-Dilbert/pkg-descr
new file mode 100644
index 000000000000..4b9be8238fc4
--- /dev/null
+++ b/www/p5-WWW-Dilbert/pkg-descr
@@ -0,0 +1,10 @@
+This module will download the latest Dilbert of the Day cartoon strip
+from the Dilbert website and return an object which can be either
+stored in a database or output to a browser, disk or whatever. It
+allows importing of Dilbert strips from disk or alternate URLs, and
+has a random strip interface to return strips from the database.
+
+WWW: http://search.cpan.org/dist/WWW-Dilbert
+
+-- Cheng-Lung Sung
+clsung at dragon2.net
diff --git a/www/p5-WWW-Dilbert/pkg-plist b/www/p5-WWW-Dilbert/pkg-plist
new file mode 100644
index 000000000000..fe10555a54e9
--- /dev/null
+++ b/www/p5-WWW-Dilbert/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/WWW/Dilbert.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Dilbert/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Dilbert
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/WWW 2>/dev/null || true