aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-chklinks
diff options
context:
space:
mode:
authorchinsan <chinsan@FreeBSD.org>2007-06-12 21:26:18 +0800
committerchinsan <chinsan@FreeBSD.org>2007-06-12 21:26:18 +0800
commitc2e62f75378a024bd049079424d80a0ec7dc3cd1 (patch)
treefdd685a12ecd5efef8fa7eb63449dc0556b87c2e /www/p5-chklinks
parent315f8e845714883233a4379a120f7900f1a1e718 (diff)
downloadfreebsd-ports-gnome-c2e62f75378a024bd049079424d80a0ec7dc3cd1.tar.gz
freebsd-ports-gnome-c2e62f75378a024bd049079424d80a0ec7dc3cd1.tar.zst
freebsd-ports-gnome-c2e62f75378a024bd049079424d80a0ec7dc3cd1.zip
Add p5-chklinks 3.06, a non-threaded Perl link checker.
PR: ports/113421 Submitted by: chinsan
Diffstat (limited to 'www/p5-chklinks')
-rw-r--r--www/p5-chklinks/Makefile30
-rw-r--r--www/p5-chklinks/distinfo3
-rw-r--r--www/p5-chklinks/pkg-descr9
3 files changed, 42 insertions, 0 deletions
diff --git a/www/p5-chklinks/Makefile b/www/p5-chklinks/Makefile
new file mode 100644
index 000000000000..a1bf3eb143fc
--- /dev/null
+++ b/www/p5-chklinks/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-chklinks
+# Date created: 2007/06/07
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= chklinks
+PORTVERSION= 3.06
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Locale/IMACAT
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= A non-threaded Perl link checker
+
+BUILD_DEPENDS= p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
+ ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+MAN1= chklinks.1
+
+PLIST_FILES= bin/chklinks \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/chklinks/.packlist
+PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/chklinks
+
+.include <bsd.port.mk>
diff --git a/www/p5-chklinks/distinfo b/www/p5-chklinks/distinfo
new file mode 100644
index 000000000000..52aede2a52c6
--- /dev/null
+++ b/www/p5-chklinks/distinfo
@@ -0,0 +1,3 @@
+MD5 (chklinks-3.06.tar.gz) = 7877fc7e9985d1ffa812c6f773e8ceb7
+SHA256 (chklinks-3.06.tar.gz) = 7ff478c6ab33d64ff7b62d5f787ce0e86f0b8ef0d2143dc2c97ca4b66ff15b70
+SIZE (chklinks-3.06.tar.gz) = 67349
diff --git a/www/p5-chklinks/pkg-descr b/www/p5-chklinks/pkg-descr
new file mode 100644
index 000000000000..d1c6346ba5e8
--- /dev/null
+++ b/www/p5-chklinks/pkg-descr
@@ -0,0 +1,9 @@
+chklinks is a Perl link checker. It helps finding broken links on your
+website.
+
+chklinks differs from linkchecker in that chklinks is non- threaded. It does
+not raises many simultaneously connections for its job. It won't run out of
+the resources and crash your system in a moment. This is certainly more
+desirable for most webmasters and users.
+
+WWW: http://search.cpan.org/dist/chklinks/