aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-libservlet/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-07-28 14:28:47 +0800
committerijliao <ijliao@FreeBSD.org>2001-07-28 14:28:47 +0800
commit8263e7d678d78c0b99ba801eedf3d87b2a8b5f7e (patch)
treedb7ce844cfad249bf770041d6c13c21e7524d0e6 /www/p5-libservlet/Makefile
parentf05aa6e02f4d6aa220c1334fc0155815cb24f5d6 (diff)
downloadfreebsd-ports-gnome-8263e7d678d78c0b99ba801eedf3d87b2a8b5f7e.tar.gz
freebsd-ports-gnome-8263e7d678d78c0b99ba801eedf3d87b2a8b5f7e.tar.zst
freebsd-ports-gnome-8263e7d678d78c0b99ba801eedf3d87b2a8b5f7e.zip
add p5-libservlet
Servlet API for Perl
Diffstat (limited to 'www/p5-libservlet/Makefile')
-rw-r--r--www/p5-libservlet/Makefile61
1 files changed, 61 insertions, 0 deletions
diff --git a/www/p5-libservlet/Makefile b/www/p5-libservlet/Makefile
new file mode 100644
index 000000000000..3bd1d371c6bd
--- /dev/null
+++ b/www/p5-libservlet/Makefile
@@ -0,0 +1,61 @@
+# ex:ts=8
+# New ports collection makefile for: p5-libservlet
+# Date created: Jul 28, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= libservlet
+PORTVERSION= 0.9.1
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ijliao@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Exception/Class.pm:${PORTSDIR}/devel/p5-Exception-Class
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Servlet.3 \
+ Servlet::ServletException.3 \
+ Servlet::Util::Event.3 \
+ Servlet::Http::HttpSession.3 \
+ Servlet::Http::HttpServletRequestWrapper.3 \
+ Servlet::Http::HttpServletResponse.3 \
+ Servlet::Http::HttpServlet.3 \
+ Servlet::Http::HttpSessionEvent.3 \
+ Servlet::ServletContextEvent.3 \
+ Servlet::ServletContextListener.3 \
+ Servlet::ServletContextAttributeListener.3 \
+ Servlet::Http::Cookie.3 \
+ Servlet::ServletOutputStream.3 \
+ Servlet::Servlet.3 \
+ Servlet::GenericServlet.3 \
+ Servlet::ServletResponse.3 \
+ Servlet::UnavailableException.3 \
+ Servlet::Http::HttpSessionAttributesListener.3 \
+ Servlet::Filter.3 \
+ Servlet::ServletRequestWrapper.3 \
+ Servlet::Http::HttpSessionListener.3 \
+ Servlet::Http::HttpServletResponseWrapper.3 \
+ Servlet::Util::Exception.3 \
+ Servlet::SingleThreadModel.3 \
+ Servlet::FilterChain.3 \
+ Servlet::Http::HttpServletRequest.3 \
+ Servlet::Http::HttpSessionBindingEvent.3 \
+ Servlet::ServletContextAttributeEvent.3 \
+ Servlet::ServletContext.3 \
+ Servlet::Http::HttpSessionActivationListener.3 \
+ Servlet::ServletRequest.3 \
+ Servlet::ServletInputStream.3 \
+ Servlet::Http::HttpSessionBindingListener.3 \
+ Servlet::ServletResponseWrapper.3 \
+ Servlet::RequestDispatcher.3
+
+.include <bsd.port.mk>