aboutsummaryrefslogtreecommitdiffstats
path: root/www/pear-HTTP_Session2/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-12-28 16:54:32 +0800
committeredwin <edwin@FreeBSD.org>2003-12-28 16:54:32 +0800
commitc5aaa7c7037b91f8bd12a6e2723b10f174f5a905 (patch)
treef62840896965379f3983ff6cbd083cde7f4ac43c /www/pear-HTTP_Session2/Makefile
parent05b6b5ebc5eeecebf39e1f0665d4f04e9248b9d9 (diff)
downloadfreebsd-ports-gnome-c5aaa7c7037b91f8bd12a6e2723b10f174f5a905.tar.gz
freebsd-ports-gnome-c5aaa7c7037b91f8bd12a6e2723b10f174f5a905.tar.zst
freebsd-ports-gnome-c5aaa7c7037b91f8bd12a6e2723b10f174f5a905.zip
New port: pear-HTTP_Session: OO interface to the session_* family functions
Object-oriented interface to the session_* family functions it provides extra features such as database storage for session data using DB package. It introduces new methods like isNew(), useCookies(), setExpire(), setIdle(), isExpired(), isIdled() and others. WWW: http://pear.php.net/package-info.php?package=HTTP_Session PR: ports/60195 Submitted by: Alex Miller <asm@asm.kiev.ua>
Diffstat (limited to 'www/pear-HTTP_Session2/Makefile')
-rw-r--r--www/pear-HTTP_Session2/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/www/pear-HTTP_Session2/Makefile b/www/pear-HTTP_Session2/Makefile
new file mode 100644
index 000000000000..ba9efc793dd2
--- /dev/null
+++ b/www/pear-HTTP_Session2/Makefile
@@ -0,0 +1,36 @@
+# Ports collection makefile for: pear-HTTP_Session
+# Date created: 13 December 2003
+# Whom: Alex Miller (<asm@asm.kiev.ua>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP_Session
+PORTVERSION= 0.4
+CATEGORIES= www devel pear
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= PEAR Object-oriented interface to the session_* family functions
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/docs/sessiondata.sql ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/docs/HTTP_Session_Example.php ${DOCSDIR}
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+.endif
+
+do-install:
+ @${MKDIR} ${PEARDIR}/Session/Container
+ @${CP} -p ${WRKSRC}/Session/Container/DB.php ${PEARDIR}/Session/Container
+ @${CP} -p ${WRKSRC}/Session/Container.php ${PEARDIR}/Session
+ @${CP} ${WRKSRC}/Session.php ${PEARDIR}
+ @${CHOWN} ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/Session.php
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/Session
+
+.include <bsd.port.post.mk>