aboutsummaryrefslogtreecommitdiffstats
path: root/www/pear-Services_Delicious
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-03-09 03:48:41 +0800
committermat <mat@FreeBSD.org>2018-03-09 03:48:41 +0800
commit3de11f75e95b0f2dda0d4e2d1bed3fca9fd4925e (patch)
treea942b9de6ec3ced252f123bf8a905b18d685aa72 /www/pear-Services_Delicious
parentbd4297a179c7edf0fe5800bb82c677771f17923c (diff)
downloadfreebsd-ports-gnome-3de11f75e95b0f2dda0d4e2d1bed3fca9fd4925e.tar.gz
freebsd-ports-gnome-3de11f75e95b0f2dda0d4e2d1bed3fca9fd4925e.tar.zst
freebsd-ports-gnome-3de11f75e95b0f2dda0d4e2d1bed3fca9fd4925e.zip
Introduce PHP flavors.
Ports using USES=php:phpize, php:ext, php:zend, and php:pecl are now flavored. They will automatically get flavors (php56, php70, php71, php72) depending of the versions they support (set with IGNORE_WITH_PHP). As a consequence, ports using USES=pear and USES=horde are also flavored. PR: 226242 Submitted by: mat Exp-run by: antoine Approved by: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14208
Diffstat (limited to 'www/pear-Services_Delicious')
-rw-r--r--www/pear-Services_Delicious/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/www/pear-Services_Delicious/Makefile b/www/pear-Services_Delicious/Makefile
index 9323b20cb515..6c3b0950ea52 100644
--- a/www/pear-Services_Delicious/Makefile
+++ b/www/pear-Services_Delicious/Makefile
@@ -8,10 +8,10 @@ CATEGORIES= www pear
MAINTAINER= joneum@FreeBSD.org
COMMENT= PEAR Client for the del.icio.us web service
-BUILD_DEPENDS= ${PEARDIR}/XML/Serializer.php:devel/pear-XML_Serializer \
- ${PEARDIR}/HTTP/Request.php:www/pear-HTTP_Request
-RUN_DEPENDS= ${PEARDIR}/XML/Serializer.php:devel/pear-XML_Serializer \
- ${PEARDIR}/HTTP/Request.php:www/pear-HTTP_Request
+BUILD_DEPENDS= ${PEARDIR}/XML/Serializer.php:devel/pear-XML_Serializer@${PHP_FLAVOR} \
+ ${PEARDIR}/HTTP/Request.php:www/pear-HTTP_Request@${PHP_FLAVOR}
+RUN_DEPENDS= ${PEARDIR}/XML/Serializer.php:devel/pear-XML_Serializer@${PHP_FLAVOR} \
+ ${PEARDIR}/HTTP/Request.php:www/pear-HTTP_Request@${PHP_FLAVOR}
USES= dos2unix pear php
USE_PHP= openssl