aboutsummaryrefslogtreecommitdiffstats
path: root/www/pear-Services_GeoNames
diff options
context:
space:
mode:
authortabthorpe <tabthorpe@FreeBSD.org>2009-01-27 05:24:56 +0800
committertabthorpe <tabthorpe@FreeBSD.org>2009-01-27 05:24:56 +0800
commit7e24236f2a94007b998dee8782ed94b1a2299378 (patch)
tree218bdb9daa0022b1675ea8b774285eaf8eabfc3e /www/pear-Services_GeoNames
parentf4ed48d17fcc8f46d7d1359430d9e20fc26b6d31 (diff)
downloadfreebsd-ports-gnome-7e24236f2a94007b998dee8782ed94b1a2299378.tar.gz
freebsd-ports-gnome-7e24236f2a94007b998dee8782ed94b1a2299378.tar.zst
freebsd-ports-gnome-7e24236f2a94007b998dee8782ed94b1a2299378.zip
Services_GeoNames is a PHP5 interface to the various webservices
offered by the GeoNames project. The GeoNames database contains over 8,000,000 geographical names corresponding to over 6,500,000 unique features. All features are categorized into one out of nine feature classes and further subcategorized into one out of 645 feature codes. Beyond names of places in various languages, data stored include latitude, longitude, elevation, population, administrative subdivision and postal codes. All coordinates use the WGS84 system (World Geodetic System 1984). Those data are accessible free of charge through a number of Web services and a daily database export. The Web services include direct and reverse geocoding,finding places through postal codes, finding places next to a given place, and finding Wikipedia articles about neighbouring places. WWW: http://pear.php.net/package/Services_GeoNames PR: ports/130935 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'www/pear-Services_GeoNames')
-rw-r--r--www/pear-Services_GeoNames/Makefile61
-rw-r--r--www/pear-Services_GeoNames/distinfo3
-rw-r--r--www/pear-Services_GeoNames/pkg-descr18
3 files changed, 82 insertions, 0 deletions
diff --git a/www/pear-Services_GeoNames/Makefile b/www/pear-Services_GeoNames/Makefile
new file mode 100644
index 000000000000..fda8389d00c0
--- /dev/null
+++ b/www/pear-Services_GeoNames/Makefile
@@ -0,0 +1,61 @@
+# Ports collection makefile for: pear-Services_GeoNames
+# Date created: 24 Jan 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Services_GeoNames
+PORTVERSION= 0.2.3
+CATEGORIES= www pear
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A PHP5 Interface to the GeoNames Public API
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
+ ${PEARDIR}/HTTP/Request2.php:${PORTSDIR}/www/pear-HTTP_Request2
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+FILES= Services/GeoNames.php Services/GeoNames/Exception.php
+EXAMPLES= examples1.php
+TESTS= AllTests.php \
+ data/test_children.dat data/test_cities.dat \
+ data/test_countrycode.dat data/test_countryinfo.dat \
+ data/test_countrysubdivision.dat data/test_earthquakes.dat \
+ data/test_findnearby.dat data/test_findnearbyplacename.dat \
+ data/test_findnearbypostalcodes.dat data/test_findnearbystreets.dat \
+ data/test_findnearbyweather.dat data/test_findnearbywikipedia.dat \
+ data/test_findnearestaddress.dat data/test_findnearestintersection.dat \
+ data/test_get.dat data/test_gtopo30.dat \
+ data/test_hierarchy.dat data/test_neighbourhood.dat \
+ data/test_neighbours.dat data/test_other_03.dat \
+ data/test_other_06.dat data/test_postalcodecountryinfo.dat \
+ data/test_postalcodelookup.dat data/test_postalcodesearch.dat \
+ data/test_search.dat data/test_siblings.dat \
+ data/test_srtm3.dat data/test_timezone.dat \
+ data/test_weather.dat data/test_weathericao.dat \
+ data/test_wikipediaboundingbox.dat data/test_wikipediasearch.dat \
+ setup.php \
+ test_children.phpt test_cities.phpt \
+ test_countrycode.phpt test_countryinfo.phpt \
+ test_countrysubdivision.phpt test_earthquakes.phpt \
+ test_findnearby.phpt test_findnearbyplacename.phpt \
+ test_findnearbypostalcodes.phpt test_findnearbystreets.phpt \
+ test_findnearbyweather.phpt test_findnearbywikipedia.phpt \
+ test_findnearestaddress.phpt test_findnearestintersection.phpt \
+ test_get.phpt test_gtopo30.phpt \
+ test_hierarchy.phpt test_neighbourhood.phpt \
+ test_neighbours.phpt test_other_01.phpt \
+ test_other_02.phpt test_other_03.phpt \
+ test_other_04.phpt test_other_05.phpt \
+ test_other_06.phpt test_other_07.phpt \
+ test_postalcodecountryinfo.phpt test_postalcodelookup.phpt \
+ test_postalcodesearch.phpt test_search.phpt \
+ test_siblings.phpt test_srtm3.phpt \
+ test_timezone.phpt test_weather.phpt \
+ test_weathericao.phpt test_wikipediaboundingbox.phpt \
+ test_wikipediasearch.phpt
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/www/pear-Services_GeoNames/distinfo b/www/pear-Services_GeoNames/distinfo
new file mode 100644
index 000000000000..1200a455e00d
--- /dev/null
+++ b/www/pear-Services_GeoNames/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/Services_GeoNames-0.2.3.tgz) = aba63e256fbb90dbacf7ea2c96a94811
+SHA256 (PEAR/Services_GeoNames-0.2.3.tgz) = 3ee2475c44b5f465344960eb4a11f0e4cb5e84b87b65826152ef25216d28ba5a
+SIZE (PEAR/Services_GeoNames-0.2.3.tgz) = 48820
diff --git a/www/pear-Services_GeoNames/pkg-descr b/www/pear-Services_GeoNames/pkg-descr
new file mode 100644
index 000000000000..f1b5c27eaabe
--- /dev/null
+++ b/www/pear-Services_GeoNames/pkg-descr
@@ -0,0 +1,18 @@
+Services_GeoNames is a PHP5 interface to the various webservices
+offered by the GeoNames project.
+
+The GeoNames database contains over 8,000,000 geographical names
+corresponding to over 6,500,000 unique features. All features are
+categorized into one out of nine feature classes and further
+subcategorized into one out of 645 feature codes. Beyond names of
+places in various languages, data stored include latitude, longitude,
+elevation, population, administrative subdivision and postal codes.
+All coordinates use the WGS84 system (World Geodetic System 1984).
+
+Those data are accessible free of charge through a number of Web
+services and a daily database export. The Web services include
+direct and reverse geocoding,finding places through postal codes,
+finding places next to a given place, and finding Wikipedia articles
+about neighbouring places.
+
+WWW: http://pear.php.net/package/Services_GeoNames