aboutsummaryrefslogtreecommitdiffstats
path: root/www/pecl-yar/Makefile
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-11-16 04:52:16 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-11-16 04:52:16 +0800
commit61ec24616b4214e052a8520cc80826cbefafce03 (patch)
tree1ad8b757f04e805b11e59683c13283b24b9e6320 /www/pecl-yar/Makefile
parent7c31114f9a5e3dc1e41cded41c03ceee2a87a205 (diff)
downloadfreebsd-ports-gnome-61ec24616b4214e052a8520cc80826cbefafce03.tar.gz
freebsd-ports-gnome-61ec24616b4214e052a8520cc80826cbefafce03.tar.zst
freebsd-ports-gnome-61ec24616b4214e052a8520cc80826cbefafce03.zip
- Add pecl-yar 1.2.0
Yar (Yet another RPC framework) is a light, concurrent RPC framework, supports multi package protocols (json, msgpack) WWW: http://pecl.php.net/package/yar PR: ports/183991 Submitted by: John Chen <johnpupu@gmail.com>
Diffstat (limited to 'www/pecl-yar/Makefile')
-rw-r--r--www/pecl-yar/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/www/pecl-yar/Makefile b/www/pecl-yar/Makefile
new file mode 100644
index 000000000000..434d74da56ed
--- /dev/null
+++ b/www/pecl-yar/Makefile
@@ -0,0 +1,31 @@
+# Created by: John Chen <johnpupu@gmail.com>
+# $FreeBSD$
+
+PORTNAME= yar
+PORTVERSION= 1.2.0
+CATEGORIES= www
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= johnpupu@gmail.com
+COMMENT= Yar (Yet another RPC framework) is a light, concurrent RPC framework
+
+LICENSE= PHP301
+
+PHP_MODNAME= yar
+USE_PHP= json curl
+USE_PHPEXT= yes
+USE_PHPIZE= yes
+USE_PHP_BUILD= yes
+
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ARGS= --with-php-config=${PREFIX}/bin/php-config
+
+OPTIONS_DEFINE= MSGPACK
+MSGPACK_DESC= Enable MSGPACK module
+MSGPACK_BUILD_DEPENDS= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/msgpack.so:${PORTSDIR}/devel/pecl-msgpack
+MSGPACK_RUN_DEPENDS= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/msgpack.so:${PORTSDIR}/devel/pecl-msgpack
+
+.include <bsd.port.mk>