aboutsummaryrefslogtreecommitdiffstats
path: root/www/phalcon
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2017-03-22 23:02:19 +0800
committervanilla <vanilla@FreeBSD.org>2017-03-22 23:02:19 +0800
commit44eb5d05434cb43845cd17b26b9bd0324489cf57 (patch)
tree7094c9db45a4e615ce824a0891f15cd1b177da0e /www/phalcon
parent04c48e33bd706fcfd1bfcc131ba214e22f0eff94 (diff)
downloadfreebsd-ports-gnome-44eb5d05434cb43845cd17b26b9bd0324489cf57.tar.gz
freebsd-ports-gnome-44eb5d05434cb43845cd17b26b9bd0324489cf57.tar.zst
freebsd-ports-gnome-44eb5d05434cb43845cd17b26b9bd0324489cf57.zip
update to 3.0.4 and fix 32 bit build on PHP 7.0
PR: 217443 Submitted by: Franco Fichtner <franco@opnsense.org> Approved by: maintainer
Diffstat (limited to 'www/phalcon')
-rw-r--r--www/phalcon/Makefile6
-rw-r--r--www/phalcon/distinfo6
-rw-r--r--www/phalcon/files/extra-patch-phalcon.zep.c31
3 files changed, 39 insertions, 4 deletions
diff --git a/www/phalcon/Makefile b/www/phalcon/Makefile
index e8203ff6ddef..f122ce03d872 100644
--- a/www/phalcon/Makefile
+++ b/www/phalcon/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= phalcon
-PORTVERSION= 3.0.3
+PORTVERSION= 3.0.4
DISTVERSIONPREFIX= v
CATEGORIES= www
@@ -28,4 +28,8 @@ CONFIGURE_ARGS= --enable-phalcon
PBITS= ${ARCH:S/amd64/64/:S/armv6/32/:S/i386/32/:S/x86_64/64/}
WRKSRC_SUBDIR= build/php${PHP_VER:C/.$//}/${PBITS}bits
+.if ${PHP_VER} == 70 && ${PBITS} == 32
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-phalcon.zep.c
+.endif
+
.include <bsd.port.post.mk>
diff --git a/www/phalcon/distinfo b/www/phalcon/distinfo
index d3cc2a46ad20..2e58302125f0 100644
--- a/www/phalcon/distinfo
+++ b/www/phalcon/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1482903422
-SHA256 (phalcon-cphalcon-v3.0.3_GH0.tar.gz) = b3b5a2408b9eed5f440bf8fcb89b18da255ddc6ed1d90e585aa70975c258699c
-SIZE (phalcon-cphalcon-v3.0.3_GH0.tar.gz) = 6371473
+TIMESTAMP = 1487668442
+SHA256 (phalcon-cphalcon-v3.0.4_GH0.tar.gz) = 50834275cd964a5d1fdd7a588183ca4e038a46900045a6cf91f50b56664d15cd
+SIZE (phalcon-cphalcon-v3.0.4_GH0.tar.gz) = 6407812
diff --git a/www/phalcon/files/extra-patch-phalcon.zep.c b/www/phalcon/files/extra-patch-phalcon.zep.c
new file mode 100644
index 000000000000..f7fcb2c74700
--- /dev/null
+++ b/www/phalcon/files/extra-patch-phalcon.zep.c
@@ -0,0 +1,31 @@
+--- phalcon.zep.c.orig 2016-11-26 21:03:16 UTC
++++ phalcon.zep.c
+@@ -2114,8 +2114,8 @@ static int ZEPHIR_FASTCALL zephir_memory
+ #define ZEPHIR_MM_RESTORE() zephir_memory_restore_stack(NULL)
+
+ #else
+-static void ZEPHIR_FASTCALL zephir_memory_grow_stack();
+-static int ZEPHIR_FASTCALL zephir_memory_restore_stack();
++static void zephir_memory_grow_stack();
++static int zephir_memory_restore_stack();
+
+ #define ZEPHIR_MM_GROW() zephir_memory_grow_stack()
+ #define ZEPHIR_MM_RESTORE() zephir_memory_restore_stack()
+@@ -4212,7 +4212,7 @@ static void ZEPHIR_FASTCALL zephir_memor
+
+ #else
+
+-static void ZEPHIR_FASTCALL zephir_memory_grow_stack()
++static void zephir_memory_grow_stack()
+ {
+ zend_zephir_globals_def *g = ZEPHIR_VGLOBAL;
+ if (g->start_memory == NULL) {
+@@ -4221,7 +4221,7 @@ static void ZEPHIR_FASTCALL zephir_memor
+ zephir_memory_grow_stack_common(g);
+ }
+
+-static int ZEPHIR_FASTCALL zephir_memory_restore_stack()
++static int zephir_memory_restore_stack()
+ {
+ zephir_memory_restore_stack_common(ZEPHIR_VGLOBAL);
+ return SUCCESS;