aboutsummaryrefslogtreecommitdiffstats
path: root/www/php-plurk-api
diff options
context:
space:
mode:
authorglarkin <glarkin@FreeBSD.org>2010-04-16 01:48:25 +0800
committerglarkin <glarkin@FreeBSD.org>2010-04-16 01:48:25 +0800
commit02fe2b0f9a9855e04cd188e34de980a06bba6dec (patch)
treefd4d5761f808a8743f288d8fcd1803e7d4c5bba8 /www/php-plurk-api
parent9a0c8e1310ce37d900e54c02092ff46d046ff0eb (diff)
downloadfreebsd-ports-gnome-02fe2b0f9a9855e04cd188e34de980a06bba6dec.tar.gz
freebsd-ports-gnome-02fe2b0f9a9855e04cd188e34de980a06bba6dec.tar.zst
freebsd-ports-gnome-02fe2b0f9a9855e04cd188e34de980a06bba6dec.zip
Plurk is a popular Internet service, and many applications are
designed for Plurk, including mobile and desktop applications. This is the PHP Plurk API client for interacting with the Plurk Internet service. WWW: http://code.google.com/p/php-plurk-api/ PR: ports/144308 Submitted by: Bo-Yi Wu <appleboy.tw at gmail.com>
Diffstat (limited to 'www/php-plurk-api')
-rw-r--r--www/php-plurk-api/Makefile48
-rw-r--r--www/php-plurk-api/distinfo3
-rw-r--r--www/php-plurk-api/files/pkg-message.in35
-rw-r--r--www/php-plurk-api/pkg-descr7
-rw-r--r--www/php-plurk-api/pkg-plist84
5 files changed, 177 insertions, 0 deletions
diff --git a/www/php-plurk-api/Makefile b/www/php-plurk-api/Makefile
new file mode 100644
index 000000000000..d8cad424e095
--- /dev/null
+++ b/www/php-plurk-api/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: php-plurk-api
+# Date created: 2010-02-26
+# Whom: Bo-Yi Wu <appleboy.tw@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= php-plurk-api
+PORTVERSION= 1.4.2
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+DISTNAME= php-plurk-api-${PORTVERSION}
+
+MAINTAINER= appleboy.tw@gmail.com
+COMMENT= A Plurk API Implementation with PHP
+
+USE_ZIP= yes
+NO_BUILD= yes
+USE_PHP= json curl
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+SUB_LIST+= PKGNAME=${PKGNAME}
+SUB_FILES= pkg-message
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ @${MV} ${WRKSRC}\ ${PORTVERSION} ${WRKSRC}
+ @${ECHO_CMD} '@exec ${MV} ${WRKSRC}\ ${PORTVERSION} \
+ ${WRKSRC}' >> ${TMPPLIST}
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${WWWDIR}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
+ @${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} \
+ ${PHPBBDIR:S|^${PREFIX}/|%D/|}' >> ${TMPPLIST}
+ @${FIND} ${WWWDIR} -type f -print0 | ${XARGS} -0 ${CHMOD} 644
+ @${ECHO_CMD} '@exec ${FIND} ${WWWDIR} -type f -print0 | \
+ ${XARGS} -0 ${CHMOD} 644' >> ${TMPPLIST}
+ @${FIND} ${WWWDIR} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
+ @${ECHO_CMD} '@exec ${FIND} ${WWWDIR} -type d -print0 | \
+ ${XARGS} -0 ${CHMOD} 755' >> ${TMPPLIST}
+ @${CHMOD} 755 ${WWWDIR}/example.php
+ @${ECHO_CMD} '@exec ${CHMOD} 755 ${WWWDIR}/example.php' >> ${TMPPLIST}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/php-plurk-api/distinfo b/www/php-plurk-api/distinfo
new file mode 100644
index 000000000000..7b70f33bd87d
--- /dev/null
+++ b/www/php-plurk-api/distinfo
@@ -0,0 +1,3 @@
+MD5 (php-plurk-api-1.4.2.zip) = c37eb035eadec308bd98a4d1389fe22c
+SHA256 (php-plurk-api-1.4.2.zip) = 8963369dcaa906c0c5dbb34aa639ccad5dc854d3c14ee6e3afdcd4331f6d6aaf
+SIZE (php-plurk-api-1.4.2.zip) = 103552
diff --git a/www/php-plurk-api/files/pkg-message.in b/www/php-plurk-api/files/pkg-message.in
new file mode 100644
index 000000000000..11a819344c7e
--- /dev/null
+++ b/www/php-plurk-api/files/pkg-message.in
@@ -0,0 +1,35 @@
+
+**********************************************
+Plurk API provides a standard way of accessing
+and implementing applications on top of the Plurk
+platform. The API is a simple HTTP API that can be
+accessed from any language that supports creation
+of HTTP requests.
+
+The API returns JSON encoded data. You should use
+a JSON library to decode the data returned. Some
+good JSON libraries are simplejson (Python),
+JSON.simple (Java) or json (Ruby) or json (PHP).
+
+The current limit is 50.000 calls pr. day. If you
+need more than this contact us with a description
+of what you are making.
+
+
+%%PKGNAME%% has been installed into :
+
+ %%WWWDIR%%
+
+php-plurk-api is a Plurk API Client implementation with PHP.
+
+ the API Official Website:
+ http://www.plurk.com/API
+
+ Code Repository:
+ https://code.google.com/p/php-plurk-api/
+
+ php-plurk-api online documents:
+ http://plurk.lab3.tw/docs/
+
+**********************************************
+
diff --git a/www/php-plurk-api/pkg-descr b/www/php-plurk-api/pkg-descr
new file mode 100644
index 000000000000..84829480128e
--- /dev/null
+++ b/www/php-plurk-api/pkg-descr
@@ -0,0 +1,7 @@
+Plurk is a popular Internet service, and many applications are
+designed for Plurk, including mobile and desktop applications.
+
+This is the PHP Plurk API client for interacting with the Plurk
+Internet service.
+
+WWW: http://code.google.com/p/php-plurk-api/
diff --git a/www/php-plurk-api/pkg-plist b/www/php-plurk-api/pkg-plist
new file mode 100644
index 000000000000..a59f63da0bea
--- /dev/null
+++ b/www/php-plurk-api/pkg-plist
@@ -0,0 +1,84 @@
+%%WWWDIR%%/ChangeLog
+%%WWWDIR%%/README
+%%WWWDIR%%/common.php
+%%WWWDIR%%/config.php
+%%WWWDIR%%/constant.php
+%%WWWDIR%%/cookie
+%%WWWDIR%%/documents/blank.html
+%%WWWDIR%%/documents/classtrees_php-plurk-api.html
+%%WWWDIR%%/documents/elementindex.html
+%%WWWDIR%%/documents/elementindex_php-plurk-api.html
+%%WWWDIR%%/documents/errors.html
+%%WWWDIR%%/documents/index.html
+%%WWWDIR%%/documents/li_php-plurk-api.html
+%%WWWDIR%%/documents/media/banner.css
+%%WWWDIR%%/documents/media/images/AbstractClass.png
+%%WWWDIR%%/documents/media/images/AbstractClass_logo.png
+%%WWWDIR%%/documents/media/images/AbstractMethod.png
+%%WWWDIR%%/documents/media/images/AbstractPrivateClass.png
+%%WWWDIR%%/documents/media/images/AbstractPrivateClass_logo.png
+%%WWWDIR%%/documents/media/images/AbstractPrivateMethod.png
+%%WWWDIR%%/documents/media/images/Class.png
+%%WWWDIR%%/documents/media/images/Class_logo.png
+%%WWWDIR%%/documents/media/images/Constant.png
+%%WWWDIR%%/documents/media/images/Constructor.png
+%%WWWDIR%%/documents/media/images/Destructor.png
+%%WWWDIR%%/documents/media/images/Function.png
+%%WWWDIR%%/documents/media/images/Global.png
+%%WWWDIR%%/documents/media/images/I.png
+%%WWWDIR%%/documents/media/images/Index.png
+%%WWWDIR%%/documents/media/images/Interface.png
+%%WWWDIR%%/documents/media/images/Interface_logo.png
+%%WWWDIR%%/documents/media/images/L.png
+%%WWWDIR%%/documents/media/images/Lminus.png
+%%WWWDIR%%/documents/media/images/Lplus.png
+%%WWWDIR%%/documents/media/images/Method.png
+%%WWWDIR%%/documents/media/images/Page.png
+%%WWWDIR%%/documents/media/images/Page_logo.png
+%%WWWDIR%%/documents/media/images/PrivateClass.png
+%%WWWDIR%%/documents/media/images/PrivateClass_logo.png
+%%WWWDIR%%/documents/media/images/PrivateMethod.png
+%%WWWDIR%%/documents/media/images/PrivateVariable.png
+%%WWWDIR%%/documents/media/images/StaticMethod.png
+%%WWWDIR%%/documents/media/images/StaticVariable.png
+%%WWWDIR%%/documents/media/images/T.png
+%%WWWDIR%%/documents/media/images/Tminus.png
+%%WWWDIR%%/documents/media/images/Tplus.png
+%%WWWDIR%%/documents/media/images/Variable.png
+%%WWWDIR%%/documents/media/images/blank.png
+%%WWWDIR%%/documents/media/images/class_folder.png
+%%WWWDIR%%/documents/media/images/empty.png
+%%WWWDIR%%/documents/media/images/file.png
+%%WWWDIR%%/documents/media/images/folder.png
+%%WWWDIR%%/documents/media/images/function_folder.png
+%%WWWDIR%%/documents/media/images/next_button.png
+%%WWWDIR%%/documents/media/images/next_button_disabled.png
+%%WWWDIR%%/documents/media/images/package.png
+%%WWWDIR%%/documents/media/images/package_folder.png
+%%WWWDIR%%/documents/media/images/previous_button.png
+%%WWWDIR%%/documents/media/images/previous_button_disabled.png
+%%WWWDIR%%/documents/media/images/private_class_logo.png
+%%WWWDIR%%/documents/media/images/tutorial.png
+%%WWWDIR%%/documents/media/images/tutorial_folder.png
+%%WWWDIR%%/documents/media/images/up_button.png
+%%WWWDIR%%/documents/media/stylesheet.css
+%%WWWDIR%%/documents/packages.html
+%%WWWDIR%%/documents/php-plurk-api/_common.php.html
+%%WWWDIR%%/documents/php-plurk-api/_config.php.html
+%%WWWDIR%%/documents/php-plurk-api/_constant.php.html
+%%WWWDIR%%/documents/php-plurk-api/_example.php.html
+%%WWWDIR%%/documents/php-plurk-api/_plurk_api.php.html
+%%WWWDIR%%/documents/php-plurk-api/common.html
+%%WWWDIR%%/documents/php-plurk-api/plurk_api.html
+%%WWWDIR%%/documents/ric_ChangeLog.html
+%%WWWDIR%%/documents/ric_README.html
+%%WWWDIR%%/documents/todolist.html
+%%WWWDIR%%/example.php
+%%WWWDIR%%/log
+%%WWWDIR%%/plurk_api.php
+@dirrm %%WWWDIR%%/documents/php-plurk-api
+@dirrm %%WWWDIR%%/documents/media/images
+@dirrm %%WWWDIR%%/documents/media
+@dirrm %%WWWDIR%%/documents/default
+@dirrm %%WWWDIR%%/documents
+@dirrmtry %%WWWDIR%%