aboutsummaryrefslogtreecommitdiffstats
path: root/www/phpbb/Makefile
diff options
context:
space:
mode:
authorwjv <wjv@FreeBSD.org>2002-10-30 03:54:47 +0800
committerwjv <wjv@FreeBSD.org>2002-10-30 03:54:47 +0800
commitfed69fe9e567d36bcfab122d2fffcb56d73bedee (patch)
treefed949377922ff1179a98961a1102acf8dc43bdd /www/phpbb/Makefile
parent187cdc9e6fde03b6832085c7a4e7c56f32c88a3b (diff)
downloadfreebsd-ports-gnome-fed69fe9e567d36bcfab122d2fffcb56d73bedee.tar.gz
freebsd-ports-gnome-fed69fe9e567d36bcfab122d2fffcb56d73bedee.tar.zst
freebsd-ports-gnome-fed69fe9e567d36bcfab122d2fffcb56d73bedee.zip
- Update to version 2.0.3
- Use $TAR rather than cpio(1) to install - $PERL -> $REINPLACE_CMD - Install contributed code under $DATADIR - Numerous small fixes
Diffstat (limited to 'www/phpbb/Makefile')
-rw-r--r--www/phpbb/Makefile61
1 files changed, 33 insertions, 28 deletions
diff --git a/www/phpbb/Makefile b/www/phpbb/Makefile
index ac5a581e3e92..e91192c7935c 100644
--- a/www/phpbb/Makefile
+++ b/www/phpbb/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= phpbb
-PORTVERSION= 2.0.0
-PORTREVISION= 1
+PORTVERSION= 2.0.3
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -20,23 +19,30 @@ RUN_DEPENDS= ${LOCALBASE}/lib/php/System.php:${PORTSDIR}/www/mod_php4
# The phpBB2 port supports a number of variables that may be tweaked at build
# time. Perform a "make options" to see more information on these variables.
#
+WWWDOCROOT?= www/data
+PHPBBURL?= phpBB2
+WWWOWN?= www
+WWWGRP?= www
+#
+# End of user-configurable variables.
+
+# Set/override/append to variables from bsd.port.mk:
+#
WRKSRC= ${WRKDIR}/phpBB2
NO_BUILD= yes
-CPIO= cpio --quiet -pdum -R
-WWWDOCROOT= www/data
-PHPBBURL= phpBB2
-PHPBBDIR= ${WWWDOCROOT}/${PHPBBURL}
-WWWOWN= www
-WWWGRP= www
+USE_REINPLACE= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
+PLIST_SUB+= PHPBBDIR=${PHPBBDIR} WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
+
+# Set custom variables:
+#
+PHPBBDIR= ${WWWDOCROOT}/${PHPBBURL}
PKGOPTS= ${FILESDIR}/pkg-opts
-PLIST_SUB+= PHPBBDIR=${PHPBBDIR} WWWOWN=${WWWOWN}
-EXCEPTFILES= install.php upgrade.php update_to_FINAL.php
+EXCEPTFILES= install.php upgrade.php update_to_${PORTVERSION:S/.//g}.php
options:
@ ${ECHO_MSG} "===> Build options for ${PKGNAME}:"
- @ ${PERL} -ne '/^#/ || /^\s/ && print || \
- print sprintf "* %s [%s]\n %s", split(/\|/)' ${PKGOPTS}
+ @ ${CAT} ${PKGOPTS}
post-extract:
.if !defined(BATCH)
@@ -47,36 +53,35 @@ post-extract:
.endif
post-patch:
- @ ${PERL} -pi.orig -e "s#\.\./templates#/${PHPBBURL}/templates#" \
+ @ ${REINPLACE_CMD} -e "s#\.\./templates#/${PHPBBURL}/templates#" \
${WRKSRC}/docs/*.html
post-configure:
- @ ${SED} -e 's#%%PREFIX%%#${PREFIX}#g' \
- -e 's#%%DOCSDIR%%#${DOCSDIR}#g' \
- -e 's#%%PHPBBURL%%#${PHPBBURL}#g' \
- -e 's#%%PHPBBDIR%%#${PHPBBDIR}#g' pkg-message > \
- ${PKGMESSAGE}
+ @ ${SED} \
+ -e 's#%%PREFIX%%#${PREFIX}#g' -e 's#%%DOCSDIR%%#${DOCSDIR}#g' \
+ -e 's#%%PHPBBURL%%#${PHPBBURL}#g' -e 's#%%PHPBBDIR%%#${PHPBBDIR}#g' \
+ -e 's#%%DATADIR%%#${DATADIR}#g' \
+ -e 's#%%DELETEFILES%%#${EXCEPTFILES}#g' pkg-message > ${PKGMESSAGE}
do-install:
@ ${MKDIR} -m 0775 ${PREFIX}/${PHPBBDIR}
- @ ${CHOWN} ${WWWOWN}:${WWWGRP} ${PREFIX}/${PHPBBDIR}
- @ cd ${WRKSRC} && find * \( -name config.php \
- ${EXCEPTFILES:S/^/-o -name /} -o -name docs -a -prune \) \
- -o -print | ${CPIO} ${WWWOWN}:${WWWGRP} ${PREFIX}/${PHPBBDIR}
+ @ cd ${WRKSRC} && ${FIND} * \( -name config.php \
+ ${EXCEPTFILES:S/^/-o -name /} \
+ -o -name docs -a -prune -o -name contrib -a -prune \) -o -print \
+ | ${TAR} cTf - - | ${TAR} xUCf ${PREFIX}/${PHPBBDIR} -
@ ${TOUCH} ${PREFIX}/${PHPBBDIR}/config.php
- @ ${CHOWN} ${WWWOWN}:${WWWGRP} ${PREFIX}/${PHPBBDIR}/config.php
- @ ${MKDIR} ${DATADIR}
+ @ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${PHPBBDIR}
+ @ ${MKDIR} ${DATADIR}/contrib
@ cd ${WRKSRC} && ${INSTALL_DATA} ${EXCEPTFILES} ${DATADIR}
+ @ cd ${WRKSRC}/contrib && ${INSTALL_DATA} * ${DATADIR}/contrib
post-install:
@ cd ${DATADIR} && ${INSTALL} -c -o ${WWWOWN} -g ${WWWGRP} \
${EXCEPTFILES} ${PREFIX}/${PHPBBDIR}
.if !defined(NOPORTOCS)
@ ${MKDIR} ${DOCSDIR}
-.for docfile in AUTHORS FAQ.html INSTALL.html README.html \
- coding-guidelines.txt codingstandards.htm
- @ ${INSTALL_DATA} ${WRKSRC}/docs/${docfile} ${DOCSDIR}
-.endfor
+ @ cd ${WRKSRC}/docs && ${FIND} * -type f -maxdepth 0 \! -name \*.bak \
+ \! -name COPYING -exec ${INSTALL_DATA} {} ${DOCSDIR} \;
.if !defined(BATCH)
@ ${CAT} ${PKGMESSAGE}
.endif