aboutsummaryrefslogtreecommitdiffstats
path: root/www/phpmustache
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2013-07-23 02:55:37 +0800
committermarino <marino@FreeBSD.org>2013-07-23 02:55:37 +0800
commit055001df4200fcfa6127aaf515edb8a77e6ef735 (patch)
treeb2ff7c5eb3383ced90c9acab0acdb12162013a88 /www/phpmustache
parentefeed12e7043e4fd10154fe1d224433e442e1e83 (diff)
downloadfreebsd-ports-gnome-055001df4200fcfa6127aaf515edb8a77e6ef735.tar.gz
freebsd-ports-gnome-055001df4200fcfa6127aaf515edb8a77e6ef735.tar.zst
freebsd-ports-gnome-055001df4200fcfa6127aaf515edb8a77e6ef735.zip
www/phpmustache: Unbreak fetch and update to version 2.4.0
This port had some sort of broken roll-your-own github fetch support. It could have been easily corrected for the current version 0.8.1, but that was 11 releases ago! So in addition to fixing the fetch, the port was updated to the latest release v2.4.0. The port now requires PHP to build. It always required PHP as a run depends but this was previously omitted. The MIT license was moved to the built-in license handling, and the documentation was eliminated because it is in unreadable markdown format. The test files were also eliminated because it doesn't appear to be meant for users. The examples were kept and augmented. The name of the main class file changed from "Mustache.php" to "mustache.php" but gets installed to the same location. PR: ports/179961 Approved by: bapt (mentor), maintainer timeout (~4 weeks)
Diffstat (limited to 'www/phpmustache')
-rw-r--r--www/phpmustache/Makefile46
-rw-r--r--www/phpmustache/distinfo4
-rw-r--r--www/phpmustache/pkg-plist55
3 files changed, 31 insertions, 74 deletions
diff --git a/www/phpmustache/Makefile b/www/phpmustache/Makefile
index 23494aa691b3..9cbf719c3dc3 100644
--- a/www/phpmustache/Makefile
+++ b/www/phpmustache/Makefile
@@ -1,48 +1,36 @@
-# New ports collection makefile for: phpmustache
-# Date created: 25 October 2011
-# Whom: Steve Polyack <spolyack@collaborativefusion.com>
-#
+# Created by: Steve Polyack <spolyack@collaborativefusion.com>
# $FreeBSD$
-#
PORTNAME= phpmustache
-PORTVERSION= 0.8.1
+PORTVERSION= 2.4.0
CATEGORIES= www
-MASTER_SITES= https://github.com/bobthecow/mustache.php/tarball/master/
-DISTNAME= bobthecow-mustache.php-v${PORTVERSION}-0-g${GITVERSION}
+MASTER_SITES= GH
MAINTAINER= spolyack@collaborativefusion.com
COMMENT= PHP5 code for Mustache
-GITVERSION= 1e23df0
-FETCH_ARGS= -pRr
-WRKSRC= ${WRKDIR}/bobthecow-mustache.php-${GITVERSION}
+LICENSE= MIT
-NO_BUILD= yes
+USE_GITHUB= yes
+GH_ACCOUNT= bobthecow
+GH_PROJECT= mustache.php
+GH_TAGNAME= v2.4.0
+GH_COMMIT= 8433da6
+
+USE_PHP= yes
+USE_PHP_BUILD= yes
SUB_FILES= pkg-message
+do-build:
+ @${WRKSRC}/bin/build_bootstrap.php
+
do-install:
@${MKDIR} ${DATADIR}
- @${INSTALL_DATA} ${WRKSRC}/Mustache.php ${DATADIR}
- @${MKDIR} ${DATADIR}/test
- @${INSTALL_DATA} ${WRKSRC}/test/*.php ${WRKSRC}/test/phpunit.xml ${DATADIR}/test
- @${MKDIR} ${DATADIR}/test/lib/yaml/doc ${DATADIR}/test/lib/yaml/lib
-.for f in README.markdown LICENSE package.xml
- @${INSTALL_DATA} ${WRKSRC}/test/lib/yaml/$f ${DATADIR}/test/lib/yaml
-.endfor
- @${INSTALL_DATA} ${WRKSRC}/test/lib/yaml/lib/* ${DATADIR}/test/lib/yaml/lib
- @${INSTALL_DATA} ${WRKSRC}/test/lib/yaml/doc/* ${DATADIR}/test/lib/yaml/doc
- @${MKDIR} ${DATADIR}/test/spec
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for f in README.markdown LICENSE
- @${INSTALL_DATA} ${WRKSRC}/$f ${DOCSDIR}
-.endfor
-.endif
+ @${INSTALL_DATA} ${WRKSRC}/mustache.php ${DATADIR}
.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
- @${CP} -R ${WRKSRC}/examples/* ${EXAMPLESDIR}
+ @${CP} -R ${WRKSRC}/test/fixtures/examples/* ${EXAMPLESDIR}
.endif
post-install:
diff --git a/www/phpmustache/distinfo b/www/phpmustache/distinfo
index 430c7f25abca..64f974fc64ef 100644
--- a/www/phpmustache/distinfo
+++ b/www/phpmustache/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bobthecow-mustache.php-v0.8.1-0-g1e23df0.tar.gz) = 9111025ef0fa8b1412436ee26fc8715726399da16c57a69e29fb4927c42ede1c
-SIZE (bobthecow-mustache.php-v0.8.1-0-g1e23df0.tar.gz) = 41364
+SHA256 (phpmustache-2.4.0.tar.gz) = 132439e9fa7a9cf23b0329049c707312848c066e7842c6e892af1c3a02fe341d
+SIZE (phpmustache-2.4.0.tar.gz) = 44139
diff --git a/www/phpmustache/pkg-plist b/www/phpmustache/pkg-plist
index f93aa6c57d32..9ef6c65d9ad3 100644
--- a/www/phpmustache/pkg-plist
+++ b/www/phpmustache/pkg-plist
@@ -1,6 +1,4 @@
-%%DATADIR%%/Mustache.php
-%%PORTDOCS%%%%DOCSDIR%%/README.markdown
-%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%DATADIR%%/mustache.php
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/child_context/ChildContext.php
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/child_context/child_context.mustache
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/child_context/child_context.txt
@@ -25,6 +23,9 @@
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/grand_parent_context/GrandParentContext.php
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/grand_parent_context/grand_parent_context.mustache
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/grand_parent_context/grand_parent_context.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/i18n/I18n.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/i18n/i18n.mustache
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/i18n/i18n.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/implicit_iterator/ImplicitIterator.php
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/implicit_iterator/implicit_iterator.mustache
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/implicit_iterator/implicit_iterator.txt
@@ -34,18 +35,11 @@
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/inverted_section/InvertedSection.php
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/inverted_section/inverted_section.mustache
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/inverted_section/inverted_section.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/partials/partials/header.mustache
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/partials/Partials.php
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/partials/partials.mustache
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/partials/partials.txt
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/partials_with_view_class/PartialsWithViewClass.php
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/partials_with_view_class/partials_with_view_class.mustache
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/partials_with_view_class/partials_with_view_class.txt
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pragma_unescaped/PragmaUnescaped.php
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pragma_unescaped/pragma_unescaped.mustache
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pragma_unescaped/pragma_unescaped.txt
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pragmas_in_partials/PragmasInPartials.php
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pragmas_in_partials/pragmas_in_partials.mustache
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pragmas_in_partials/pragmas_in_partials.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/recursive_partials/partials/child.mustache
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/recursive_partials/RecursivePartials.php
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/recursive_partials/recursive_partials.mustache
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/recursive_partials/recursive_partials.txt
@@ -76,36 +70,10 @@
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/utf8_unescaped/UTF8Unescaped.php
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/utf8_unescaped/utf8_unescaped.mustache
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/utf8_unescaped/utf8_unescaped.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/whitespace/partials/alphabet.mustache
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/whitespace/Whitespace.php
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/whitespace/whitespace.mustache
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/whitespace/whitespace.txt
-%%DATADIR%%/test/MustacheExceptionTest.php
-%%DATADIR%%/test/MustacheHigherOrderSectionsTest.php
-%%DATADIR%%/test/MustacheInjectionTest.php
-%%DATADIR%%/test/MustacheObjectSectionTest.php
-%%DATADIR%%/test/MustachePragmaTest.php
-%%DATADIR%%/test/MustachePragmaUnescapedTest.php
-%%DATADIR%%/test/MustacheSpecTest.php
-%%DATADIR%%/test/MustacheTest.php
-%%DATADIR%%/test/lib/yaml/LICENSE
-%%DATADIR%%/test/lib/yaml/README.markdown
-%%DATADIR%%/test/lib/yaml/doc/00-Introduction.markdown
-%%DATADIR%%/test/lib/yaml/doc/01-Usage.markdown
-%%DATADIR%%/test/lib/yaml/doc/02-YAML.markdown
-%%DATADIR%%/test/lib/yaml/doc/A-License.markdown
-%%DATADIR%%/test/lib/yaml/lib/sfYaml.php
-%%DATADIR%%/test/lib/yaml/lib/sfYamlDumper.php
-%%DATADIR%%/test/lib/yaml/lib/sfYamlInline.php
-%%DATADIR%%/test/lib/yaml/lib/sfYamlParser.php
-%%DATADIR%%/test/lib/yaml/package.xml
-%%DATADIR%%/test/phpunit.xml
-@dirrm %%DATADIR%%/test/lib/yaml/doc
-@dirrm %%DATADIR%%/test/lib/yaml/lib
-@dirrm %%DATADIR%%/test/lib/yaml
-@dirrm %%DATADIR%%/test/lib
-@dirrm %%DATADIR%%/test/spec
-@dirrm %%DATADIR%%/test
-@dirrm %%DATADIR%%
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/child_context
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/comments
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/complex
@@ -114,13 +82,13 @@
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/double_section
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/escaped
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/grand_parent_context
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/i18n
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/implicit_iterator
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/inverted_double_section
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/inverted_section
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/partials/partials
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/partials
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/partials_with_view_class
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/pragma_unescaped
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/pragmas_in_partials
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/recursive_partials/partials
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/recursive_partials
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/section_iterator_objects
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/section_magic_objects
@@ -131,6 +99,7 @@
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/unescaped
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/utf8
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/utf8_unescaped
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/whitespace/partials
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/whitespace
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%