aboutsummaryrefslogtreecommitdiffstats
path: root/www/phpsysinfo
diff options
context:
space:
mode:
authorshaun <shaun@FreeBSD.org>2007-02-01 05:38:39 +0800
committershaun <shaun@FreeBSD.org>2007-02-01 05:38:39 +0800
commitc472fcb9f51c0a088876f24fc83161dd7e154b9d (patch)
treee6e9df223d4d54009cdad8eaae542769fd90592b /www/phpsysinfo
parent34e8381637602209ad02680fb4db07c3aa06e575 (diff)
downloadfreebsd-ports-gnome-c472fcb9f51c0a088876f24fc83161dd7e154b9d.tar.gz
freebsd-ports-gnome-c472fcb9f51c0a088876f24fc83161dd7e154b9d.tar.zst
freebsd-ports-gnome-c472fcb9f51c0a088876f24fc83161dd7e154b9d.zip
A bug present in PHP 5.2.0 causes a segfault in phpSysInfo; add a patch
that works around this. Submitted by: Zoltan Frombach Obtained from: http://sourceforge.net/forum/forum.php?thread_id=1656641&forum_id=10
Diffstat (limited to 'www/phpsysinfo')
-rw-r--r--www/phpsysinfo/Makefile1
-rw-r--r--www/phpsysinfo/files/patch-pre5.2.1-segfault.diff11
2 files changed, 12 insertions, 0 deletions
diff --git a/www/phpsysinfo/Makefile b/www/phpsysinfo/Makefile
index 78cd63827633..cdfb91e3c9ea 100644
--- a/www/phpsysinfo/Makefile
+++ b/www/phpsysinfo/Makefile
@@ -6,6 +6,7 @@
PORTNAME= phpSysInfo
PORTVERSION= 2.5.2
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME:L}
diff --git a/www/phpsysinfo/files/patch-pre5.2.1-segfault.diff b/www/phpsysinfo/files/patch-pre5.2.1-segfault.diff
new file mode 100644
index 000000000000..f3282fd26c3e
--- /dev/null
+++ b/www/phpsysinfo/files/patch-pre5.2.1-segfault.diff
@@ -0,0 +1,11 @@
+--- includes/xml/filesystems.php.orig
++++ includes/xml/filesystems.php
+@@ -85,7 +85,7 @@
+ . " <td align=\"" . $textdir['right'] . "\" valign=\"top\"><font size=\"-1\"><b>" . $text['size'] . "</b></font></td>\n </tr>\n";
+ for( $i = 1, $max = sizeof( $XPath->getDataParts( "/phpsysinfo/FileSystem" ) ); $i < $max; $i++ ) {
+ if( $XPath->match( "/phpsysinfo/FileSystem/Mount[" . $i . "]/MountPointID" ) ) {
+- if( ! $XPath->match( "/phpsysinfo/FileSystem/Mount[" . $i . "]/Options" ) || ! stristr( $XPath->getData( "/phpsysinfo/FileSystem/Mount[" . $i . "]/Options" ), "bind" ) ) {
++ if( ! $XPath->match( "/phpsysinfo/FileSystem/Mount[" . $i . "]/Options" ) ) {
+ if( ! in_array( $XPath->getData( "/phpsysinfo/FileSystem/Mount[" . $i . "]/Device/Name" ), $arrCounteddevlist ) ) {
+ $arrSum['size'] += $XPath->getData( "/phpsysinfo/FileSystem/Mount[" . $i . "]/Size" );
+ $arrSum['used'] += $XPath->getData( "/phpsysinfo/FileSystem/Mount[" . $i . "]/Used" );