aboutsummaryrefslogtreecommitdiffstats
path: root/www/plone
diff options
context:
space:
mode:
authoralexbl <alexbl@FreeBSD.org>2007-07-30 17:42:28 +0800
committeralexbl <alexbl@FreeBSD.org>2007-07-30 17:42:28 +0800
commit7d749db4cf14f30613e9a53a08ffa3d3b4575146 (patch)
treead9062005432bbf28f5cce4ad3a1cd32a59dba69 /www/plone
parent8e2da239f74a82ad1c98b69bd27abb3f4e40ecf3 (diff)
downloadfreebsd-ports-gnome-7d749db4cf14f30613e9a53a08ffa3d3b4575146.tar.gz
freebsd-ports-gnome-7d749db4cf14f30613e9a53a08ffa3d3b4575146.tar.zst
freebsd-ports-gnome-7d749db4cf14f30613e9a53a08ffa3d3b4575146.zip
- Make Python 2.5.1 the default Python version
- Add significantly better support in bsd.python.mk for working with Python Eggs and the easy_install system Tested by: pointyhat runs Approved by: pav (portmgr) Most work by: perky Thanks to: pav
Diffstat (limited to 'www/plone')
-rw-r--r--www/plone/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/www/plone/Makefile b/www/plone/Makefile
index 2c14b212c33b..c31cdee6ec9d 100644
--- a/www/plone/Makefile
+++ b/www/plone/Makefile
@@ -77,4 +77,10 @@ post-install:
@${CAT} ${PKGMESSAGE}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_VERSION} != ${PYTHON_DEFAULT_VERSION} && defined(PACKAGE_BUILDING)
+IGNORE= can't be built: the default Python version should be ${PYTHON_VERSION} in order to build a package in the build cluster
+.endif
+
+.include <bsd.port.post.mk>