aboutsummaryrefslogtreecommitdiffstats
path: root/www/pound
diff options
context:
space:
mode:
authormux <mux@FreeBSD.org>2007-10-09 22:58:18 +0800
committermux <mux@FreeBSD.org>2007-10-09 22:58:18 +0800
commit69456fe55f14f299ebc0b6e5cdf6c335eec79fbb (patch)
tree756e698c5eca8227d447a22bd4c00cda21418b04 /www/pound
parentc62d21be8537a9c57ab0ddcb4584ecf2f8914469 (diff)
downloadfreebsd-ports-gnome-69456fe55f14f299ebc0b6e5cdf6c335eec79fbb.tar.gz
freebsd-ports-gnome-69456fe55f14f299ebc0b6e5cdf6c335eec79fbb.tar.zst
freebsd-ports-gnome-69456fe55f14f299ebc0b6e5cdf6c335eec79fbb.zip
Add two new OPTIONS to this port:
- The PCRE option allows one to link pound against libpcre for the regcomp() and regexec() functions instead of libc. This can make a substantial difference in CPU consumption with some workloads. Defaults to off. - The LIBTHR option links pound against the libthr for threading, instead of libpthread. This makes a *huge* difference when you deal with enough traffic. Defaults to on. Bump PORTREVISION. Approved by: anders (maintainer)
Diffstat (limited to 'www/pound')
-rw-r--r--www/pound/Makefile25
1 files changed, 22 insertions, 3 deletions
diff --git a/www/pound/Makefile b/www/pound/Makefile
index 9606bc8c760a..1d655dab1a3a 100644
--- a/www/pound/Makefile
+++ b/www/pound/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pound
PORTVERSION= 2.3.2
+PORTREVISION= 1
CATEGORIES= www net
MASTER_SITES= http://www.apsis.ch/pound/ \
ftp://ftp.nuug.no/pub/anders/distfiles/
@@ -22,15 +23,17 @@ USE_RC_SUBR= ${PORTNAME}.sh
SUB_LIST= NAME=${PORTNAME}
-CONFIGURE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
- PTHREAD_LIBS="${PTHREAD_LIBS}"
+POUND_CFLAGS= ${CFLAGS}
+POUND_LDFLAGS= ${LDFLAGS}
MAKE_ARGS+= F_CONF=${PREFIX}/etc/pound.cfg
MAN8= pound.8 poundctl.8
OPTIONS= DAEMON "Running as a daemon" on \
+ LIBTHR "Link against libthr for threading" on \
LOG "With Syslog support" on \
- MSDAV "With the Microsoft WebDAV extensions support" off
+ MSDAV "With the Microsoft WebDAV extensions support" off \
+ PCRE "Build with libpcre support" off
.include <bsd.port.pre.mk>
@@ -46,6 +49,22 @@ CONFIGURE_ARGS+= --disable-log
CONFIGURE_ARGS+= --enable-msdav
.endif
+.if defined(WITH_PCRE)
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+POUND_CFLAGS+= "-I${LOCALBASE}/include"
+POUND_LDFLAGS+= "-L${LOCALBASE}/lib"
+.endif
+
+.if !defined(WITHOUT_LIBTHR)
+PTHREAD_LIBS= -lthr
+.endif
+
+CONFIGURE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}" \
+ CFLAGS="${POUND_CFLAGS}" \
+ CPPFLAGS="${POUND_CFLAGS}" \
+ LDFLAGS="${POUND_LDFLAGS}"
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}