aboutsummaryrefslogtreecommitdiffstats
path: root/www/pound
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2004-05-01 05:29:04 +0800
committerclement <clement@FreeBSD.org>2004-05-01 05:29:04 +0800
commit9781c2b2ff5517404926fa1ef54dedc894b15efd (patch)
treed8659d2b0823b6c30284d2f398055ed25467fce3 /www/pound
parent0b5f9945cbb469258a3281da111f7e068d468d61 (diff)
downloadfreebsd-ports-gnome-9781c2b2ff5517404926fa1ef54dedc894b15efd.tar.gz
freebsd-ports-gnome-9781c2b2ff5517404926fa1ef54dedc894b15efd.tar.zst
freebsd-ports-gnome-9781c2b2ff5517404926fa1ef54dedc894b15efd.zip
- Update to 1.7
It fixes a security vulnerabilty. http://www.apsis.ch/pound/pound_list/archive/2003/2003-12/1070234315000 PR: 65132 Submitted by: ryan <ports@c0decafe.net> Reviewed by: me Update approved by: anders (maintainer)
Diffstat (limited to 'www/pound')
-rw-r--r--www/pound/Makefile2
-rw-r--r--www/pound/distinfo4
-rw-r--r--www/pound/files/patch-Makefile.in13
-rw-r--r--www/pound/files/patch-configure23
-rw-r--r--www/pound/files/patch-pound.c30
5 files changed, 58 insertions, 14 deletions
diff --git a/www/pound/Makefile b/www/pound/Makefile
index d81c139414f9..346d439293c2 100644
--- a/www/pound/Makefile
+++ b/www/pound/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pound
-PORTVERSION= 1.5
+PORTVERSION= 1.7
CATEGORIES= www net
MASTER_SITES= http://www.apsis.ch/pound/ \
ftp://ftp.nuug.no/pub/anders/distfiles/
diff --git a/www/pound/distinfo b/www/pound/distinfo
index 7e93f6947c12..e2ad9c2d73d5 100644
--- a/www/pound/distinfo
+++ b/www/pound/distinfo
@@ -1,2 +1,2 @@
-MD5 (Pound-1.5.tgz) = e838381f7fb49136c531895a0e93c31d
-SIZE (Pound-1.5.tgz) = 120219
+MD5 (Pound-1.7.tgz) = ebd15a0ff4a1920a857239630c33e8f5
+SIZE (Pound-1.7.tgz) = 132879
diff --git a/www/pound/files/patch-Makefile.in b/www/pound/files/patch-Makefile.in
new file mode 100644
index 000000000000..ef46de7928c8
--- /dev/null
+++ b/www/pound/files/patch-Makefile.in
@@ -0,0 +1,13 @@
+--- Makefile.in Wed Mar 24 11:03:14 2004
++++ Makefile.in Sun Mar 28 15:01:40 2004
+@@ -48,8 +48,8 @@
+ $(OBJS): pound.h
+
+ install: all
+- @INSTALL@ -o bin -g bin -m 555 -s -D pound @sbindir@/pound
+- @INSTALL@ -o bin -g bin -m 644 -D pound.8 @mandir@/man8/pound.8
++ @INSTALL@ -o bin -g bin -m 555 -s pound @sbindir@/pound
++ @INSTALL@ -o bin -g bin -m 644 pound.8 @mandir@/man8/pound.8
+
+ clean:
+ rm -f pound $(OBJS)
diff --git a/www/pound/files/patch-configure b/www/pound/files/patch-configure
index 0be7b2121fa1..4cf238659539 100644
--- a/www/pound/files/patch-configure
+++ b/www/pound/files/patch-configure
@@ -1,12 +1,13 @@
---- configure.orig Thu Apr 24 15:45:26 2003
-+++ configure Tue Apr 29 02:58:39 2003
-@@ -1850,7 +1850,8 @@
- if test $ac_cv_lib_pthread_pthread_create = yes; then
- LIBS="-lpthread ${LIBS}"
- else
-- CPPFLAGS="${CPPFLAGS} -pthread -DNEED_STACK"; LDFLAGS="${LDFLAGS} -pthread"
-+ CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS} -DNEED_STACK"
-+ LDFLAGS="${PTHREAD_LIBS} ${LDFLAGS}"
- fi
+--- configure.orig Fri Apr 30 22:18:25 2004
++++ configure Fri Apr 30 22:19:13 2004
+@@ -2348,8 +2348,8 @@
- echo "$as_me:1856: checking for socket in -lsocket" >&5
+ case $target_os in
+ *BSD*|*bsd*)
+- CPPFLAGS="${CPPFLAGS} -pthread -DNEED_STACK -D_REENTRANT -D_THREAD_SAFE"
+- LDFLAGS="${LDFLAGS} -pthread"
++ CPPFLAGS="${CPPFLAGS} ${PTHREAD_CFLAGS} -DNEED_STACK -D_REENTRANT -D_THREAD_SAFE"
++ LDFLAGS="${PTHREAD_LIBS} ${LDFLAGS}"
+ ;;
+ *)
+ CPPFLAGS="${CPPFLAGS} -D_REENTRANT"
diff --git a/www/pound/files/patch-pound.c b/www/pound/files/patch-pound.c
new file mode 100644
index 000000000000..58eec83c4d61
--- /dev/null
+++ b/www/pound/files/patch-pound.c
@@ -0,0 +1,30 @@
+--- pound.c Wed Mar 24 16:03:14 2004
++++ pound.c Tue Mar 30 19:13:51 2004
+@@ -742,10 +742,11 @@
+ logmsg(LOG_WARNING, "HTTP arg: malloc");
+ close(clnt);
+ } else {
++ socklen_t namelen;
+ arg->sock = clnt;
+ arg->from_host = clnt_addr.sin_addr;
+- memset(&arg->to_host, 0, n = sizeof(arg->to_host));
+- getsockname(http_sock[i], (struct sockaddr *)&arg->to_host, &n);
++ memset(&arg->to_host, 0, namelen = sizeof(arg->to_host));
++ getsockname(http_sock[i], (struct sockaddr *)&arg->to_host, &namelen);
+ arg->ctx = NULL;
+ if(pthread_create(&thr, &attr, thr_http, (void *)arg)) {
+ logmsg(LOG_WARNING, "HTTP pthread_create: %s", strerror(errno));
+@@ -776,10 +777,11 @@
+ logmsg(LOG_WARNING, "HTTPS arg: malloc");
+ close(clnt);
+ } else {
++ socklen_t namelen;
+ arg->sock = clnt;
+ arg->from_host = clnt_addr.sin_addr;
+- memset(&arg->to_host, 0, n = sizeof(arg->to_host));
+- getsockname(https_sock[i], (struct sockaddr *)&arg->to_host, &n);
++ memset(&arg->to_host, 0, namelen = sizeof(arg->to_host));
++ getsockname(https_sock[i], (struct sockaddr *)&arg->to_host, &namelen);
+ arg->ctx = ctx[i];
+ if(pthread_create(&thr, &attr, thr_http, (void *)arg)) {
+ logmsg(LOG_WARNING, "HTTPS pthread_create: %s", strerror(errno));