aboutsummaryrefslogtreecommitdiffstats
path: root/www/pound
diff options
context:
space:
mode:
authoranders <anders@FreeBSD.org>2005-03-16 07:27:02 +0800
committeranders <anders@FreeBSD.org>2005-03-16 07:27:02 +0800
commit36652ba7a615166ecf54c071ef0822c8f4eeefc0 (patch)
tree1317b449a5295f59befa0495ce808b1bdb46ede5 /www/pound
parentee6990f20455c2f935fcbc0f13934c4025a4ae1a (diff)
downloadfreebsd-ports-gnome-36652ba7a615166ecf54c071ef0822c8f4eeefc0.tar.gz
freebsd-ports-gnome-36652ba7a615166ecf54c071ef0822c8f4eeefc0.tar.zst
freebsd-ports-gnome-36652ba7a615166ecf54c071ef0822c8f4eeefc0.zip
Update to 1.8.2.
PR: 73923 Submitted by: ports@c0decafe.net
Diffstat (limited to 'www/pound')
-rw-r--r--www/pound/Makefile2
-rw-r--r--www/pound/distinfo4
-rw-r--r--www/pound/files/patch-Makefile.in13
-rw-r--r--www/pound/files/patch-configure13
-rw-r--r--www/pound/files/patch-pound.c30
5 files changed, 3 insertions, 59 deletions
diff --git a/www/pound/Makefile b/www/pound/Makefile
index 346d439293c2..8ec248fa6f4d 100644
--- a/www/pound/Makefile
+++ b/www/pound/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pound
-PORTVERSION= 1.7
+PORTVERSION= 1.8.2
CATEGORIES= www net
MASTER_SITES= http://www.apsis.ch/pound/ \
ftp://ftp.nuug.no/pub/anders/distfiles/
diff --git a/www/pound/distinfo b/www/pound/distinfo
index e2ad9c2d73d5..768a0b31e80e 100644
--- a/www/pound/distinfo
+++ b/www/pound/distinfo
@@ -1,2 +1,2 @@
-MD5 (Pound-1.7.tgz) = ebd15a0ff4a1920a857239630c33e8f5
-SIZE (Pound-1.7.tgz) = 132879
+MD5 (Pound-1.8.2.tgz) = c9b0793bb4d57be2270093d79b13c019
+SIZE (Pound-1.8.2.tgz) = 140455
diff --git a/www/pound/files/patch-Makefile.in b/www/pound/files/patch-Makefile.in
deleted file mode 100644
index ef46de7928c8..000000000000
--- a/www/pound/files/patch-Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- Makefile.in Wed Mar 24 11:03:14 2004
-+++ Makefile.in Sun Mar 28 15:01:40 2004
-@@ -48,8 +48,8 @@
- $(OBJS): pound.h
-
- install: all
-- @INSTALL@ -o bin -g bin -m 555 -s -D pound @sbindir@/pound
-- @INSTALL@ -o bin -g bin -m 644 -D pound.8 @mandir@/man8/pound.8
-+ @INSTALL@ -o bin -g bin -m 555 -s pound @sbindir@/pound
-+ @INSTALL@ -o bin -g bin -m 644 pound.8 @mandir@/man8/pound.8
-
- clean:
- rm -f pound $(OBJS)
diff --git a/www/pound/files/patch-configure b/www/pound/files/patch-configure
deleted file mode 100644
index 4cf238659539..000000000000
--- a/www/pound/files/patch-configure
+++ /dev/null
@@ -1,13 +0,0 @@
---- configure.orig Fri Apr 30 22:18:25 2004
-+++ configure Fri Apr 30 22:19:13 2004
-@@ -2348,8 +2348,8 @@
-
- case $target_os in
- *BSD*|*bsd*)
-- CPPFLAGS="${CPPFLAGS} -pthread -DNEED_STACK -D_REENTRANT -D_THREAD_SAFE"
-- LDFLAGS="${LDFLAGS} -pthread"
-+ CPPFLAGS="${CPPFLAGS} ${PTHREAD_CFLAGS} -DNEED_STACK -D_REENTRANT -D_THREAD_SAFE"
-+ LDFLAGS="${PTHREAD_LIBS} ${LDFLAGS}"
- ;;
- *)
- CPPFLAGS="${CPPFLAGS} -D_REENTRANT"
diff --git a/www/pound/files/patch-pound.c b/www/pound/files/patch-pound.c
deleted file mode 100644
index 58eec83c4d61..000000000000
--- a/www/pound/files/patch-pound.c
+++ /dev/null
@@ -1,30 +0,0 @@
---- pound.c Wed Mar 24 16:03:14 2004
-+++ pound.c Tue Mar 30 19:13:51 2004
-@@ -742,10 +742,11 @@
- logmsg(LOG_WARNING, "HTTP arg: malloc");
- close(clnt);
- } else {
-+ socklen_t namelen;
- arg->sock = clnt;
- arg->from_host = clnt_addr.sin_addr;
-- memset(&arg->to_host, 0, n = sizeof(arg->to_host));
-- getsockname(http_sock[i], (struct sockaddr *)&arg->to_host, &n);
-+ memset(&arg->to_host, 0, namelen = sizeof(arg->to_host));
-+ getsockname(http_sock[i], (struct sockaddr *)&arg->to_host, &namelen);
- arg->ctx = NULL;
- if(pthread_create(&thr, &attr, thr_http, (void *)arg)) {
- logmsg(LOG_WARNING, "HTTP pthread_create: %s", strerror(errno));
-@@ -776,10 +777,11 @@
- logmsg(LOG_WARNING, "HTTPS arg: malloc");
- close(clnt);
- } else {
-+ socklen_t namelen;
- arg->sock = clnt;
- arg->from_host = clnt_addr.sin_addr;
-- memset(&arg->to_host, 0, n = sizeof(arg->to_host));
-- getsockname(https_sock[i], (struct sockaddr *)&arg->to_host, &n);
-+ memset(&arg->to_host, 0, namelen = sizeof(arg->to_host));
-+ getsockname(https_sock[i], (struct sockaddr *)&arg->to_host, &namelen);
- arg->ctx = ctx[i];
- if(pthread_create(&thr, &attr, thr_http, (void *)arg)) {
- logmsg(LOG_WARNING, "HTTPS pthread_create: %s", strerror(errno));