aboutsummaryrefslogtreecommitdiffstats
path: root/www/privoxy
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-08-31 20:08:21 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-08-31 20:08:21 +0800
commitfb73e81fefe24887b9ff7b7f747f9eeefdd73e58 (patch)
tree69042614b95d8918ce954d2902972a3d0a46328a /www/privoxy
parenta64b64daea2157c02adb8a5310452137daa2b6ce (diff)
downloadfreebsd-ports-gnome-fb73e81fefe24887b9ff7b7f747f9eeefdd73e58.tar.gz
freebsd-ports-gnome-fb73e81fefe24887b9ff7b7f747f9eeefdd73e58.tar.zst
freebsd-ports-gnome-fb73e81fefe24887b9ff7b7f747f9eeefdd73e58.zip
- Update to 3.0.26
- Use official website as primary master site. - Add option to increase the number of connections Privoxy can serve at the same time - Quote variables in the rc script more consistently. The upstream changes are documented at: https://www.privoxy.org/3.0.26/user-manual/whatsnew.html PR: 212240 Submitted by: fk@fabiankeil.de (maintainer)
Diffstat (limited to 'www/privoxy')
-rw-r--r--www/privoxy/Makefile12
-rw-r--r--www/privoxy/distinfo5
-rw-r--r--www/privoxy/files/privoxy.in32
-rw-r--r--www/privoxy/pkg-plist1
4 files changed, 28 insertions, 22 deletions
diff --git a/www/privoxy/Makefile b/www/privoxy/Makefile
index 286523349883..e9a35d0723fa 100644
--- a/www/privoxy/Makefile
+++ b/www/privoxy/Makefile
@@ -2,9 +2,10 @@
# $FreeBSD$
PORTNAME= privoxy
-PORTVERSION= 3.0.24
+PORTVERSION= 3.0.26
CATEGORIES= www ipv6
-MASTER_SITES= SF/ijbswa/Sources/${PORTVERSION}%20%28stable%29
+MASTER_SITES= https://www.privoxy.org/sf-download-mirror/Sources/${PORTVERSION}%20(stable)/ \
+ SF/ijbswa/Sources/${PORTVERSION}%20%28stable%29
DISTNAME= privoxy-${PORTVERSION}-stable-src
MAINTAINER= fk@fabiankeil.de
@@ -33,14 +34,15 @@ GROUPS= privoxy
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS_DEFINE= ACCEPT_FILTER BROKEN_STRPTIME COMPRESSION DEBUG \
- DOCS EDITOR FORCE PRIVOXY_TOOLS TOGGLE
+OPTIONS_DEFINE= ACCEPT_FILTER BROKEN_STRPTIME BUMP_FD_SETSIZE COMPRESSION \
+ DEBUG DOCS EDITOR FORCE PRIVOXY_TOOLS TOGGLE
ACCEPT_FILTER_DESC= Support for accf_http(9)
BROKEN_STRPTIME_DESC= Enable workaround for standards/173421
COMPRESSION_DESC= Support compression of buffered content
DOCS_DESC= Let Privoxy serve the user manual
EDITOR_DESC= Support use of the web-based action editor
+BUMP_FD_SETSIZE_DESC= Support more client connections at the same time
FORCE_DESC= Support bypassing of blocks
PRIVOXY_TOOLS_DESC= Install Privoxy-Log-Parser, uagen, etc.
TOGGLE_DESC= Support for remote toggling
@@ -53,6 +55,8 @@ ACCEPT_FILTER_CONFIGURE_ON= --enable-accept-filter
BROKEN_STRPTIME_CONFIGURE_ON= --enable-strptime-sanity-checks
+BUMP_FD_SETSIZE_CONFIGURE_ON= --with-fdsetsize=8192
+
COMPRESSION_CONFIGURE_ON= --enable-compression
DEBUG_CONFIGURE_ON= --with-debug
diff --git a/www/privoxy/distinfo b/www/privoxy/distinfo
index 13b690f66eb3..7801b659f9f6 100644
--- a/www/privoxy/distinfo
+++ b/www/privoxy/distinfo
@@ -1,2 +1,3 @@
-SHA256 (privoxy-3.0.24-stable-src.tar.gz) = a381f6dc78f08de0d4a2342d47a5949a6608073ada34b933137184f3ca9fb012
-SIZE (privoxy-3.0.24-stable-src.tar.gz) = 1728265
+TIMESTAMP = 1472287144
+SHA256 (privoxy-3.0.26-stable-src.tar.gz) = 57e415b43ee5dfdca74685cc034053eaae962952fdabd086171551a86abf9cd8
+SIZE (privoxy-3.0.26-stable-src.tar.gz) = 1741772
diff --git a/www/privoxy/files/privoxy.in b/www/privoxy/files/privoxy.in
index 98d766cfd99a..9518a784fc6a 100644
--- a/www/privoxy/files/privoxy.in
+++ b/www/privoxy/files/privoxy.in
@@ -36,26 +36,26 @@ load_rc_config ${name}
: ${privoxy_pidfile="${privoxy_piddir}/privoxy.pid"}
privoxy_prestart () {
- if [ ! -e ${privoxy_config} ]; then
- echo config file not found. Copying the example file to ${privoxy_config}.
- cp %%PREFIX%%/share/examples/privoxy/config ${privoxy_config}
- chown ${privoxy_user}:${privoxy_user} ${privoxy_config};
+ if [ ! -e "${privoxy_config}" ]; then
+ echo "config file not found. Copying the example file to ${privoxy_config}."
+ cp %%PREFIX%%/share/examples/privoxy/config "${privoxy_config}"
+ chown "${privoxy_user}:${privoxy_user}" "${privoxy_config}";
fi
actionfile="%%PREFIX%%/etc/privoxy/match-all.action"
- if [ ! -e ${actionfile} ]; then
- echo ${actionfile} not found. Copying the example file.
- cp %%PREFIX%%/share/examples/privoxy/match-all.action ${actionfile}
- chown ${privoxy_user}:${privoxy_user} ${actionfile}
+ if [ ! -e "${actionfile}" ]; then
+ echo "${actionfile} not found. Copying the example file."
+ cp %%PREFIX%%/share/examples/privoxy/match-all.action "${actionfile}"
+ chown "${privoxy_user}:${privoxy_user}" "${actionfile}"
fi
- if [ ! -e ${privoxy_logdir} ]; then
- echo ${privoxy_logdir} not found. Creating ...
- mkdir ${privoxy_logdir}
- chown ${privoxy_user}:${privoxy_user} ${privoxy_logdir}
- chmod 0750 ${privoxy_logdir}
+ if [ ! -e "${privoxy_logdir}" ]; then
+ echo "${privoxy_logdir} not found. Creating ..."
+ mkdir "${privoxy_logdir}"
+ chown "${privoxy_user}:${privoxy_user}" "${privoxy_logdir}"
+ chmod 0750 "${privoxy_logdir}"
fi
- if [ ! -d ${privoxy_piddir} ]; then
- mkdir -p ${privoxy_piddir}
- chown ${privoxy_user}:${privoxy_user} ${privoxy_piddir}
+ if [ ! -d "${privoxy_piddir}" ]; then
+ mkdir -p "${privoxy_piddir}"
+ chown "${privoxy_user}:${privoxy_user}" "${privoxy_piddir}"
fi
}
diff --git a/www/privoxy/pkg-plist b/www/privoxy/pkg-plist
index 3f748ee5effa..bd502f75737a 100644
--- a/www/privoxy/pkg-plist
+++ b/www/privoxy/pkg-plist
@@ -15,6 +15,7 @@ etc/privoxy/templates/cgi-error-file-read-only
etc/privoxy/templates/cgi-error-modified
etc/privoxy/templates/cgi-error-parse
etc/privoxy/templates/cgi-style.css
+etc/privoxy/templates/client-tags
etc/privoxy/templates/connect-failed
etc/privoxy/templates/connection-timeout
etc/privoxy/templates/default