aboutsummaryrefslogtreecommitdiffstats
path: root/www/privoxy
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-02-24 09:36:26 +0800
committerwen <wen@FreeBSD.org>2010-02-24 09:36:26 +0800
commitba0910f1ac29fbdebe84cd93476f0083be8685df (patch)
tree27ecf12ca4083aefeaa9f256a64d65a9ac7b0bd1 /www/privoxy
parente42e87c30206e24df4e1c7a3802ea90fb75583e6 (diff)
downloadfreebsd-ports-gnome-ba0910f1ac29fbdebe84cd93476f0083be8685df.tar.gz
freebsd-ports-gnome-ba0910f1ac29fbdebe84cd93476f0083be8685df.tar.zst
freebsd-ports-gnome-ba0910f1ac29fbdebe84cd93476f0083be8685df.zip
- Update to 3.0.16
PR: ports/144146 Submitted by: Fabian Keil <fk@fabiankeil.de> (maintainer) Feature safe: yes
Diffstat (limited to 'www/privoxy')
-rw-r--r--www/privoxy/Makefile52
-rw-r--r--www/privoxy/distinfo6
-rw-r--r--www/privoxy/files/pkg-message.in8
-rw-r--r--www/privoxy/files/privoxy.in7
-rw-r--r--www/privoxy/pkg-plist7
5 files changed, 56 insertions, 24 deletions
diff --git a/www/privoxy/Makefile b/www/privoxy/Makefile
index 51c194f4b01d..b0b7bdd73cb5 100644
--- a/www/privoxy/Makefile
+++ b/www/privoxy/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= privoxy
-PORTVERSION= 3.0.12
-CATEGORIES= www
+PORTVERSION= 3.0.16
+CATEGORIES= www ipv6
MASTER_SITES= SF/ijbswa/Sources/${PORTVERSION}%20%28stable%29
DISTNAME= privoxy-${PORTVERSION}-stable-src
@@ -35,27 +35,41 @@ MAN1= privoxy.1
CONFIGURE_ENV= LDFLAGS=-L${LOCALBASE}/lib \
CPPFLAGS=-I${LOCALBASE}/include/
-OPTIONS= FORCE "Allows to optionally bypass blocks" On \
- TOGGLE "Support for remote toggling" On \
+OPTIONS= ACCEPT_FILTER "Enable support for accf_http(9)" Off \
+ DEBUG "Build with debugging symbols" Off \
EDITOR "Allow to enable the webbased action editor" On \
- DEBUG "Build with debugging symbols" Off
+ FORCE "Allows to optionally bypass blocks" On \
+ PRIVOXY_TOOLS "Install Privoxy-Log-Parser, uagen etc." Off \
+ TOGGLE "Support for remote toggling" On
.include <bsd.port.pre.mk>
-.if defined(WITHOUT_FORCE)
-CONFIGURE_ARGS+= --disable-force
+.if defined(WITH_ACCEPT_FILTER)
+CONFIGURE_ARGS+= --enable-accept-filter
.endif
-.if defined(WITHOUT_TOGGLE)
-CONFIGURE_ARGS+= --disable-toggle
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --with-debug
.endif
.if defined(WITHOUT_EDITOR)
CONFIGURE_ARGS+= --disable-editor
.endif
-.if defined(WITH_DEBUG)
-CONFIGURE_ARGS+= --with-debug
+.if defined(WITHOUT_FORCE)
+CONFIGURE_ARGS+= --disable-force
+.endif
+
+.if defined(WITHOUT_TOGGLE)
+CONFIGURE_ARGS+= --disable-toggle
+.endif
+
+.if defined(WITH_PRIVOXY_TOOLS)
+USE_PERL5_RUN= yes
+RUN_DEPENDS+= curl.5:${PORTSDIR}/ftp/curl
+PLIST_SUB+= PRIVOXY_TOOLS=""
+.else
+PLIST_SUB+= PRIVOXY_TOOLS="@comment "
.endif
post-patch:
@@ -68,8 +82,12 @@ post-patch:
${REINPLACE_CMD} \
-e 's,^#\(user-manual\) http://www.privoxy.org/user-manual/,\1 ${DOCSDIR}/user-manual,' \
${WRKSRC}/config
-
.endif
+ ${REINPLACE_CMD} \
+ -e 's,\(/etc/privoxy\),${PREFIX}\1,' ${WRKSRC}/tools/uagen.pl
+# Effectivly apply revision 1.208 to fix a regression test.
+ ${REINPLACE_CMD} \
+ -e 's,\(-fast-redirects -hide-refer\),\1r,' ${WRKSRC}/default.action.master
pre-configure:
@cd ${WRKSRC}; ${AUTOHEADER}
@@ -82,7 +100,12 @@ do-install:
@${MKDIR} ${PREFIX}/etc/privoxy/templates
@${INSTALL_PROGRAM} ${WRKSRC}/privoxy ${PREFIX}/sbin
@${INSTALL_DATA} ${WRKSRC}/templates/[a-z]* ${PREFIX}/etc/privoxy/templates
-.for defaultfile in default.action default.filter
+.if defined(WITH_PRIVOXY_TOOLS)
+.for privoxy_tool in privoxy-log-parser.pl privoxy-regression-test.pl uagen.pl
+ @${INSTALL_SCRIPT} ${WRKSRC}/tools/${privoxy_tool} ${PREFIX}/bin
+.endfor
+.endif
+.for defaultfile in default.action default.filter regression-tests.action
@${INSTALL_DATA} ${WRKSRC}/${defaultfile} ${PREFIX}/etc/privoxy
@${CHOWN} privoxy:privoxy ${PREFIX}/etc/privoxy/${defaultfile}
@${CHMOD} 0444 ${PREFIX}/etc/privoxy/${defaultfile}
@@ -101,9 +124,6 @@ do-install:
.endif
post-install:
- @${MKDIR} /var/log/privoxy
- @${CHOWN} privoxy:privoxy /var/log/privoxy
- @${CHMOD} 0750 /var/log/privoxy
@${MKDIR} /var/run/privoxy
@${CHOWN} privoxy:privoxy /var/run/privoxy
@${CHMOD} 0750 /var/run/privoxy
diff --git a/www/privoxy/distinfo b/www/privoxy/distinfo
index f9c4430594a4..4551207d6096 100644
--- a/www/privoxy/distinfo
+++ b/www/privoxy/distinfo
@@ -1,3 +1,3 @@
-MD5 (privoxy-3.0.12-stable-src.tar.gz) = c973e608d27b248ef567b47664308da1
-SHA256 (privoxy-3.0.12-stable-src.tar.gz) = c910da7fdd51dc197b7cd6695555c7dd0124b8fc44cb03d1fc645d72438dcf9a
-SIZE (privoxy-3.0.12-stable-src.tar.gz) = 1811124
+MD5 (privoxy-3.0.16-stable-src.tar.gz) = 64d3ffcdf8307e04a375773bb4eb255e
+SHA256 (privoxy-3.0.16-stable-src.tar.gz) = 7df74e33cf9263cb8153e5746e4ad09bf82d7c43d175511bb79056b8a4fafee6
+SIZE (privoxy-3.0.16-stable-src.tar.gz) = 1656721
diff --git a/www/privoxy/files/pkg-message.in b/www/privoxy/files/pkg-message.in
index 55d510fb3da0..f24e5bee12c0 100644
--- a/www/privoxy/files/pkg-message.in
+++ b/www/privoxy/files/pkg-message.in
@@ -19,9 +19,9 @@
changing them you should use your own action and
filter files as described in Privoxy's manual.
- If you installed Privoxy as package and are using the
- default configuration, you have to make sure the
- directories /var/log/privoxy and /var/run/privoxy
- exist and are owned by privoxy:privoxy.
+ If you installed Privoxy as package and are using
+ the default configuration, you have to make sure
+ the directory /var/run/privoxy exists and is owned
+ by privoxy:privoxy.
***********************************************************
diff --git a/www/privoxy/files/privoxy.in b/www/privoxy/files/privoxy.in
index bd986656dd4a..999e57ead5c5 100644
--- a/www/privoxy/files/privoxy.in
+++ b/www/privoxy/files/privoxy.in
@@ -30,6 +30,7 @@ load_rc_config ${name}
: ${privoxy_enable="NO"}
: ${privoxy_config="%%PREFIX%%/etc/privoxy/config"}
+: ${privoxy_logdir="/var/log/privoxy"}
: ${privoxy_user="privoxy"}
: ${privoxy_pidfile="/var/run/privoxy/privoxy.pid"}
@@ -45,6 +46,12 @@ config_file_check () {
cp %%PREFIX%%/share/examples/privoxy/match-all.action ${actionfile}
chown ${privoxy_user}:${privoxy_user} ${actionfile}
fi
+ if [ ! -e ${privoxy_logdir} ]; then
+ echo ${privoxy_logdir} not found. Creating ...
+ mkdir ${privoxy_logdir}
+ chown ${privoxy_user}:${privoxy_user} ${privoxy_logdir}
+ chmod 0750 ${privoxy_logdir}
+ fi
}
start_precmd="config_file_check"
diff --git a/www/privoxy/pkg-plist b/www/privoxy/pkg-plist
index 986ad534abb9..c7354b00f569 100644
--- a/www/privoxy/pkg-plist
+++ b/www/privoxy/pkg-plist
@@ -1,6 +1,10 @@
+%%PRIVOXY_TOOLS%%bin/privoxy-log-parser.pl
+%%PRIVOXY_TOOLS%%bin/privoxy-regression-test.pl
+%%PRIVOXY_TOOLS%%bin/uagen.pl
sbin/privoxy
etc/privoxy/default.action
etc/privoxy/default.filter
+etc/privoxy/regression-tests.action
etc/privoxy/templates/blocked
etc/privoxy/templates/cgi-error-404
etc/privoxy/templates/cgi-error-bad-param
@@ -11,6 +15,7 @@ etc/privoxy/templates/cgi-error-modified
etc/privoxy/templates/cgi-error-parse
etc/privoxy/templates/cgi-style.css
etc/privoxy/templates/connect-failed
+etc/privoxy/templates/connection-timeout
etc/privoxy/templates/default
etc/privoxy/templates/edit-actions-add-url-form
etc/privoxy/templates/edit-actions-for-url
@@ -26,6 +31,7 @@ etc/privoxy/templates/mod-local-help
etc/privoxy/templates/mod-support-and-service
etc/privoxy/templates/mod-title
etc/privoxy/templates/mod-unstable-warning
+etc/privoxy/templates/no-server-data
etc/privoxy/templates/no-such-domain
etc/privoxy/templates/show-request
etc/privoxy/templates/show-status
@@ -54,7 +60,6 @@ etc/privoxy/templates/url-info-osd.xml
%%PORTDOCS%%%%DOCSDIR%%/user-manual/seealso.html
%%PORTDOCS%%%%DOCSDIR%%/user-manual/startup.html
%%PORTDOCS%%%%DOCSDIR%%/user-manual/templates.html
-%%PORTDOCS%%%%DOCSDIR%%/user-manual/upgradersnote.html
%%PORTDOCS%%%%DOCSDIR%%/user-manual/whatsnew.html
%%EXAMPLESDIR%%/config
%%EXAMPLESDIR%%/match-all.action