aboutsummaryrefslogtreecommitdiffstats
path: root/www/privoxy
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-02-24 07:05:31 +0800
committermiwi <miwi@FreeBSD.org>2009-02-24 07:05:31 +0800
commitf80fdb478fca3bb18327a4be19f69b30517c0cb7 (patch)
treeb3f4a16dda296b96ce971669b8f2b7ab978b0c5f /www/privoxy
parent067708cd64749b11d596632c971c4b3e8ff7b977 (diff)
downloadfreebsd-ports-gnome-f80fdb478fca3bb18327a4be19f69b30517c0cb7.tar.gz
freebsd-ports-gnome-f80fdb478fca3bb18327a4be19f69b30517c0cb7.tar.zst
freebsd-ports-gnome-f80fdb478fca3bb18327a4be19f69b30517c0cb7.zip
- Update to 3.0.11
PR: 131978 Submitted by: Fabian Keil <fk@fabiankeil.de> (maintainer)
Diffstat (limited to 'www/privoxy')
-rw-r--r--www/privoxy/Makefile8
-rw-r--r--www/privoxy/distinfo6
-rw-r--r--www/privoxy/files/pkg-message.in9
-rw-r--r--www/privoxy/files/privoxy.in23
-rw-r--r--www/privoxy/pkg-plist2
5 files changed, 28 insertions, 20 deletions
diff --git a/www/privoxy/Makefile b/www/privoxy/Makefile
index f4945067eea7..4a98d9f44d7a 100644
--- a/www/privoxy/Makefile
+++ b/www/privoxy/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= privoxy
-PORTVERSION= 3.0.10
+PORTVERSION= 3.0.11
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ijbswa
@@ -83,13 +83,13 @@ do-install:
@${MKDIR} ${PREFIX}/etc/privoxy/templates
@${INSTALL_PROGRAM} ${WRKSRC}/privoxy ${PREFIX}/sbin
@${INSTALL_DATA} ${WRKSRC}/templates/[a-z]* ${PREFIX}/etc/privoxy/templates
-.for defaultfile in default.action standard.action default.filter
+.for defaultfile in default.action default.filter
@${INSTALL_DATA} ${WRKSRC}/${defaultfile} ${PREFIX}/etc/privoxy
@${CHOWN} privoxy:privoxy ${PREFIX}/etc/privoxy/${defaultfile}
- @${CHMOD} 0640 ${PREFIX}/etc/privoxy/${defaultfile}
+ @${CHMOD} 0444 ${PREFIX}/etc/privoxy/${defaultfile}
.endfor
@${MKDIR} ${EXAMPLESDIR}
-.for examplefile in config trust user.action
+.for examplefile in config match-all.action trust user.action
@${INSTALL_DATA} ${WRKSRC}/${examplefile} ${EXAMPLESDIR}/
@${CHOWN} privoxy:privoxy ${EXAMPLESDIR}/${examplefile}
@${CHMOD} 0640 ${EXAMPLESDIR}/${examplefile}
diff --git a/www/privoxy/distinfo b/www/privoxy/distinfo
index 34d011015642..cf94b4c6810a 100644
--- a/www/privoxy/distinfo
+++ b/www/privoxy/distinfo
@@ -1,3 +1,3 @@
-MD5 (privoxy-3.0.10-stable-src.tar.gz) = 01281017f28be2c7133124d1768da364
-SHA256 (privoxy-3.0.10-stable-src.tar.gz) = 3d9f9f56482012ddab396caf73f4c401746a4eeebd6c763b04f6108e48a9094f
-SIZE (privoxy-3.0.10-stable-src.tar.gz) = 1957465
+MD5 (privoxy-3.0.11-stable-src.tar.gz) = 438d048de32d80ca7b17e72bdf5c7c3f
+SHA256 (privoxy-3.0.11-stable-src.tar.gz) = cd1a3d2be048cba26ba70b4896709d8a0d2d2bbc0adca4b5a260319674098926
+SIZE (privoxy-3.0.11-stable-src.tar.gz) = 2050049
diff --git a/www/privoxy/files/pkg-message.in b/www/privoxy/files/pkg-message.in
index 2887e1a2ebd7..55d510fb3da0 100644
--- a/www/privoxy/files/pkg-message.in
+++ b/www/privoxy/files/pkg-message.in
@@ -14,11 +14,10 @@
For documentation see:
%%DOCSDIR%%/user-manual or 'man privoxy'
- Note that default.filter, standard.action and
- default.action get overwritten with each Privoxy
- update. Instead of changing them you should use
- your own action and filter files as described in
- Privoxy's manual.
+ Note that default.filter and default.action get
+ overwritten with each Privoxy update. Instead of
+ changing them you should use your own action and
+ filter files as described in Privoxy's manual.
If you installed Privoxy as package and are using the
default configuration, you have to make sure the
diff --git a/www/privoxy/files/privoxy.in b/www/privoxy/files/privoxy.in
index 5e44c6497868..7ebe77cdf1f5 100644
--- a/www/privoxy/files/privoxy.in
+++ b/www/privoxy/files/privoxy.in
@@ -4,7 +4,7 @@
#
#
# PROVIDE: privoxy
-# REQUIRE: NETWORKING
+# REQUIRE: DAEMON
# BEFORE: LOGIN
#
# This rc script understands the following variables
@@ -34,14 +34,23 @@ load_rc_config ${name}
: ${privoxy_user="privoxy"}
: ${privoxy_pidfile="/var/run/privoxy/privoxy.pid"}
-start_precmd="if [ ! -e ${privoxy_config} ]; then\
- echo ${privoxy_config} not found. Copying default configuration.;\
- cp %%PREFIX%%/share/examples/privoxy/config ${privoxy_config};\
- chown ${privoxy_user}:${privoxy_user} ${privoxy_config};\
-fi"
+config_file_check () {
+ if [ ! -e ${privoxy_config} ]; then
+ echo config file not found. Copying the example file to ${privoxy_config}.
+ cp %%PREFIX%%/share/examples/privoxy/config ${privoxy_config}
+ chown ${privoxy_user}:${privoxy_user} ${privoxy_config};
+ fi
+ actionfile="%%PREFIX%%/etc/privoxy/match-all.action"
+ if [ ! -e ${actionfile} ]; then
+ echo ${actionfile} not found. Copying the example file.
+ cp %%PREFIX%%/share/examples/privoxy/match-all.action ${actionfile}
+ chown ${privoxy_user}:${privoxy_user} ${actionfile}
+ fi
+}
+
+start_precmd="config_file_check"
command="%%PREFIX%%/sbin/privoxy"
command_args="${privoxy_flags} --pidfile ${privoxy_pidfile} ${privoxy_config}"
run_rc_command "$1"
-
diff --git a/www/privoxy/pkg-plist b/www/privoxy/pkg-plist
index df7d42aebae8..986ad534abb9 100644
--- a/www/privoxy/pkg-plist
+++ b/www/privoxy/pkg-plist
@@ -1,7 +1,6 @@
sbin/privoxy
etc/privoxy/default.action
etc/privoxy/default.filter
-etc/privoxy/standard.action
etc/privoxy/templates/blocked
etc/privoxy/templates/cgi-error-404
etc/privoxy/templates/cgi-error-bad-param
@@ -58,6 +57,7 @@ etc/privoxy/templates/url-info-osd.xml
%%PORTDOCS%%%%DOCSDIR%%/user-manual/upgradersnote.html
%%PORTDOCS%%%%DOCSDIR%%/user-manual/whatsnew.html
%%EXAMPLESDIR%%/config
+%%EXAMPLESDIR%%/match-all.action
%%EXAMPLESDIR%%/trust
%%EXAMPLESDIR%%/user.action
@dirrm %%EXAMPLESDIR%%