aboutsummaryrefslogtreecommitdiffstats
path: root/www/publicfile
diff options
context:
space:
mode:
authorlx <lx@FreeBSD.org>2007-05-27 08:10:02 +0800
committerlx <lx@FreeBSD.org>2007-05-27 08:10:02 +0800
commitf30e1ab2fa5f6db27be62ce396a71a91c7e4e005 (patch)
tree3790c9cf2caeaa856c6444ab0419f8f99d18d7fb /www/publicfile
parent8e7b0b8af912a1a2ef0d2e9c7d0bfc464ab3d9f5 (diff)
downloadfreebsd-ports-gnome-f30e1ab2fa5f6db27be62ce396a71a91c7e4e005.tar.gz
freebsd-ports-gnome-f30e1ab2fa5f6db27be62ce396a71a91c7e4e005.tar.zst
freebsd-ports-gnome-f30e1ab2fa5f6db27be62ce396a71a91c7e4e005.zip
Make OPTIONS vanilla by default, and make portlint happy.
Approved by: edwin (mentor)
Diffstat (limited to 'www/publicfile')
-rw-r--r--www/publicfile/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/www/publicfile/Makefile b/www/publicfile/Makefile
index 1f4650c67147..b495a0710600 100644
--- a/www/publicfile/Makefile
+++ b/www/publicfile/Makefile
@@ -12,17 +12,17 @@ CATEGORIES= www ftp
MASTER_SITES= http://cr.yp.to/publicfile/ \
ftp://cr.yp.to/publicfile/
-MAINTAINER= lx@redundancy.redundancy.org
+MAINTAINER= lx@FreeBSD.org
COMMENT= A secure, read-only, anonymous HTTP/FTP server
RUN_DEPENDS= setuidgid:${PORTSDIR}/sysutils/daemontools \
tcpserver:${PORTSDIR}/sysutils/ucspi-tcp
OPTIONS= BASICAUTH "basic HTTP authentication support" off \
- COMMONLOG "support for Apache common log format" on \
- REDIRECT_SLASH "don't complain when omitting trailing slash" off \
- ENV_FILETYPES "get filetypes from the environment" off \
- SSL "provide SSL support through ucspi-ssl" on
+ COMMONLOG "support for Apache common log format" off \
+ REDIRECT_SLASH "don't require trailing slash on directories" off \
+ ENV_FILETYPES "get mime types from the environment" off \
+ SSL "provide SSL support through ucspi-ssl" off
.include <bsd.port.pre.mk>
@@ -31,14 +31,14 @@ pre-everything::
@${ECHO_MSG}
@${ECHO_MSG} "Currently the common log and auth patches conflict."
@${ECHO_MSG}
-BROKEN= "Currently the common log and auth patches conflict."
+BROKEN= Currently the common log and auth patches conflict.
.endif
.if defined(WITH_BASICAUTH) && defined(WITH_REDIRECT_SLASH)
@${ECHO_MSG}
@${ECHO_MSG} "Currently the redirect slash and auth patches conflict."
@${ECHO_MSG}
-BROKEN= "Currently the redirect slash and auth patches conflict."
+BROKEN= Currently the redirect slash and auth patches conflict.
.endif
.if defined(WITH_REDIRECT_SLASH)