aboutsummaryrefslogtreecommitdiffstats
path: root/www/py-django
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2012-09-01 01:56:06 +0800
committerlwhsu <lwhsu@FreeBSD.org>2012-09-01 01:56:06 +0800
commit4e883fa7b47bd4e096a92c36ded32da438f6282b (patch)
tree53747095967a4cdae2ba3d998d0ccee4ad47d846 /www/py-django
parent63648ed5bc06a0838cfebea62273cc4183d49e14 (diff)
downloadfreebsd-ports-gnome-4e883fa7b47bd4e096a92c36ded32da438f6282b.tar.gz
freebsd-ports-gnome-4e883fa7b47bd4e096a92c36ded32da438f6282b.tar.zst
freebsd-ports-gnome-4e883fa7b47bd4e096a92c36ded32da438f6282b.zip
- Convert to new options framework
Diffstat (limited to 'www/py-django')
-rw-r--r--www/py-django/Makefile29
1 files changed, 14 insertions, 15 deletions
diff --git a/www/py-django/Makefile b/www/py-django/Makefile
index 1be4651ee98c..a460610fd5b7 100644
--- a/www/py-django/Makefile
+++ b/www/py-django/Makefile
@@ -28,11 +28,10 @@ CONFLICTS= py2[0-9]-django-devel-[0-9]* py2[0-9]-django-1.[23].*
DOCSDIR= ${PREFIX}/share/doc/py-django
-OPTIONS= POSTGRESQL "PostgreSQL support" off \
- MYSQL "MySQL support" off \
- SQLITE "SQLite support" off \
- FASTCGI "FastCGI support" off \
- DOCS "Install HTML documentation (requires Sphinx)" off
+OPTIONS_DEFINE= PGSQL MYSQL SQLITE FASTCGI HTMLDOCS
+OPTIONS_DEFAULT=
+
+HTMLDOCS_DESC= Build and install the HTML documentation (requires Sphinx)
MAN1= daily_cleanup.1 django-admin.1 gather_profile_stats.1
@@ -41,32 +40,32 @@ OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
.include <bsd.port.pre.mk>
-.if defined(WITH_POSTGRESQL)
+.if ${PORT_OPTIONS:MPGSQL}
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psycopg2/_psycopg.so:${PORTSDIR}/databases/py-psycopg2
.endif
-.if defined(WITH_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:${PORTSDIR}/databases/py-MySQLdb
.endif
-.if defined(WITH_SQLITE)
+.if ${PORT_OPTIONS:MSQLITE}
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
.endif
-.if defined(WITH_FASTCGI)
+.if ${PORT_OPTIONS:MFASTCGI}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}flup>0:${PORTSDIR}/www/py-flup
.endif
-.if defined(WITH_DOCS)
+.if ${PORT_OPTIONS:MHTMLDOCS}
+. if defined(NOPORTDOCS)
+IGNORE= you cannot build documentation while setting NOPORTDOCS
+. endif
BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}sphinx>0:${PORTSDIR}/textproc/py-sphinx
PORTDOCS= *
.endif
post-build:
-.if defined(WITH_DOCS)
-. if defined(NOPORTDOCS)
-IGNORE= you cannot build documentation while setting NOPORTDOCS
-. endif
+.if ${PORT_OPTIONS:MHTMLDOCS}
cd ${WRKSRC}/docs && ${MAKE} html
.endif
@@ -75,7 +74,7 @@ post-install:
@${ECHO_MSG} ""
@${ECHO_MSG} " * See http://docs.djangoproject.com/ for complete documentation"
@${ECHO_MSG} ""
-.if defined(WITH_DOCS)
+.if ${PORT_OPTIONS:MHTMLDOCS}
${MKDIR} ${DOCSDIR}
${CP} -R ${WRKSRC}/docs/_build/html ${DOCSDIR}
.endif