aboutsummaryrefslogtreecommitdiffstats
path: root/www/py-funkload/Makefile
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2007-06-22 20:18:05 +0800
committerlwhsu <lwhsu@FreeBSD.org>2007-06-22 20:18:05 +0800
commitb964697f39297224cc4c951a80605e666919cdaa (patch)
tree6b2bb3ccfa7e2c2bf497b1d05686279bfe2f6f28 /www/py-funkload/Makefile
parente3a9d9bd7403a9c1b00941fdf9d2f9e0a74e1db4 (diff)
downloadfreebsd-ports-gnome-b964697f39297224cc4c951a80605e666919cdaa.tar.gz
freebsd-ports-gnome-b964697f39297224cc4c951a80605e666919cdaa.tar.zst
freebsd-ports-gnome-b964697f39297224cc4c951a80605e666919cdaa.zip
- Use CHEESESHOP in MASTER_SITES
- Respect NOPORTEXAMPLES
Diffstat (limited to 'www/py-funkload/Makefile')
-rw-r--r--www/py-funkload/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/www/py-funkload/Makefile b/www/py-funkload/Makefile
index 62f1a9c8f337..59551b58cfe0 100644
--- a/www/py-funkload/Makefile
+++ b/www/py-funkload/Makefile
@@ -10,7 +10,7 @@ PORTVERSION= 1.6.2
PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= http://funkload.nuxeo.org/ \
- http://cheeseshop.python.org/packages/source/f/funkload/
+ CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= lwhsu@FreeBSD.org
@@ -39,17 +39,17 @@ PLIST_SUB+= EASY_INSTALL_CMD=${EASY_INSTALL_CMD} \
PYFUNKLOAD_EGG=${PYFUNKLOAD_EGG} \
PYFUNKLOAD_EGG_VER="${PORTNAME}==${PORTVERSION}"
-.if !defined(NOPORTDOCS)
DOCSDIR= ${TARGETDIR}/share/doc/py-${PORTNAME}
EXAMPLESDIR= ${TARGETDIR}/share/examples/py-${PORTNAME}
-.endif
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
.endif
+.if !defined(NOPORTEXAMPLES)
${MKDIR} ${EXAMPLESDIR}
${CP} -R ${WRKSRC}/funkload/demo ${EXAMPLESDIR}
+.endif
.include <bsd.port.mk>