aboutsummaryrefslogtreecommitdiffstats
path: root/www/py-google-api-python-client
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-11-30 23:50:30 +0800
committermat <mat@FreeBSD.org>2017-11-30 23:50:30 +0800
commit32512cab3e8dd90b7cd0525bb5dc98007db431e2 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /www/py-google-api-python-client
parentb4ddc365e88ebdb48627086b02365b74119cf189 (diff)
downloadfreebsd-ports-gnome-32512cab3e8dd90b7cd0525bb5dc98007db431e2.tar.gz
freebsd-ports-gnome-32512cab3e8dd90b7cd0525bb5dc98007db431e2.tar.zst
freebsd-ports-gnome-32512cab3e8dd90b7cd0525bb5dc98007db431e2.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Diffstat (limited to 'www/py-google-api-python-client')
-rw-r--r--www/py-google-api-python-client/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/www/py-google-api-python-client/Makefile b/www/py-google-api-python-client/Makefile
index 2f616c506ae8..c651974af0ca 100644
--- a/www/py-google-api-python-client/Makefile
+++ b/www/py-google-api-python-client/Makefile
@@ -12,13 +12,13 @@ COMMENT= Google API Client Library for Python
LICENSE= APACHE20
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}httplib2>=0.9.2:www/py-httplib2 \
- ${PYTHON_PKGNAMEPREFIX}oauth2client>=1.5.0:security/py-oauth2client \
- ${PYTHON_PKGNAMEPREFIX}six>=1.6.1:devel/py-six \
- ${PYTHON_PKGNAMEPREFIX}uritemplate>=3.0.0:net/py-uritemplate
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}httplib2>=0.9.2:www/py-httplib2@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}oauth2client>=1.5.0:security/py-oauth2client@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.6.1:devel/py-six@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}uritemplate>=3.0.0:net/py-uritemplate@${FLAVOR}
DJANGO_DESC= Use the library with Django
-DJANGO_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django18>=1.3:www/py-django18
+DJANGO_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django18>=1.3:www/py-django18@${FLAVOR}
GAE_DESC= Use the library with Google App Engine
GAE_RUN_DEPENDS= google-appengine>=1.4.3:www/google-appengine
@@ -30,7 +30,7 @@ USES= python
USE_PYTHON= autoplist distutils
WEBTEST_DESC= Use WebTest helper to test WSGI apps
-WEBTEST_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}WebTest>=1.3.3:www/py-WebTest \
- ${PYTHON_PKGNAMEPREFIX}openssl>=0.13:security/py-openssl
+WEBTEST_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}WebTest>=1.3.3:www/py-WebTest@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}openssl>=0.13:security/py-openssl@${FLAVOR}
.include <bsd.port.mk>