aboutsummaryrefslogtreecommitdiffstats
path: root/www/py-plone.supermodel
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2012-01-03 03:53:53 +0800
committerrm <rm@FreeBSD.org>2012-01-03 03:53:53 +0800
commit0d73c407016f55427e87aa516eefc57a4e51682c (patch)
treefd22087956f7f521b0a586b5a43daeb130851339 /www/py-plone.supermodel
parent28b087a3daa25fabf2b2a2b091a50776cb1d52d4 (diff)
downloadfreebsd-ports-gnome-0d73c407016f55427e87aa516eefc57a4e51682c.tar.gz
freebsd-ports-gnome-0d73c407016f55427e87aa516eefc57a4e51682c.tar.zst
freebsd-ports-gnome-0d73c407016f55427e87aa516eefc57a4e51682c.zip
Import plone4 dependencies part 10/15
Diffstat (limited to 'www/py-plone.supermodel')
-rw-r--r--www/py-plone.supermodel/Makefile33
-rw-r--r--www/py-plone.supermodel/distinfo2
-rw-r--r--www/py-plone.supermodel/files/patch-plone-supermodel_exportimport.py8
-rw-r--r--www/py-plone.supermodel/files/patch-plone-supermodel_parser.py11
-rw-r--r--www/py-plone.supermodel/files/patch-plone-supermodel_serializer.py11
-rw-r--r--www/py-plone.supermodel/files/patch-plone-supermodel_tests.py9
-rw-r--r--www/py-plone.supermodel/files/patch-plone-supermodel_utils.py11
-rw-r--r--www/py-plone.supermodel/pkg-descr3
-rw-r--r--www/py-plone.supermodel/pkg-plist54
9 files changed, 142 insertions, 0 deletions
diff --git a/www/py-plone.supermodel/Makefile b/www/py-plone.supermodel/Makefile
new file mode 100644
index 000000000000..8dd544c0b785
--- /dev/null
+++ b/www/py-plone.supermodel/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: py-plone.supermodel
+# Date created: 02 January 2012
+# Whom: Ruslan Mahmatkhanov <cvs-src@yandex.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= plone.supermodel
+PORTVERSION= 1.0.3
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rm@FreeBSD.org
+COMMENT= Serialize Zope schema definitions to and from XML
+
+LICENSE= BSD
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zope.component>=0:${PORTSDIR}/devel/py-zope.component \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>=0:${PORTSDIR}/devel/py-zope.interface \
+ ${PYTHON_PKGNAMEPREFIX}zope.schema>=0:${PORTSDIR}/devel/py-zope.schema \
+ ${PYTHON_PKGNAMEPREFIX}zope.deferredimport>=0:${PORTSDIR}/devel/py-zope.deferredimport \
+ ${PYTHON_PKGNAMEPREFIX}zope.dottedname>=0:${PORTSDIR}/devel/py-zope.dottedname
+
+DIST_SUBDIR= zope
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+USE_ZIP= yes
+
+post-patch:
+ @${FIND} ${WRKSRC} -type f -name "*.orig" -delete
+
+.include <bsd.port.mk>
diff --git a/www/py-plone.supermodel/distinfo b/www/py-plone.supermodel/distinfo
new file mode 100644
index 000000000000..f0db6c49e43b
--- /dev/null
+++ b/www/py-plone.supermodel/distinfo
@@ -0,0 +1,2 @@
+SHA256 (zope/plone.supermodel-1.0.3.zip) = 97f04b162268af76c3cfa93cd96697b190f6977a01118cfbb62bf0279078dea7
+SIZE (zope/plone.supermodel-1.0.3.zip) = 39166
diff --git a/www/py-plone.supermodel/files/patch-plone-supermodel_exportimport.py b/www/py-plone.supermodel/files/patch-plone-supermodel_exportimport.py
new file mode 100644
index 000000000000..d3b50d34ba00
--- /dev/null
+++ b/www/py-plone.supermodel/files/patch-plone-supermodel_exportimport.py
@@ -0,0 +1,8 @@
+--- plone/supermodel/exportimport.py.orig 2011-05-13 20:28:08.000000000 +0400
++++ plone/supermodel/exportimport.py 2011-09-22 23:05:55.000000000 +0400
+@@ -1,4 +1,4 @@
+-from elementtree import ElementTree
++from xml.etree import ElementTree
+
+ from zope.interface import Interface, implements, implementedBy
+ from zope.component import queryUtility
diff --git a/www/py-plone.supermodel/files/patch-plone-supermodel_parser.py b/www/py-plone.supermodel/files/patch-plone-supermodel_parser.py
new file mode 100644
index 000000000000..8d69f7a405c4
--- /dev/null
+++ b/www/py-plone.supermodel/files/patch-plone-supermodel_parser.py
@@ -0,0 +1,11 @@
+--- plone/supermodel/parser.py.orig 2011-04-29 22:24:50.000000000 +0400
++++ plone/supermodel/parser.py 2011-09-22 23:06:17.000000000 +0400
+@@ -17,7 +17,7 @@
+ from plone.supermodel.model import Model, Fieldset
+ from plone.supermodel.interfaces import FIELDSETS_KEY
+
+-from elementtree import ElementTree
++from xml.etree import ElementTree
+
+ # Helper adapters
+
diff --git a/www/py-plone.supermodel/files/patch-plone-supermodel_serializer.py b/www/py-plone.supermodel/files/patch-plone-supermodel_serializer.py
new file mode 100644
index 000000000000..1abf0f64e293
--- /dev/null
+++ b/www/py-plone.supermodel/files/patch-plone-supermodel_serializer.py
@@ -0,0 +1,11 @@
+--- plone/supermodel/serializer.py.orig 2011-04-29 22:24:50.000000000 +0400
++++ plone/supermodel/serializer.py 2011-09-22 23:06:40.000000000 +0400
+@@ -15,7 +15,7 @@
+
+ from plone.supermodel.utils import sortedFields, prettyXML
+
+-from elementtree import ElementTree
++from xml.etree import ElementTree
+
+
+ class DefaultFieldNameExtractor(object):
diff --git a/www/py-plone.supermodel/files/patch-plone-supermodel_tests.py b/www/py-plone.supermodel/files/patch-plone-supermodel_tests.py
new file mode 100644
index 000000000000..5fd2987c3cea
--- /dev/null
+++ b/www/py-plone.supermodel/files/patch-plone-supermodel_tests.py
@@ -0,0 +1,9 @@
+--- plone/supermodel/test.py.orig 2011-04-30 12:22:20.000000000 +0400
++++ plone/supermodel/tests.py 2011-09-22 23:07:10.000000000 +0400
+@@ -1,5 +1,5 @@
+ from cStringIO import StringIO
+-from elementtree import ElementTree as etree
++from xml.etree import ElementTree as etree
+ import doctest
+ import unittest
+ import zope.app.testing.placelesssetup
diff --git a/www/py-plone.supermodel/files/patch-plone-supermodel_utils.py b/www/py-plone.supermodel/files/patch-plone-supermodel_utils.py
new file mode 100644
index 000000000000..0bef234102c1
--- /dev/null
+++ b/www/py-plone.supermodel/files/patch-plone-supermodel_utils.py
@@ -0,0 +1,11 @@
+--- plone/supermodel/utils.py.orig 2011-04-29 22:24:50.000000000 +0400
++++ plone/supermodel/utils.py 2011-09-22 23:06:55.000000000 +0400
+@@ -2,7 +2,7 @@
+ import sys
+ import re
+
+-from elementtree import ElementTree
++from xml.etree import ElementTree
+
+ from zope.interface import directlyProvidedBy, directlyProvides
+ from zope.schema.interfaces import IField, IFromUnicode, IDict, ICollection
diff --git a/www/py-plone.supermodel/pkg-descr b/www/py-plone.supermodel/pkg-descr
new file mode 100644
index 000000000000..952be5f30b8b
--- /dev/null
+++ b/www/py-plone.supermodel/pkg-descr
@@ -0,0 +1,3 @@
+Serialize Zope schema definitions to and from XML.
+
+WWW: http://pypi.python.org/pypi/plone.supermodel
diff --git a/www/py-plone.supermodel/pkg-plist b/www/py-plone.supermodel/pkg-plist
new file mode 100644
index 000000000000..fe137b7d8772
--- /dev/null
+++ b/www/py-plone.supermodel/pkg-plist
@@ -0,0 +1,54 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/PKG-INFO
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/SOURCES.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/dependency_links.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/entry_points.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/namespace_packages.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/not-zip-safe
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/requires.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/top_level.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/configure.zcml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/converters.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/converters.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/converters.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/exportimport.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/exportimport.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/exportimport.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/fields.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/fields.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/fields.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/fields.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/generated.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/generated.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/generated.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/interfaces.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/interfaces.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/interfaces.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/model.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/model.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/model.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/parser.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/parser.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/parser.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/patches.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/patches.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/patches.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/schema.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/serializer.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/serializer.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/serializer.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/tests.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/tests.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/tests.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/utils.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/utils.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel/utils.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone/supermodel
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/plone
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%