aboutsummaryrefslogtreecommitdiffstats
path: root/www/py-requests
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2012-05-04 00:16:46 +0800
committermiwi <miwi@FreeBSD.org>2012-05-04 00:16:46 +0800
commitd0844f0028961e871edef163b037416ada9b34f5 (patch)
treea534d70c7a8bd60fe4a1bc7e5c1d058154bd21ea /www/py-requests
parent36f6274cdbb447df92ace8228ffdd980e231690b (diff)
downloadfreebsd-ports-gnome-d0844f0028961e871edef163b037416ada9b34f5.tar.gz
freebsd-ports-gnome-d0844f0028961e871edef163b037416ada9b34f5.tar.zst
freebsd-ports-gnome-d0844f0028961e871edef163b037416ada9b34f5.zip
- Update to 0.11.2
PR: 167243 Submitted by: Olivier Duchateau <duchateau.olivier@gmail.com> (maintainer)
Diffstat (limited to 'www/py-requests')
-rw-r--r--www/py-requests/Makefile2
-rw-r--r--www/py-requests/distinfo4
-rw-r--r--www/py-requests/files/patch-requests_models.py8
3 files changed, 7 insertions, 7 deletions
diff --git a/www/py-requests/Makefile b/www/py-requests/Makefile
index f910a1025845..992d181fb4d6 100644
--- a/www/py-requests/Makefile
+++ b/www/py-requests/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= requests
-PORTVERSION= 0.11.1
+PORTVERSION= 0.11.2
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/www/py-requests/distinfo b/www/py-requests/distinfo
index e2f72415a78d..a1eecd87e56f 100644
--- a/www/py-requests/distinfo
+++ b/www/py-requests/distinfo
@@ -1,2 +1,2 @@
-SHA256 (requests-0.11.1.tar.gz) = fd4260541d0e559c78e2b3072bd79f36e0f8ef935bcbbadaa8c98cd8b5a62897
-SIZE (requests-0.11.1.tar.gz) = 63100
+SHA256 (requests-0.11.2.tar.gz) = 547bf78a774a6018271d6e5c40613ec554642ba4d6cdf45813e7894145293c57
+SIZE (requests-0.11.2.tar.gz) = 71080
diff --git a/www/py-requests/files/patch-requests_models.py b/www/py-requests/files/patch-requests_models.py
index e167bb275c96..86b6dab5c14a 100644
--- a/www/py-requests/files/patch-requests_models.py
+++ b/www/py-requests/files/patch-requests_models.py
@@ -1,17 +1,17 @@
---- requests/models.py.orig 2012-03-09 17:51:20.000000000 +0100
-+++ requests/models.py 2012-03-19 17:49:25.000000000 +0100
+--- requests/models.py.orig 2012-04-23 04:13:53.000000000 +0200
++++ requests/models.py 2012-04-23 18:22:55.000000000 +0200
@@ -15,12 +15,12 @@
from .status_codes import codes
from .auth import HTTPBasicAuth, HTTPProxyAuth
-from .packages.urllib3.response import HTTPResponse
--from .packages.urllib3.exceptions import MaxRetryError
+-from .packages.urllib3.exceptions import MaxRetryError, LocationParseError
-from .packages.urllib3.exceptions import SSLError as _SSLError
-from .packages.urllib3.exceptions import HTTPError as _HTTPError
-from .packages.urllib3 import connectionpool, poolmanager
-from .packages.urllib3.filepost import encode_multipart_formdata
+from urllib3.response import HTTPResponse
-+from urllib3.exceptions import MaxRetryError
++from urllib3.exceptions import MaxRetryError, LocationParseError
+from urllib3.exceptions import SSLError as _SSLError
+from urllib3.exceptions import HTTPError as _HTTPError
+from urllib3 import connectionpool, poolmanager