aboutsummaryrefslogtreecommitdiffstats
path: root/www/py-rssdler
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-10-10 12:36:38 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-10-10 12:36:38 +0800
commit148eb52cc8223dab2bf9c7f378d689f63fe89b50 (patch)
tree048bdb9fe65af61e7823c07bdaa82153e0f43994 /www/py-rssdler
parent27f30b367f598a52092983ee141cd15c9f69a659 (diff)
downloadfreebsd-ports-gnome-148eb52cc8223dab2bf9c7f378d689f63fe89b50.tar.gz
freebsd-ports-gnome-148eb52cc8223dab2bf9c7f378d689f63fe89b50.tar.zst
freebsd-ports-gnome-148eb52cc8223dab2bf9c7f378d689f63fe89b50.zip
- Clear pidfile on SIGTERM (cf. issue#56 on googlecode)
- Bump PORTREVISION PR: ports/151339 Submitted by: Anonymous <swell.k@gmail.com> (maintainer)
Diffstat (limited to 'www/py-rssdler')
-rw-r--r--www/py-rssdler/Makefile2
-rw-r--r--www/py-rssdler/files/patch-rssdler.py10
2 files changed, 11 insertions, 1 deletions
diff --git a/www/py-rssdler/Makefile b/www/py-rssdler/Makefile
index 6fb0f39195e8..eff548290e60 100644
--- a/www/py-rssdler/Makefile
+++ b/www/py-rssdler/Makefile
@@ -7,7 +7,7 @@
PORTNAME= rssdler
PORTVERSION= 0.4.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www python
MASTER_SITES= GOOGLE_CODE
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/www/py-rssdler/files/patch-rssdler.py b/www/py-rssdler/files/patch-rssdler.py
new file mode 100644
index 000000000000..aa94ab3cb40a
--- /dev/null
+++ b/www/py-rssdler/files/patch-rssdler.py
@@ -0,0 +1,10 @@
+--- ./rssdler.py.orig 2010-10-10 03:58:44.112133159 +0000
++++ ./rssdler.py 2010-10-10 03:59:10.937002223 +0000
+@@ -2180,6 +2180,7 @@
+ elif param == "--purge-saved": _action = 'purge-saved'
+ elif param == "--comment-config": _action = 'comment-config'
+ signal.signal(signal.SIGINT, signalHandler)
++ signal.signal(signal.SIGTERM, signalHandler)
+ sys.excepthook = setDebug #this is NOT supposed to be called!
+ if _action == 'comment-config':
+ print(commentConfig)