aboutsummaryrefslogtreecommitdiffstats
path: root/www/py-spyne
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-11-30 23:50:30 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 06:02:26 +0800
commitad9c5e72c063fd2001b42cfbb2fcc63cb86019d7 (patch)
tree9278ac4e2888d0d4639a79120e16d131e6c1a759 /www/py-spyne
parentf028d4118bfcd78d5e1bb92d8dc9fb40bd3d0328 (diff)
downloadfreebsd-ports-gnome-ad9c5e72c063fd2001b42cfbb2fcc63cb86019d7.tar.gz
freebsd-ports-gnome-ad9c5e72c063fd2001b42cfbb2fcc63cb86019d7.tar.zst
freebsd-ports-gnome-ad9c5e72c063fd2001b42cfbb2fcc63cb86019d7.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Diffstat (limited to 'www/py-spyne')
-rw-r--r--www/py-spyne/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/www/py-spyne/Makefile b/www/py-spyne/Makefile
index 3b2b8046bf1a..2824856ea993 100644
--- a/www/py-spyne/Makefile
+++ b/www/py-spyne/Makefile
@@ -12,10 +12,10 @@ COMMENT= Transport and architecture agnostic RPC library
LICENSE= LGPL21
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytz>=0:devel/py-pytz
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytz>=0:devel/py-pytz@${FLAVOR}
NO_ARCH= yes
USE_PYTHON= autoplist concurrent distutils
-USES= python
+USES= python:2.7
.include <bsd.port.mk>