aboutsummaryrefslogtreecommitdiffstats
path: root/www/qdecoder
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2004-03-15 19:33:34 +0800
committerkris <kris@FreeBSD.org>2004-03-15 19:33:34 +0800
commita77b2fd207effe28441720efd4e75a70e58c8854 (patch)
tree2e12ae3a25184e46bb62589f25da0b0108bd2ccd /www/qdecoder
parentf3cccf2ffbc894acd0973f4d33927d51583d518a (diff)
downloadfreebsd-ports-gnome-a77b2fd207effe28441720efd4e75a70e58c8854.tar.gz
freebsd-ports-gnome-a77b2fd207effe28441720efd4e75a70e58c8854.tar.zst
freebsd-ports-gnome-a77b2fd207effe28441720efd4e75a70e58c8854.zip
Fix build on amd64 (compile shared library objects with -fPIC)
Diffstat (limited to 'www/qdecoder')
-rw-r--r--www/qdecoder/files/patch-src::Makefile.in52
1 files changed, 52 insertions, 0 deletions
diff --git a/www/qdecoder/files/patch-src::Makefile.in b/www/qdecoder/files/patch-src::Makefile.in
new file mode 100644
index 000000000000..7dd1215598d4
--- /dev/null
+++ b/www/qdecoder/files/patch-src::Makefile.in
@@ -0,0 +1,52 @@
+--- src/Makefile.in.orig Mon Mar 15 03:30:00 2004
++++ src/Makefile.in Mon Mar 15 03:31:47 2004
+@@ -90,11 +90,36 @@
+ qInternalEntry.o \
+ md5/md5c.o
+
++# Shared objects List
++SHOBJ = qDecoder.So \
++ qSession.So \
++ qfDecoder.So \
++ qsDecoder.So \
++ qHttpHeader.So \
++ qError.So \
++ qEnv.So \
++ qEncode.So \
++ qString.So \
++ qFile.So \
++ qValid.So \
++ qArg.So \
++ qAwk.So \
++ qSed.So \
++ qCount.So \
++ qDownload.So \
++ qTime.So \
++ qMisc.So \
++ qInternalCommon.So \
++ qInternalEntry.So \
++ md5/md5c.So
++
++.SUFFIXES: .o .So
++
+ ## Make Library
+-all: ${OBJ}
++all: ${OBJ} ${SHOBJ}
+ ${AR} ${ARFLAGS} ${LIBNAME} ${OBJ}
+ ${RANLIB} ${LIBNAME}
+- ${LD} ${LDFLAGS} -o ${SLIBREALNAME} ${OBJ}
++ ${LD} ${LDFLAGS} -o ${SLIBREALNAME} ${SHOBJ}
+ ${CHMOD} 0644 ${SLIBREALNAME}
+ ${RM} -f ${SLIBNAME}
+ ${LN_S} ${SLIBREALNAME} ${SLIBNAME}
+@@ -102,6 +127,10 @@
+ ## Compile Module
+ .c.o:
+ ${CC} ${CFLAGS} ${DEFS} ${INCLUDE} -c -o $@ $<
++
++## Compile PIC Module
++.c.So:
++ ${CC} ${CFLAGS} -fPIC ${DEFS} ${INCLUDE} -c -o $@ $<
+
+ ## Install Module
+ install: all