aboutsummaryrefslogtreecommitdiffstats
path: root/www/qooxdoo/Makefile
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2011-04-10 00:32:19 +0800
committernivit <nivit@FreeBSD.org>2011-04-10 00:32:19 +0800
commit2de2b6f0fd790fa4236906de6d11fe7abe63b83d (patch)
tree3d1217c9f8863f9692215dbce982210d2be5f1a7 /www/qooxdoo/Makefile
parent8fbac85d7b8ef855e0e561831c00316bd48b71be (diff)
downloadfreebsd-ports-gnome-2de2b6f0fd790fa4236906de6d11fe7abe63b83d.tar.gz
freebsd-ports-gnome-2de2b6f0fd790fa4236906de6d11fe7abe63b83d.tar.zst
freebsd-ports-gnome-2de2b6f0fd790fa4236906de6d11fe7abe63b83d.zip
- Update to 1.4
Diffstat (limited to 'www/qooxdoo/Makefile')
-rw-r--r--www/qooxdoo/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/www/qooxdoo/Makefile b/www/qooxdoo/Makefile
index b8e07059fd07..697d1b08f753 100644
--- a/www/qooxdoo/Makefile
+++ b/www/qooxdoo/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= qooxdoo
-PORTVERSION= 1.3
-#PORTREVISION= 0
+PORTVERSION= 1.4
+PORTREVISION= 0
CATEGORIES= www devel
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-current/${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-sdk
@@ -27,6 +27,8 @@ REINPLACE_ARGS= -i.bak -e 's,/usr/bin/env python,&${PYTHON_VER},'
USE_PYTHON= -2.7
USE_ZIP= yes
+SHAREMODE= 644
+
XARGS_ARGS= -0
post-patch:
@@ -44,6 +46,7 @@ do-install:
.if !defined(NOPORTEXAMPLES)
cd ${WRKSRC}/application && ${COPYTREE_SHARE} . ${EXAMPLESDIR}
.endif
- ${LN} -s ${DATADIR}/tool/bin/create-application.py ${PREFIX}/bin/create-application.py
+ ${INSTALL_DATA} ${WRKSRC}/version.txt ${DATADIR}
+ ${CHMOD} ${BINMODE} ${DATADIR}/tool/bin/*.py
.include <bsd.port.mk>