aboutsummaryrefslogtreecommitdiffstats
path: root/www/qooxdoo/Makefile
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2011-08-03 21:47:30 +0800
committernivit <nivit@FreeBSD.org>2011-08-03 21:47:30 +0800
commitdab38d07cf351b6589c9ed619ff26037fa8786e9 (patch)
tree7b10c6728e841da9c9a3bcb2b38c5fcaff02b9ea /www/qooxdoo/Makefile
parentf03afc0f625282e275442c127a6b0b79a43e54d1 (diff)
downloadfreebsd-ports-gnome-dab38d07cf351b6589c9ed619ff26037fa8786e9.tar.gz
freebsd-ports-gnome-dab38d07cf351b6589c9ed619ff26037fa8786e9.tar.zst
freebsd-ports-gnome-dab38d07cf351b6589c9ed619ff26037fa8786e9.zip
- Update to 1.5
- Install bytecode of all Python files under ${DATADIR}/tool/bin
Diffstat (limited to 'www/qooxdoo/Makefile')
-rw-r--r--www/qooxdoo/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/www/qooxdoo/Makefile b/www/qooxdoo/Makefile
index 697d1b08f753..f53d46cb592b 100644
--- a/www/qooxdoo/Makefile
+++ b/www/qooxdoo/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= qooxdoo
-PORTVERSION= 1.4
+PORTVERSION= 1.5
PORTREVISION= 0
CATEGORIES= www devel
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-current/${PORTVERSION}/
@@ -18,8 +18,6 @@ COMMENT= A comprehensive and innovative Ajax application framework
FIND_FILES= ${WRKSRC} -type f -name "*.py" -print0
FIND_FILES_BAK= ${WRKSRC} -type f -and \( -name "*.orig" -or -name "*.bak" \)
-NO_BUILD= yes
-
QXDDIRS= component framework tool
REINPLACE_ARGS= -i.bak -e 's,/usr/bin/env python,&${PYTHON_VER},'
@@ -35,6 +33,10 @@ post-patch:
${FIND} ${FIND_FILES} | ${XARGS} ${XARGS_ARGS} ${REINPLACE_CMD}
${FIND} ${FIND_FILES_BAK} -delete
+do-build:
+ ${PYTHON_CMD} -m compileall -f ${WRKSRC}/tool/bin
+ ${PYTHON_CMD} -O -m compileall -f ${WRKSRC}/tool/bin
+
do-install:
${MKDIR} ${DATADIR}
.for D in ${QXDDIRS}