aboutsummaryrefslogtreecommitdiffstats
path: root/www/quanta
diff options
context:
space:
mode:
authoralane <alane@FreeBSD.org>2002-09-28 05:09:00 +0800
committeralane <alane@FreeBSD.org>2002-09-28 05:09:00 +0800
commite485b8ee6ad2f71ecffb7821c8d5f9a8c6383b80 (patch)
treef92742236fde8ac4b2f41f3cefba43dda5a1bbbb /www/quanta
parent53ef0ccddbf59dcb599e70fa6fa2b1af79c8cf7a (diff)
downloadfreebsd-ports-gnome-e485b8ee6ad2f71ecffb7821c8d5f9a8c6383b80.tar.gz
freebsd-ports-gnome-e485b8ee6ad2f71ecffb7821c8d5f9a8c6383b80.tar.zst
freebsd-ports-gnome-e485b8ee6ad2f71ecffb7821c8d5f9a8c6383b80.zip
1. Fixed broken current build, and a warning on stable.
2. Changed a lib dep to a build dep only. 3. Bumped portrevision because of dependency change (sorry people, I know I'm thrashing you....) Submitted by: Mikhail Teterin <mi+mx@aldan.algebra.com> Approved by: Kris (approved fixing quanta, tell me if you want to back out, kris)
Diffstat (limited to 'www/quanta')
-rw-r--r--www/quanta/Makefile4
-rw-r--r--www/quanta/files/patch-quanta-plugins-phph4dbg-dbgbase-dbg_core.c6
2 files changed, 8 insertions, 2 deletions
diff --git a/www/quanta/Makefile b/www/quanta/Makefile
index df6c7810fed8..303ec9e350cd 100644
--- a/www/quanta/Makefile
+++ b/www/quanta/Makefile
@@ -10,7 +10,7 @@
PORTNAME= quanta
PORTVERSION= 3.0
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 2 # dammit! I hate this kludge.
CATEGORIES= www kde
@@ -26,7 +26,7 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
MAINTAINER= alane@freebsd.org
-LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
+BUILD_DEPENDS= xgettext:${PORTSDIR}/devel/gettext
USE_KDELIBS_VER=3
USE_XPM= yes
diff --git a/www/quanta/files/patch-quanta-plugins-phph4dbg-dbgbase-dbg_core.c b/www/quanta/files/patch-quanta-plugins-phph4dbg-dbgbase-dbg_core.c
new file mode 100644
index 000000000000..d9b8c361c30f
--- /dev/null
+++ b/www/quanta/files/patch-quanta-plugins-phph4dbg-dbgbase-dbg_core.c
@@ -0,0 +1,6 @@
+--- quanta/plugins/php4dbg/dbgbase/dbg_core.c Sat Apr 21 09:48:32 2001
++++ quanta/plugins/php4dbg/dbgbase/dbg_core.c Fri Sep 27 14:12:29 2002
+@@ -15,3 +15,2 @@
+ #include <string.h>
+-#include <malloc.h>
+ #include <stdlib.h>