aboutsummaryrefslogtreecommitdiffstats
path: root/www/redmine
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-01-10 14:41:12 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-01-10 14:41:12 +0800
commit66078928b69bb8ba9854bdf682162c92a873490f (patch)
tree24e45f7871bc003c689c88feff4e2283e5376963 /www/redmine
parent7981c382033ecf21abe6cca47e566b48622f59a4 (diff)
downloadfreebsd-ports-gnome-66078928b69bb8ba9854bdf682162c92a873490f.tar.gz
freebsd-ports-gnome-66078928b69bb8ba9854bdf682162c92a873490f.tar.zst
freebsd-ports-gnome-66078928b69bb8ba9854bdf682162c92a873490f.zip
Update to 3.4.4
Changes: https://redmine.org/projects/redmine/wiki/Changelog
Diffstat (limited to 'www/redmine')
-rw-r--r--www/redmine/Makefile5
-rw-r--r--www/redmine/distinfo6
-rw-r--r--www/redmine/files/patch-Gemfile17
-rw-r--r--www/redmine/pkg-plist4
4 files changed, 20 insertions, 12 deletions
diff --git a/www/redmine/Makefile b/www/redmine/Makefile
index 6974fff4ac4d..7b46af76ac90 100644
--- a/www/redmine/Makefile
+++ b/www/redmine/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= redmine
-PORTVERSION= 3.4.3
+PORTVERSION= 3.4.4
CATEGORIES= www
MASTER_SITES= http://www.redmine.org/releases/
@@ -23,7 +23,8 @@ RUN_DEPENDS= rubygem-bundler>=1.5.0:sysutils/rubygem-bundler \
rubygem-roadie-rails>=1.2.0:mail/rubygem-roadie-rails \
rubygem-roadie>=3.2.1:mail/rubygem-roadie \
rubygem-mimemagic>=0:misc/rubygem-mimemagic \
- rubygem-nokogiri>=1.7.2:textproc/rubygem-nokogiri \
+ rubygem-mail>=2.6.4:mail/rubygem-mail \
+ rubygem-nokogiri>=1.8.1:textproc/rubygem-nokogiri \
rubygem-i18n>=0.8.5:devel/rubygem-i18n \
rubygem-ffi>=1.9.14:devel/rubygem-ffi \
rubygem-rails-html-sanitizer>=1.0.3:textproc/rubygem-rails-html-sanitizer \
diff --git a/www/redmine/distinfo b/www/redmine/distinfo
index e66ecf5821fc..19012f647e79 100644
--- a/www/redmine/distinfo
+++ b/www/redmine/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1512997860
-SHA256 (redmine-3.4.3.tar.gz) = 62c3ea32491a13db294237ff7ade5a447e0d2913204eb871ab3a99414e41f63d
-SIZE (redmine-3.4.3.tar.gz) = 2442818
+TIMESTAMP = 1515554053
+SHA256 (redmine-3.4.4.tar.gz) = ce3a43d89303575575e59b790d9316e2f554d126d166212648ce51039d2065b4
+SIZE (redmine-3.4.4.tar.gz) = 2447358
diff --git a/www/redmine/files/patch-Gemfile b/www/redmine/files/patch-Gemfile
index 0e8ceb149903..47467ab469af 100644
--- a/www/redmine/files/patch-Gemfile
+++ b/www/redmine/files/patch-Gemfile
@@ -1,12 +1,15 @@
---- Gemfile.orig 2017-07-16 18:18:29 UTC
+--- Gemfile.orig 2018-01-08 19:38:18 UTC
+++ Gemfile
-@@ -4,20 +4,20 @@ if Gem::Version.new(Bundler::VERSION) <
+@@ -4,24 +4,24 @@ if Gem::Version.new(Bundler::VERSION) <
abort "Redmine requires Bundler 1.5.0 or higher (you're using #{Bundler::VERSION}).\nPlease update with 'gem update bundler'."
end
-gem "rails", "4.2.8"
+gem "rails", ">= 4.2.8"
gem "addressable", "2.4.0" if RUBY_VERSION < "2.0"
+ if RUBY_VERSION < "2.1"
+ gem "public_suffix", (RUBY_VERSION < "2.0" ? "~> 1.4" : "~> 2.0.5")
+ end
-gem "jquery-rails", "~> 3.1.4"
+gem "jquery-rails", ">= 3.1.4"
gem "coderay", "~> 1.1.1"
@@ -19,15 +22,15 @@
+gem "roadie-rails", "~> 1.1", ">= 1.1.1"
gem "roadie", "~> 3.2.1"
gem "mimemagic"
+ gem "mail", "~> 2.6.4"
--gem "nokogiri", (RUBY_VERSION >= "2.1" ? "~> 1.7.2" : "~> 1.6.8")
+ gem "nokogiri", (RUBY_VERSION >= "2.1" ? "~> 1.8.1" : "~> 1.6.8")
-gem "i18n", "~> 0.7.0"
-+gem "nokogiri"
+gem "i18n", "~> 0.7"
gem "ffi", "1.9.14", :platforms => :mingw if RUBY_VERSION < "2.0"
# Request at least rails-html-sanitizer 1.0.3 because of security advisories
-@@ -29,27 +29,15 @@ gem "rbpdf", "~> 1.19.3"
+@@ -33,27 +33,15 @@ gem "rbpdf", "~> 1.19.3"
# Optional gem for LDAP authentication
group :ldap do
@@ -57,7 +60,7 @@
# Include database gems for the adapters found in the database
# configuration file
require 'erb'
-@@ -82,23 +70,6 @@ else
+@@ -86,23 +74,6 @@ else
warn("Please configure your config/database.yml first")
end
@@ -81,7 +84,7 @@
local_gemfile = File.join(File.dirname(__FILE__), "Gemfile.local")
if File.exists?(local_gemfile)
eval_gemfile local_gemfile
-@@ -108,3 +79,7 @@ end
+@@ -112,3 +83,7 @@ end
Dir.glob File.expand_path("../plugins/*/{Gemfile,PluginGemfile}", __FILE__) do |file|
eval_gemfile file
end
diff --git a/www/redmine/pkg-plist b/www/redmine/pkg-plist
index 34d96b72f232..de3067dae317 100644
--- a/www/redmine/pkg-plist
+++ b/www/redmine/pkg-plist
@@ -1413,6 +1413,7 @@
%%WWWDIR%%/public/images/2downarrow.png
%%WWWDIR%%/public/images/2uparrow.png
%%WWWDIR%%/public/images/add.png
+%%WWWDIR%%/public/images/anonymous.png
%%WWWDIR%%/public/images/arrow_collapsed.png
%%WWWDIR%%/public/images/arrow_down.png
%%WWWDIR%%/public/images/arrow_expanded.png
@@ -1777,6 +1778,7 @@
%%WWWDIR%%/test/fixtures/mail_handler/ticket_with_cc.eml
%%WWWDIR%%/test/fixtures/mail_handler/ticket_with_custom_fields.eml
%%WWWDIR%%/test/fixtures/mail_handler/ticket_with_duplicate_keyword.eml
+%%WWWDIR%%/test/fixtures/mail_handler/ticket_with_empty_attachment.eml
%%WWWDIR%%/test/fixtures/mail_handler/ticket_with_invalid_attributes.eml
%%WWWDIR%%/test/fixtures/mail_handler/ticket_with_keyword_after_delimiter.eml
%%WWWDIR%%/test/fixtures/mail_handler/ticket_with_localized_attributes.eml
@@ -1818,6 +1820,7 @@
%%WWWDIR%%/test/functional/activities_controller_test.rb
%%WWWDIR%%/test/functional/admin_controller_test.rb
%%WWWDIR%%/test/functional/attachments_controller_test.rb
+%%WWWDIR%%/test/functional/attachments_visibility_test.rb
%%WWWDIR%%/test/functional/auth_sources_controller_test.rb
%%WWWDIR%%/test/functional/auto_completes_controller_test.rb
%%WWWDIR%%/test/functional/boards_controller_test.rb
@@ -2031,6 +2034,7 @@
%%WWWDIR%%/test/unit/lib/redmine/export/csv_test.rb
%%WWWDIR%%/test/unit/lib/redmine/export/pdf_test.rb
%%WWWDIR%%/test/unit/lib/redmine/field_format/attachment_format_test.rb
+%%WWWDIR%%/test/unit/lib/redmine/field_format/attachment_format_visibility_test.rb
%%WWWDIR%%/test/unit/lib/redmine/field_format/bool_format_test.rb
%%WWWDIR%%/test/unit/lib/redmine/field_format/enumeration_format_test.rb
%%WWWDIR%%/test/unit/lib/redmine/field_format/field_format_test.rb