aboutsummaryrefslogtreecommitdiffstats
path: root/www/rt3/Makefile
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2003-05-08 23:15:06 +0800
committerdemon <demon@FreeBSD.org>2003-05-08 23:15:06 +0800
commit38b2de037908e49e3a2a594a6cd1053b4a282120 (patch)
tree699f92432e2ef5da5fc6effaf78cbab9e7df98fd /www/rt3/Makefile
parenta4c551125d7133a670ecdf6c5cf0652f8fabc220 (diff)
downloadfreebsd-ports-gnome-38b2de037908e49e3a2a594a6cd1053b4a282120.tar.gz
freebsd-ports-gnome-38b2de037908e49e3a2a594a6cd1053b4a282120.tar.zst
freebsd-ports-gnome-38b2de037908e49e3a2a594a6cd1053b4a282120.zip
Create group 'rt' in pre-install phase, rather than post-extract.
Approved by: maintainer
Diffstat (limited to 'www/rt3/Makefile')
-rw-r--r--www/rt3/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/www/rt3/Makefile b/www/rt3/Makefile
index 7470ff1fae1e..e2b0056438d4 100644
--- a/www/rt3/Makefile
+++ b/www/rt3/Makefile
@@ -107,7 +107,6 @@ DB_DBA_PASSWORD?=
WEB_USER?= www
WEB_GROUP?= www
LIBS_GROUP?= wheel
-RT_GROUP?= rt
pre-fetch:
@${ECHO} ""
@@ -123,8 +122,11 @@ pre-fetch:
@${ECHO} ""
post-extract:
- -@pw groupadd ${RT_GROUP}
- -@cd ${WRKSRC} && chmod a+x configure
+ -@${CHMOD} a+x ${WRKSRC}/configure
+
+pre-install:
+ PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} \
+ ${PKGNAME} PRE-INSTALL
do-install:
@cd ${WRKSRC} && ${MAKE} install