aboutsummaryrefslogtreecommitdiffstats
path: root/www/rt32/Makefile
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2003-08-25 14:51:56 +0800
committerdemon <demon@FreeBSD.org>2003-08-25 14:51:56 +0800
commit8dd05668fce91d0923e16b75cab457bc871509da (patch)
treeab1ebb9364e7e7d9a6868e1b281aa4d4b8e00069 /www/rt32/Makefile
parente0c07041021de6089bd42a9260753b08eeaeb871 (diff)
downloadfreebsd-ports-gnome-8dd05668fce91d0923e16b75cab457bc871509da.tar.gz
freebsd-ports-gnome-8dd05668fce91d0923e16b75cab457bc871509da.tar.zst
freebsd-ports-gnome-8dd05668fce91d0923e16b75cab457bc871509da.zip
Correct dependencies when building with FastCGI and Apache2.
Submitted by: Rob Austein <sra@hactrn.net> via maintainer.
Diffstat (limited to 'www/rt32/Makefile')
-rw-r--r--www/rt32/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/www/rt32/Makefile b/www/rt32/Makefile
index ed1711b60f78..2908e9eb253b 100644
--- a/www/rt32/Makefile
+++ b/www/rt32/Makefile
@@ -69,9 +69,14 @@ CONFIGURE_ARGS= --prefix=${RT_PATH} \
--with-db-dba=${DB_DBA_USER}
.if defined(WITH_FASTCGI)
+.if defined(WITH_APACHE2)
+APACHE_PORT?= ${PORTSDIR}/www/apache2
+BUILD_DEPENDS+= ${LOCALBASE}/libexec/apache2/mod_fastcgi.so:${PORTSDIR}/www/mod_fastcgi
+.else
APACHE_PORT?= ${PORTSDIR}/www/apache13
-BUILD_DEPENDS+= ${LOCALBASE}/libexec/apache/mod_fastcgi.so:${PORTSDIR}/www/mod_fastcgi \
- ${ARCH_PERL}/FCGI.pm:${PORTSDIR}/www/p5-FastCGI
+BUILD_DEPENDS+= ${LOCALBASE}/libexec/apache/mod_fastcgi.so:${PORTSDIR}/www/mod_fastcgi
+.endif
+BUILD_DEPENDS+= ${ARCH_PERL}/FCGI.pm:${PORTSDIR}/www/p5-FastCGI
DEPENDS_ARGS+= WITHOUT_MODPERL=yes
.else
BUILD_DEPENDS+= ${SITE_PERL}/Apache/DBI.pm:${PORTSDIR}/www/p5-Apache-DBI