aboutsummaryrefslogtreecommitdiffstats
path: root/www/rt32
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2003-11-10 22:11:01 +0800
committerdemon <demon@FreeBSD.org>2003-11-10 22:11:01 +0800
commit2bde8c4d81bb7f92bcf335a7437b2ddd308c1d71 (patch)
tree676b35181d265148556f83aadda97f0e7f8393ac /www/rt32
parent2ef2660ee85862548146a69687549738474dad59 (diff)
downloadfreebsd-ports-gnome-2bde8c4d81bb7f92bcf335a7437b2ddd308c1d71.tar.gz
freebsd-ports-gnome-2bde8c4d81bb7f92bcf335a7437b2ddd308c1d71.tar.zst
freebsd-ports-gnome-2bde8c4d81bb7f92bcf335a7437b2ddd308c1d71.zip
Do not force users to install MySQL server on the same machine;
Add Oracle and SQLite as possible DB types. Submitted by: maintainer
Diffstat (limited to 'www/rt32')
-rw-r--r--www/rt32/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/www/rt32/Makefile b/www/rt32/Makefile
index d3ca06a87436..7fbfd5d2671f 100644
--- a/www/rt32/Makefile
+++ b/www/rt32/Makefile
@@ -89,13 +89,19 @@ BUILD_DEPENDS+= ${LOCALBASE}/libexec/apache/libperl.so:${PORTSDIR}/www/mod_perl
DB_TYPE?= mysql
+.if ${DB_TYPE} == "Oracle"
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Oracle.pm:${PORTSDIR}/databases/p5-DBD-Oracle
+.else
.if ${DB_TYPE} == "Pg"
-BUILD_DEPENDS+= ${LOCALBASE}/bin/psql:${PORTSDIR}/databases/postgresql7 \
- ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
+.else
+.if ${DB_TYPE} == "SQLite"
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/SQLite.pm:${PORTSDIR}/databases/p5-DBD-SQLite
.else
DB_TYPE= mysql
-BUILD_DEPENDS+= ${LOCALBASE}/bin/mysql_config:${PORTSDIR}/databases/mysql40-server \
- ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
+.endif
+.endif
.endif
USE_PERL5= yes
@@ -114,7 +120,7 @@ pre-fetch:
@${ECHO} ""
@${ECHO} "You may use the following build options:"
@${ECHO} ""
- @${ECHO} " DB_TYPE=type Pg for postgresql, mysql for MySQL (mysql)"
+ @${ECHO} " DB_TYPE=type mysql, Oracle, Pg or SQLite (mysql)"
@${ECHO} " DB_HOST=hostname The database host (localhost)"
@${ECHO} " DB_PORT=port The database port"
@${ECHO} " DB_DBA_USER=password Name of database administrator (root)"