aboutsummaryrefslogtreecommitdiffstats
path: root/www/rubygem-thin
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2008-01-24 14:27:00 +0800
committerclsung <clsung@FreeBSD.org>2008-01-24 14:27:00 +0800
commitee7425a04298e8458e8dbb1dae253558f79099ea (patch)
tree97c6b69f80eb489f137d45d58a85c962838a6557 /www/rubygem-thin
parent6e323b1ca8ae8fa6ba866089c60ab2bbea9a21ec (diff)
downloadfreebsd-ports-gnome-ee7425a04298e8458e8dbb1dae253558f79099ea.tar.gz
freebsd-ports-gnome-ee7425a04298e8458e8dbb1dae253558f79099ea.tar.zst
freebsd-ports-gnome-ee7425a04298e8458e8dbb1dae253558f79099ea.zip
Thin is a Ruby web server that glues together 3 of the best
Ruby libraries in web history: * the Mongrel parser, the root of Mongrel speed and security * Event Machine, a network I/O library with extremely high scalability, performance and stability * Rack, a minimal interface between webservers and Ruby frameworks Which makes it, with all humility, the most secure, stable, fast and extensible Ruby web server bundled in an easy to use gem for your own pleasure. WWW: http://code.macournoyer.com/thin/
Diffstat (limited to 'www/rubygem-thin')
-rw-r--r--www/rubygem-thin/Makefile22
-rw-r--r--www/rubygem-thin/distinfo3
-rw-r--r--www/rubygem-thin/pkg-descr13
-rw-r--r--www/rubygem-thin/pkg-plist117
4 files changed, 155 insertions, 0 deletions
diff --git a/www/rubygem-thin/Makefile b/www/rubygem-thin/Makefile
new file mode 100644
index 000000000000..30f58b03e848
--- /dev/null
+++ b/www/rubygem-thin/Makefile
@@ -0,0 +1,22 @@
+# Ports collection makefile for: thin
+# Date created: 24 Jan 2008
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= thin
+PORTVERSION= 0.5.4
+CATEGORIES= www rubygems
+MASTER_SITES= RF
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= A fast and very simple Ruby web server
+
+BUILD_DEPENDS= rackup:${PORTSDIR}/www/rubygem-rack \
+ rubygem-eventmachine>=0.8.1:${PORTSDIR}/devel/rubygem-eventmachine \
+ rubygem-daemons>=1.0.9:${PORTSDIR}/devel/rubygem-daemons
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/www/rubygem-thin/distinfo b/www/rubygem-thin/distinfo
new file mode 100644
index 000000000000..3d4d4c03fece
--- /dev/null
+++ b/www/rubygem-thin/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/thin-0.5.4.gem) = 11229d2c24a363b8fd5eb63524a53ee9
+SHA256 (rubygem/thin-0.5.4.gem) = ad51a39f54bf86f13d3f317673670b090b9c1ca54bf2b4deef76b14094ea46e2
+SIZE (rubygem/thin-0.5.4.gem) = 97280
diff --git a/www/rubygem-thin/pkg-descr b/www/rubygem-thin/pkg-descr
new file mode 100644
index 000000000000..8c805bf7ec47
--- /dev/null
+++ b/www/rubygem-thin/pkg-descr
@@ -0,0 +1,13 @@
+Thin is a Ruby web server that glues together 3 of the best
+Ruby libraries in web history:
+
+* the Mongrel parser, the root of Mongrel speed and security
+* Event Machine, a network I/O library with extremely high scalability,
+ performance and stability
+* Rack, a minimal interface between webservers and Ruby frameworks
+
+Which makes it, with all humility, the most secure, stable, fast and
+extensible Ruby web server bundled in an easy to use gem for your own
+pleasure.
+
+WWW: http://code.macournoyer.com/thin/
diff --git a/www/rubygem-thin/pkg-plist b/www/rubygem-thin/pkg-plist
new file mode 100644
index 000000000000..8b3d187bda53
--- /dev/null
+++ b/www/rubygem-thin/pkg-plist
@@ -0,0 +1,117 @@
+bin/thin
+%%GEM_CACHE%%
+%%GEM_LIB_DIR%%/CHANGELOG
+%%GEM_LIB_DIR%%/COPYING
+%%GEM_LIB_DIR%%/README
+%%GEM_LIB_DIR%%/Rakefile
+%%GEM_LIB_DIR%%/benchmark/previous.rb
+%%GEM_LIB_DIR%%/benchmark/simple.rb
+%%GEM_LIB_DIR%%/benchmark/utils.rb
+%%GEM_LIB_DIR%%/bin/thin
+%%GEM_LIB_DIR%%/doc/benchmarks.txt
+%%GEM_LIB_DIR%%/example/config.ru
+%%GEM_LIB_DIR%%/example/thin.god
+%%GEM_LIB_DIR%%/ext/thin_parser/Makefile
+%%GEM_LIB_DIR%%/ext/thin_parser/common.rl
+%%GEM_LIB_DIR%%/ext/thin_parser/ext_help.h
+%%GEM_LIB_DIR%%/ext/thin_parser/extconf.rb
+%%GEM_LIB_DIR%%/ext/thin_parser/mkmf.log
+%%GEM_LIB_DIR%%/ext/thin_parser/parser.c
+%%GEM_LIB_DIR%%/ext/thin_parser/parser.h
+%%GEM_LIB_DIR%%/ext/thin_parser/parser.o
+%%GEM_LIB_DIR%%/ext/thin_parser/parser.rl
+%%GEM_LIB_DIR%%/ext/thin_parser/thin.c
+%%GEM_LIB_DIR%%/ext/thin_parser/thin.o
+%%GEM_LIB_DIR%%/ext/thin_parser/thin_parser.so
+%%GEM_LIB_DIR%%/lib/rack/adapter/rails.rb
+%%GEM_LIB_DIR%%/lib/rack/handler/thin.rb
+%%GEM_LIB_DIR%%/lib/thin.rb
+%%GEM_LIB_DIR%%/lib/thin/cluster.rb
+%%GEM_LIB_DIR%%/lib/thin/connection.rb
+%%GEM_LIB_DIR%%/lib/thin/daemonizing.rb
+%%GEM_LIB_DIR%%/lib/thin/headers.rb
+%%GEM_LIB_DIR%%/lib/thin/logging.rb
+%%GEM_LIB_DIR%%/lib/thin/request.rb
+%%GEM_LIB_DIR%%/lib/thin/response.rb
+%%GEM_LIB_DIR%%/lib/thin/server.rb
+%%GEM_LIB_DIR%%/lib/thin/statuses.rb
+%%GEM_LIB_DIR%%/lib/thin/version.rb
+%%GEM_LIB_DIR%%/lib/thin_parser.so
+%%GEM_LIB_DIR%%/spec/cluster_spec.rb
+%%GEM_LIB_DIR%%/spec/daemonizing_spec.rb
+%%GEM_LIB_DIR%%/spec/headers_spec.rb
+%%GEM_LIB_DIR%%/spec/rack_rails_spec.rb
+%%GEM_LIB_DIR%%/spec/rails_app/app/controllers/application.rb
+%%GEM_LIB_DIR%%/spec/rails_app/app/controllers/simple_controller.rb
+%%GEM_LIB_DIR%%/spec/rails_app/app/helpers/application_helper.rb
+%%GEM_LIB_DIR%%/spec/rails_app/app/views/simple/index.html.erb
+%%GEM_LIB_DIR%%/spec/rails_app/config/boot.rb
+%%GEM_LIB_DIR%%/spec/rails_app/config/environment.rb
+%%GEM_LIB_DIR%%/spec/rails_app/config/environments/development.rb
+%%GEM_LIB_DIR%%/spec/rails_app/config/environments/production.rb
+%%GEM_LIB_DIR%%/spec/rails_app/config/environments/test.rb
+%%GEM_LIB_DIR%%/spec/rails_app/config/initializers/inflections.rb
+%%GEM_LIB_DIR%%/spec/rails_app/config/initializers/mime_types.rb
+%%GEM_LIB_DIR%%/spec/rails_app/config/routes.rb
+%%GEM_LIB_DIR%%/spec/rails_app/public/404.html
+%%GEM_LIB_DIR%%/spec/rails_app/public/422.html
+%%GEM_LIB_DIR%%/spec/rails_app/public/500.html
+%%GEM_LIB_DIR%%/spec/rails_app/public/dispatch.cgi
+%%GEM_LIB_DIR%%/spec/rails_app/public/dispatch.fcgi
+%%GEM_LIB_DIR%%/spec/rails_app/public/dispatch.rb
+%%GEM_LIB_DIR%%/spec/rails_app/public/favicon.ico
+%%GEM_LIB_DIR%%/spec/rails_app/public/images/rails.png
+%%GEM_LIB_DIR%%/spec/rails_app/public/index.html
+%%GEM_LIB_DIR%%/spec/rails_app/public/javascripts/application.js
+%%GEM_LIB_DIR%%/spec/rails_app/public/javascripts/controls.js
+%%GEM_LIB_DIR%%/spec/rails_app/public/javascripts/dragdrop.js
+%%GEM_LIB_DIR%%/spec/rails_app/public/javascripts/effects.js
+%%GEM_LIB_DIR%%/spec/rails_app/public/javascripts/prototype.js
+%%GEM_LIB_DIR%%/spec/rails_app/public/robots.txt
+%%GEM_LIB_DIR%%/spec/rails_app/script/about
+%%GEM_LIB_DIR%%/spec/rails_app/script/console
+%%GEM_LIB_DIR%%/spec/rails_app/script/destroy
+%%GEM_LIB_DIR%%/spec/rails_app/script/generate
+%%GEM_LIB_DIR%%/spec/rails_app/script/performance/benchmarker
+%%GEM_LIB_DIR%%/spec/rails_app/script/performance/profiler
+%%GEM_LIB_DIR%%/spec/rails_app/script/performance/request
+%%GEM_LIB_DIR%%/spec/rails_app/script/plugin
+%%GEM_LIB_DIR%%/spec/rails_app/script/process/inspector
+%%GEM_LIB_DIR%%/spec/rails_app/script/process/reaper
+%%GEM_LIB_DIR%%/spec/rails_app/script/process/spawner
+%%GEM_LIB_DIR%%/spec/rails_app/script/runner
+%%GEM_LIB_DIR%%/spec/rails_app/script/server
+%%GEM_LIB_DIR%%/spec/request_spec.rb
+%%GEM_LIB_DIR%%/spec/response_spec.rb
+%%GEM_LIB_DIR%%/spec/server_spec.rb
+%%GEM_LIB_DIR%%/spec/spec_helper.rb
+%%GEM_SPEC%%
+@dirrm %%GEM_LIB_DIR%%/spec/rails_app/script/process
+@dirrm %%GEM_LIB_DIR%%/spec/rails_app/script/performance
+@dirrm %%GEM_LIB_DIR%%/spec/rails_app/script
+@dirrm %%GEM_LIB_DIR%%/spec/rails_app/public/javascripts
+@dirrm %%GEM_LIB_DIR%%/spec/rails_app/public/images
+@dirrm %%GEM_LIB_DIR%%/spec/rails_app/public
+@dirrm %%GEM_LIB_DIR%%/spec/rails_app/config/initializers
+@dirrm %%GEM_LIB_DIR%%/spec/rails_app/config/environments
+@dirrm %%GEM_LIB_DIR%%/spec/rails_app/config
+@dirrm %%GEM_LIB_DIR%%/spec/rails_app/app/views/simple
+@dirrm %%GEM_LIB_DIR%%/spec/rails_app/app/views
+@dirrm %%GEM_LIB_DIR%%/spec/rails_app/app/helpers
+@dirrm %%GEM_LIB_DIR%%/spec/rails_app/app/controllers
+@dirrm %%GEM_LIB_DIR%%/spec/rails_app/app
+@dirrm %%GEM_LIB_DIR%%/spec/rails_app
+@dirrm %%GEM_LIB_DIR%%/spec
+@dirrm %%GEM_LIB_DIR%%/lib/thin
+@dirrm %%GEM_LIB_DIR%%/lib/rack/handler
+@dirrm %%GEM_LIB_DIR%%/lib/rack/adapter
+@dirrm %%GEM_LIB_DIR%%/lib/rack
+@dirrm %%GEM_LIB_DIR%%/lib
+@dirrm %%GEM_LIB_DIR%%/ext/thin_parser
+@dirrm %%GEM_LIB_DIR%%/ext
+@dirrm %%GEM_LIB_DIR%%/example
+@dirrm %%GEM_LIB_DIR%%/doc
+@dirrm %%GEM_LIB_DIR%%/bin
+@dirrm %%GEM_LIB_DIR%%/benchmark
+@dirrm %%GEM_LIB_DIR%%
+@dirrm %%GEM_DOC_DIR%%