aboutsummaryrefslogtreecommitdiffstats
path: root/www/samidare
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-05-03 03:18:35 +0800
committermiwi <miwi@FreeBSD.org>2008-05-03 03:18:35 +0800
commit52a1aa4b3de12448ec6fc7997616803dae41baae (patch)
tree4a126aff7ce92c22f6ae658dbd4cf8c789b9ca60 /www/samidare
parent6a9dd2079daae911fdc3f21ee4c8bad5da6fe064 (diff)
downloadfreebsd-ports-gnome-52a1aa4b3de12448ec6fc7997616803dae41baae.tar.gz
freebsd-ports-gnome-52a1aa4b3de12448ec6fc7997616803dae41baae.tar.zst
freebsd-ports-gnome-52a1aa4b3de12448ec6fc7997616803dae41baae.zip
samidare is a web page update checker
Features: * Easy configuration: just list up URLs. * HTML generation by template. * tDiary theme supported. * generate/read LIRS. * check page content addition to Last-Modified. WWW: http://www.a-k-r.org/samidare/ PR: ports/123236 Submitted by: TAKATSU Tomonari <tota at rtfm.jp>
Diffstat (limited to 'www/samidare')
-rw-r--r--www/samidare/Makefile50
-rw-r--r--www/samidare/distinfo3
-rw-r--r--www/samidare/pkg-descr11
-rw-r--r--www/samidare/pkg-plist2
4 files changed, 66 insertions, 0 deletions
diff --git a/www/samidare/Makefile b/www/samidare/Makefile
new file mode 100644
index 000000000000..940fcc04aca1
--- /dev/null
+++ b/www/samidare/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: samidare
+# Date created: 2008-04-30
+# Whom: TAKATSU Tomonari <tota@rtfm.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= samidare
+PORTVERSION= 0.5
+CATEGORIES= www ruby
+MASTER_SITES= http://www.a-k-r.org./samidare/
+
+MAINTAINER= tota@rtfm.jp
+COMMENT= A web page update checker written in Ruby
+
+RUN_DEPENDS= ${RUBY_SITELIBDIR}/htree.rb:${PORTSDIR}/textproc/ruby-htree
+
+USE_GMAKE= yes
+USE_RUBY= yes
+
+RUBY_REQUIRE= Ruby >= 181
+RUBY_SHEBANG_FILES= main.rb rb-link rb2rm rm2rb
+PORTDOCS= README README.ja
+PORTEXAMPLES= config.yml t.latest.html
+
+UNIQ= /usr/bin/uniq
+
+.include <bsd.port.pre.mk>
+
+.if !defined(RUBY_PROVIDED)
+IGNORE= requires Ruby 1.8.1 or later
+.endif
+
+ALL_TARGET= ${PORTNAME}
+
+post-build:
+ cd ${BUILD_WRKSRC} && \
+ ${MV} samidare samidare.orig && \
+ ${UNIQ} samidare.orig samidare
+
+do-install:
+ cd ${INSTALL_WRKSRC}; ${INSTALL_SCRIPT} ${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${EXAMPLESDIR}
+ cd ${INSTALL_WRKSRC}; ${INSTALL_DATA} ${PORTEXAMPLES} ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${INSTALL_WRKSRC}; ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/samidare/distinfo b/www/samidare/distinfo
new file mode 100644
index 000000000000..00d95c81fdc3
--- /dev/null
+++ b/www/samidare/distinfo
@@ -0,0 +1,3 @@
+MD5 (samidare-0.5.tar.gz) = 98e3005f380d5c381ff94e311499f495
+SHA256 (samidare-0.5.tar.gz) = dbb210a39ba7c1b225f49dcdd3e585a1be47595e3e2963104d91f67d8c523374
+SIZE (samidare-0.5.tar.gz) = 27161
diff --git a/www/samidare/pkg-descr b/www/samidare/pkg-descr
new file mode 100644
index 000000000000..bd38c210920a
--- /dev/null
+++ b/www/samidare/pkg-descr
@@ -0,0 +1,11 @@
+samidare is a web page update checker
+
+Features:
+ * Easy configuration: just list up URLs.
+ * HTML generation by template.
+ * tDiary theme supported.
+ * generate/read LIRS.
+ * check page content addition to Last-Modified.
+
+Author: Tanaka Akira <akr@fsij.org>
+WWW: http://www.a-k-r.org/samidare/
diff --git a/www/samidare/pkg-plist b/www/samidare/pkg-plist
new file mode 100644
index 000000000000..390f37a71ad4
--- /dev/null
+++ b/www/samidare/pkg-plist
@@ -0,0 +1,2 @@
+@comment $FreeBSD$
+bin/samidare