aboutsummaryrefslogtreecommitdiffstats
path: root/www/seamonkey/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-10-29 17:09:38 +0800
committermarcus <marcus@FreeBSD.org>2002-10-29 17:09:38 +0800
commit2745f6f946d27bb5d420bc015b0d1bff6f67b192 (patch)
treefc55fc87ba49347f11b8cda6d9097be3a5fe49eb /www/seamonkey/Makefile
parent7d615a9318d538f1abf675df46eb2c9002cbf63e (diff)
downloadfreebsd-ports-gnome-2745f6f946d27bb5d420bc015b0d1bff6f67b192.tar.gz
freebsd-ports-gnome-2745f6f946d27bb5d420bc015b0d1bff6f67b192.tar.zst
freebsd-ports-gnome-2745f6f946d27bb5d420bc015b0d1bff6f67b192.zip
* Add support for building the GTK 2 version of Mozilla (define WITH_GTK2
to do this). This feature will be used for the upcoming Galeon 1.3.0 port. [1] * Allow users to disable Composer (define WITHOUT_COMPOSER to do this) [2] Submitted by: David Magda <dmagda@magda.ca> [2] Obtained from: Galeon 1.3.0 tarball (with some modification) [1]
Diffstat (limited to 'www/seamonkey/Makefile')
-rw-r--r--www/seamonkey/Makefile20
1 files changed, 18 insertions, 2 deletions
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index 20bb805e60b1..967649fabbac 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -38,6 +38,12 @@ BROKEN= Mozilla-devel and Xft2 render the mozilla-fonts \
.endif
.endif
+.if defined(WITH_GTK2)
+LIB_DEPENDS+= gtk-x11-2.0.0:${PORTSDIR}/x11-toolkits/gtk20
+.else
+USE_GNOME= gtk12
+.endif
+
LATEST_LINK= mozilla-devel
EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude */CVS/* \
--exclude */macbuild/*\
@@ -49,7 +55,7 @@ USE_X_PREFIX= yes
USE_PERL5= yes
USE_GMAKE= yes
USE_GNOMENG= yes
-USE_GNOME= orbit gtk12
+USE_GNOME+= orbit
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= \
@@ -59,7 +65,6 @@ CONFIGURE_ARGS= \
--disable-cpp-rtti \
--enable-crypto \
--disable-debug \
- --enable-default-toolkit=gtk \
--enable-double-buffer \
--enable-dtd-debug \
--enable-jsd \
@@ -98,6 +103,17 @@ CONFIGURE_ARGS+= --enable-extensions=default,xmlterm
.endif
CONFIGURE_ENV= MOZ_INTERNAL_LIBART_LGPL=1
+.if defined(WITHOUT_COMPOSER)
+CONFIGURE_ARGS+= --disable-composer
+.endif
+
+.if defined(WITH_GTK2)
+CONFIGURE_ARGS+= --enable-default-toolkit=gtk2
+EXTRA_PATCHES= ${FILESDIR}/mozilla_12b_patch
+.else
+CONFIGURE_ARGS+= --enable-default-toolkit=gtk
+.endif
+
.if !defined(WITHOUT_XFT)
CONFIGURE_ARGS+= --enable-xft
.endif