aboutsummaryrefslogtreecommitdiffstats
path: root/www/seamonkey/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-07-23 14:58:42 +0800
committermarcus <marcus@FreeBSD.org>2002-07-23 14:58:42 +0800
commit5145654968f07488e445b2b86822d4887e2f3fd0 (patch)
tree236ef86f07b86559c5f181923cccb7d6c4662d22 /www/seamonkey/Makefile
parent79657cf9d899d03046aa9aa82de49506ca2157f8 (diff)
downloadfreebsd-ports-gnome-5145654968f07488e445b2b86822d4887e2f3fd0.tar.gz
freebsd-ports-gnome-5145654968f07488e445b2b86822d4887e2f3fd0.tar.zst
freebsd-ports-gnome-5145654968f07488e445b2b86822d4887e2f3fd0.zip
* Fix build on -CURRENT
* Silence a portlint nit wrt to the order of PORTREVISION in the Makefile * Don't use --enable-reorder on non-i386 archs * Mark BROKEN for now on alpha as there is still a core dump during post-build * Use USE_GNOMENG Submitted by: Peter Kostouros <kpeter@melbpc.org.au> (patch for -CURRENT) me (everything else)
Diffstat (limited to 'www/seamonkey/Makefile')
-rw-r--r--www/seamonkey/Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index 1576e0ca5559..7d08a645ce8b 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -7,8 +7,8 @@
PORTNAME= mozilla
PORTVERSION= 1.0
-PORTEPOCH= 1
PORTREVISION= 1
+PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA} \
http://people.FreeBSD.org/~sobomax/:local
@@ -21,8 +21,7 @@ MAINTAINER= gnome@FreeBSD.org
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
freetype-config:${PORTSDIR}/print/freetype2
-LIB_DEPENDS= ORBit.2:${PORTSDIR}/devel/ORBit \
- jpeg.9:${PORTSDIR}/graphics/jpeg \
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
mng.1:${PORTSDIR}/graphics/libmng \
freetype.9:${PORTSDIR}/print/freetype2
@@ -36,7 +35,8 @@ EXTRACT_AFTER_ARGS= | tar -xf - -X ${FILESDIR}/tar-exclude
USE_X_PREFIX= yes
USE_PERL5= yes
USE_GMAKE= yes
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= orbit gtk12
GNU_CONFIGURE= yes
CONFIGURE_ARGS= \
--disable-auto-deps \
@@ -54,7 +54,6 @@ CONFIGURE_ARGS= \
--disable-optimize \
--disable-pedantic \
--disable-plaintext-editor-only \
- --enable-reorder \
--enable-strip \
--enable-svg \
--disable-tests \
@@ -98,6 +97,14 @@ MAKE_ENV= LD_LIBRARY_PATH=${WRKSRC}/dist/bin \
MOZ_INTERNAL_LIBART_LGPL=1
ALL_TARGET= default
+.if ${ARCH} == "i386"
+CONFIGURE_ARGS+= --enable-reorder
+.endif
+
+.if ${ARCH} == "alpha"
+BROKEN= "core dumps on alpha during post-build"
+.endif
+
.if exists(${LOCALBASE}/include/freetype/freetype.h)
BROKEN="You must upgrade your freetype port to 1.3.1_2 or higher before installing Mozilla. If you have 1.3.1_2 installed, please remove ${LOCALBASE}/include/freetype, then build Mozilla"
.endif