aboutsummaryrefslogtreecommitdiffstats
path: root/www/seamonkey/Makefile
diff options
context:
space:
mode:
authorreg <reg@FreeBSD.org>2000-08-04 01:37:43 +0800
committerreg <reg@FreeBSD.org>2000-08-04 01:37:43 +0800
commit5f9387b2dfbe4cdbbc64fb4966f65523fe2f6971 (patch)
tree80d5141456452e2eee4eacc4943d3a8329188e26 /www/seamonkey/Makefile
parent5d324cb9a296ff0013d651f85aa8be45d3d29802 (diff)
downloadfreebsd-ports-gnome-5f9387b2dfbe4cdbbc64fb4966f65523fe2f6971.tar.gz
freebsd-ports-gnome-5f9387b2dfbe4cdbbc64fb4966f65523fe2f6971.tar.zst
freebsd-ports-gnome-5f9387b2dfbe4cdbbc64fb4966f65523fe2f6971.zip
Redo the upgrade to M16.
Use one of the test programs to perform component registration in post-build, so that the port no longer requires world writeability. If you have an earlier version installed, component.reg could be a security risk: chmod 644 /usr/X11R6/lib/mozilla/component.reg chmod 644 /usr/X11R6/lib/mozilla/components/*.dat
Diffstat (limited to 'www/seamonkey/Makefile')
-rw-r--r--www/seamonkey/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index f9a00bedb854..93b28bfd9792 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mozilla
-PORTVERSION= M15
+PORTVERSION= M16
CATEGORIES= www
MASTER_SITES= ftp://ftp.mozilla.org/pub/mozilla/releases/${PORTVERSION:S/M/m/}/src/
DISTNAME= ${PORTNAME}-source-${PORTVERSION}
@@ -56,6 +56,8 @@ post-build:
@${SED} -e "s;@PREFIX@;${PREFIX};g" \
${FILESDIR}/mozilla.sh >${WRKSRC}/mozilla
@${CHMOD} 555 ${WRKSRC}/mozilla
+ @(cd ${WRKSRC}/dist/bin; \
+ ${ENV} LD_LIBRARY_PATH=. MOZILLA_FIVE_HOME=. ./regxpcom)
do-install:
${MKDIR} ${PREFIX}/lib/mozilla
@@ -63,7 +65,5 @@ do-install:
cd ${WRKSRC}/dist/bin && ${TAR} -chf - * | \
${TAR} -xf - -C ${PREFIX}/lib/mozilla
${INSTALL_SCRIPT} ${WRKSRC}/mozilla ${PREFIX}/bin
- ${TOUCH} ${PREFIX}/lib/mozilla/component.reg
- ${CHMOD} 666 ${PREFIX}/lib/mozilla/component.reg
.include <bsd.port.mk>