aboutsummaryrefslogtreecommitdiffstats
path: root/www/seamonkey2/Makefile
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2004-11-09 15:48:41 +0800
committerahze <ahze@FreeBSD.org>2004-11-09 15:48:41 +0800
commit3190a731d2132bfdc45e6a013ebc0d407b86f590 (patch)
treedec886b25ce022a067f5f912e5c963258b76b74a /www/seamonkey2/Makefile
parentfe63f5fab8aceed21536cddb9e4293843526bbec (diff)
downloadfreebsd-ports-gnome-3190a731d2132bfdc45e6a013ebc0d407b86f590.tar.gz
freebsd-ports-gnome-3190a731d2132bfdc45e6a013ebc0d407b86f590.tar.zst
freebsd-ports-gnome-3190a731d2132bfdc45e6a013ebc0d407b86f590.zip
- Install isp directory to fix Movemail support [1]
- Add WITH_CAIRO_RENDER knob that uses cairo for SVG rendering that replaces SVG rendering from libart. Pointed out by: marcus [1] Approved by: marcus (co mentor)
Diffstat (limited to 'www/seamonkey2/Makefile')
-rw-r--r--www/seamonkey2/Makefile27
1 files changed, 20 insertions, 7 deletions
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
index 7ebf45c5194e..eef3406e3baf 100644
--- a/www/seamonkey2/Makefile
+++ b/www/seamonkey2/Makefile
@@ -7,15 +7,17 @@
PORTNAME?= mozilla
PORTVERSION= 1.8.a4
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH?= 2
CATEGORIES?= www
MASTER_SITES= ${MASTER_SITE_MOZILLA} \
${MASTER_SITE_LOCAL:S/$/:local/}
MASTER_SITE_SUBDIR= mozilla/releases/${PORTNAME}${PORTVERSION:S/.a4/a4/}/src \
adamw/:local
-DISTFILES= ${PORTNAME}-source-${PORTVERSION:S/.a4/a4/}${EXTRACT_SUFX} \
- libart_lgpl${EXTRACT_SUFX}:local
+DISTFILES= ${PORTNAME}-source-${PORTVERSION:S/.a4/a4/}${EXTRACT_SUFX}
+.if !defined(WITH_CAIRO_RENDER)
+DISTFILES+= libart_lgpl${EXTRACT_SUFX}:local
+.endif
MAINTAINER= gnome@FreeBSD.org
COMMENT= The open source, standards compliant web browser
@@ -67,7 +69,6 @@ CONFIGURE_ARGS= \
--disable-bidi \
--disable-plaintext-editor-only \
--enable-svg \
- --enable-svg-renderer-libart \
--disable-tests \
--disable-xterm-updates \
--enable-xinerama \
@@ -81,8 +82,7 @@ CONFIGURE_ARGS= \
PLIST= ${WRKDIR}/pkg-plist
MOZ_EXTENSIONS= default
-CONFIGURE_ENV= MOZ_INTERNAL_LIBART_LGPL=1 \
- LOCALBASE=${LOCALBASE}
+CONFIGURE_ENV= LOCALBASE=${LOCALBASE}
PKGINSTALL= ${WRKDIR}/pkg-install
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
@@ -119,6 +119,18 @@ OPTIONS=XFT "Enable Xft font anti-aliasing" on \
BROKEN= "Does not compile on ia64 or alpha"
.endif
+.if defined(WITH_CAIRO_RENDER)
+LIB_DEPENDS+= svg-cairo.1:${PORTSDIR}/graphics/libsvg-cairo
+
+CONFIGURE_ARGS+= --enable-svg-renderer-cairo \
+ --disable-svg-renderer-libart
+CONFIGURE_ENV+= MOZ_SVG_RENDERER_CAIRO=1
+.else
+CONFIGURE_ARGS+= --enable-svg-renderer-libart \
+ --disable-svg-renderer-cairo
+CONFIGURE_ENV+= MOZ_INTERNAL_LIBART_LGPL=1
+.endif
+
.if !defined(WITHOUT_XFT)
LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/libXft
CONFIGURE_ARGS+=--enable-xft --disable-freetype2
@@ -187,7 +199,7 @@ FAKEDIR= ${WRKDIR}/fake
CONFIGURE_ARGS+= --enable-reorder
.endif
-.if ${OSVERSION} < 500035
+.if ${OSVERSION} < 500035 && !defined(WITH_CAIRO_RENDER)
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-nsSVGLibartGlyphMetricsFT.cpp
.endif
@@ -289,6 +301,7 @@ pre-install:
fi
${ECHO_CMD} lib/${MOZILLA}/mozilla >> ${PLIST}
${ECHO_CMD} lib/${MOZILLA}/mozilla-config >> ${PLIST}
+ @${CP} -RL ${WRKSRC}/dist/bin/defaults/isp ${FAKEDIR}/lib/${MOZILLA}/defaults
cd ${FAKEDIR}/lib/${MOZILLA} && ${FIND} -s * -type f -o -type l | \
${SED} -e 's:^:lib/${MOZILLA}/:' >> ${PLIST} \
&& ${FIND} -d * -type d | \