aboutsummaryrefslogtreecommitdiffstats
path: root/www/seamonkey2/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-02-26 11:05:47 +0800
committermarcus <marcus@FreeBSD.org>2004-02-26 11:05:47 +0800
commit6e14c6393b3116bf5e2dc4203a97407395d7b95a (patch)
treedc4cd534fd480cdc077c3ed6aa2f98cab9ddab2a /www/seamonkey2/Makefile
parent191d66dd52108adbd1a05b53b076db4585fbe936 (diff)
downloadfreebsd-ports-gnome-6e14c6393b3116bf5e2dc4203a97407395d7b95a.tar.gz
freebsd-ports-gnome-6e14c6393b3116bf5e2dc4203a97407395d7b95a.tar.zst
freebsd-ports-gnome-6e14c6393b3116bf5e2dc4203a97407395d7b95a.zip
* Update to 1.7.a
* Fix libiconv support * Fix SVG support by using a newer version of libart_lgpl * Use OPTIONS * Fix some potential lockups related to esound * Clean up a few potential pthread problems * Remove the libical support for calendar (libical is now included with Mozilla) * Allow the JPI_LIST to be overridden For a list of what's new in 1.7.a, checkout: http://www.mozilla.org/releases/mozilla1.7a/
Diffstat (limited to 'www/seamonkey2/Makefile')
-rw-r--r--www/seamonkey2/Makefile63
1 files changed, 33 insertions, 30 deletions
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
index 3ece92d1b925..fbb93248f66c 100644
--- a/www/seamonkey2/Makefile
+++ b/www/seamonkey2/Makefile
@@ -6,16 +6,13 @@
#
PORTNAME?= mozilla
-PORTVERSION= 1.6.b
-PORTREVISION?= 1
+PORTVERSION= 1.7.a
+PORTREVISION?= 0
PORTEPOCH?= 1
CATEGORIES?= www
-MASTER_SITES= ${MASTER_SITE_MOZILLA} \
- ${MASTER_SITE_LOCAL:S/$/:local/}
-MASTER_SITE_SUBDIR= mozilla/releases/${PORTNAME}${PORTVERSION:S/.b/b/}/src \
- marcus/:local
-DISTFILES= ${PORTNAME}-source-${PORTVERSION:S/.b/b/}${EXTRACT_SUFX} \
- libart_lgpl${EXTRACT_SUFX}:local
+MASTER_SITES= ${MASTER_SITE_MOZILLA}
+MASTER_SITE_SUBDIR= mozilla/releases/${PORTNAME}${PORTVERSION:S/.a/a/}/src
+DISTFILES= ${PORTNAME}-source-${PORTVERSION:S/.a/a/}${EXTRACT_SUFX}
MAINTAINER= gnome@FreeBSD.org
COMMENT= The open source, standards compliant web browser
@@ -30,8 +27,6 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
WRKSRC= ${WRKDIR}/${PORTNAME}
-IGNORE= "Main port has been upgraded to 1.6"
-
MOZILLA?= mozilla-devel
MOZ_SUFX= -devel
@@ -55,10 +50,6 @@ BROKEN= Mozilla${MOZ_SUFX} and Xft2 render the mozilla-fonts \
BROKEN= "Calendar requires Composer and Mailnews support."
.endif
-.if defined(WITH_CALENDAR)
-LIB_DEPENDS+= ical.0:${PORTSDIR}/devel/libical
-.endif
-
LATEST_LINK= ${MOZILLA}
EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude */CVS/* \
--exclude */macbuild/*\
@@ -69,6 +60,7 @@ EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude */CVS/* \
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_PERL5= yes
+USE_ICONV= yes
USE_GMAKE= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
@@ -92,6 +84,7 @@ CONFIGURE_ARGS= \
--disable-plaintext-editor-only \
--enable-strip \
--enable-svg \
+ --enable-svg-renderer-libart \
--disable-tests \
--disable-xterm-updates \
--enable-xinerama \
@@ -121,7 +114,8 @@ MOZ_EXTENSIONS:= ${MOZ_EXTENSIONS},irc
MOZ_EXTENSIONS:= ${MOZ_EXTENSIONS},xmlterm
.endif
CONFIGURE_ARGS+= --enable-extensions=${MOZ_EXTENSIONS}
-CONFIGURE_ENV= MOZ_INTERNAL_LIBART_LGPL=1
+CONFIGURE_ENV= MOZ_INTERNAL_LIBART_LGPL=1 \
+ LOCALBASE=${LOCALBASE}
.if defined(WITH_JAVASCRIPT_DEBUGGER)
CONFIGURE_ARGS+= --enable-jsd \
@@ -132,7 +126,6 @@ CONFIGURE_ARGS+= --disable-jsd \
.endif
.if defined(WITH_CALENDAR)
-CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS+= --enable-calendar
.endif
@@ -156,12 +149,22 @@ PKGCONFIG_FILES=mozilla-gtkmozembed mozilla-js mozilla-xpcom \
mozilla-nspr mozilla-nss mozilla-plugin
# JPI stuff. List paths to Java Plug-ins here in the order to try.
-JPI_LIST=\
+JPI_LIST?=\
${LOCALBASE}/jdk1.4.2/jre/plugin/${ARCH}/ns610/libjavaplugin_oji.so \
${LOCALBASE}/jdk1.4.1/jre/plugin/${ARCH}/ns610/libjavaplugin_oji.so \
${LOCALBASE}/diablo-jdk1.3.1/jre/plugin/${ARCH}/ns600/libjavaplugin_oji.so \
${LOCALBASE}/jdk1.3.1/jre/plugin/${ARCH}/ns600/libjavaplugin_oji.so
+OPTIONS= XFT "Enable Xft font anti-aliasing" on \
+ CALENDAR "Enable the Calendar module" off \
+ MAILNEWS "Enable Mail and News modules" on \
+ COMPOSER "Enable the HTML Composer module" on \
+ LDAP "Enable LDAP support for Mailnews" on \
+ CHATZILLA "Enable the Chatzilla IRC module" on \
+ XMLTERM "Enable the XMLTerm module" on \
+ JAVASCRIPT_DEBUGGER "Enable the DTD and JavaScript debuggers" off \
+ OPTIMIZED_CFLAGS "Enable -O2 optimizations" off
+
.include <bsd.port.pre.mk>
MAKE_ENV= LD_LIBRARY_PATH=${WRKSRC}/dist/bin \
@@ -186,22 +189,12 @@ BROKEN="You must upgrade your freetype port to 1.3.1_2 or higher before installi
.endif
pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} "Mozilla has the following tunable option(s):"
- @${ECHO_MSG} " WITHOUT_XFT=yes Disables Xft anti-aliasing support"
- @${ECHO_MSG} " WITH_CALENDAR=yes Enables the Calendar module (requires Mailnews and Composer modules)"
- @${ECHO_MSG} " WITHOUT_MAILNEWS=yes Disables the Mail and News modules"
- @${ECHO_MSG} " WITHOUT_COMPOSER=yes Disables the HTML Composer module"
- @${ECHO_MSG} " WITHOUT_LDAP=yes Disables LDAP support within the Mailnews module"
- @${ECHO_MSG} " WITHOUT_CHATZILLA=yes Disable the Chatzilla IRC module"
- @${ECHO_MSG} " WITHOUT_XMLTERM=yes Disable the XMLTerm module"
- @${ECHO_MSG} " WITH_JAVASCRIPT_DEBUGGER=yes Enable the DTD and JavaScript debuggers"
- @${ECHO_MSG} " WITH_OPTIMIZED_CFLAGS=yes Enable -O2 optimization"
- @${ECHO_MSG} ""
.if defined(WITH_CALENDAR)
+ @${ECHO_MSG} ""
@${ECHO_MSG} "Calendar is still beta software."
@${ECHO_MSG} "Use at your own risk."
@${ECHO_MSG} "http://mozilla.org/projects/calendar/"
+ @${ECHO_MSG} ""
.endif
post-patch:
@@ -212,7 +205,8 @@ post-patch:
${WRKSRC}/config/autoconf.mk.in
@${FIND} ${WRKSRC}/other-licenses/libical -name "*.c" | ${XARGS} \
${REINPLACE_CMD} 's|<malloc.h>|<stdlib.h>|g'
- @${REINPLACE_CMD} -e 's|-lc_r|${PTHREAD_LIBS}|g' \
+ @${REINPLACE_CMD} -e 's|-lc_r|${PTHREAD_LIBS}|g ; \
+ s|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/configure \
${WRKSRC}/nsprpub/configure
@${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g' \
@@ -220,6 +214,15 @@ post-patch:
${WRKSRC}/security/coreconf/FreeBSD.mk \
${WRKSRC}/directory/c-sdk/config/FreeBSD.mk \
${WRKSRC}/js/src/Makefile.in
+ @${REINPLACE_CMD} -e 's|libesd\.so\.0|${ESD_LIB}|g' \
+ ${WRKSRC}/widget/src/gtk2/nsSound.cpp
+ @${REINPLACE_CMD} -e '/accessibility.typeaheadfind.enablesound/s/true/false/' \
+ ${WRKSRC}/modules/libpref/src/init/all.js \
+ ${WRKSRC}/calendar/sunbird/app/profile/all.js
+ @${REINPLACE_CMD} -e 's|<iconv.h>|\"${LOCALBASE}/include/iconv.h\"|g' \
+ ${WRKSRC}/configure \
+ ${WRKSRC}/intl/uconv/native/nsNativeUConvService.cpp \
+ ${WRKSRC}/xpcom/io/nsNativeCharsetUtils.cpp
@for pcfile in ${PKGCONFIG_FILES}; do \
${REINPLACE_CMD} -e 's|mozilla-xpcom|mozilla-xpcom${MOZ_SUFX}${PKGNAMESUFFIX}|g ; \
s|mozilla-nspr|mozilla-nspr${MOZ_SUFX}${PKGNAMESUFFIX}|g' \