aboutsummaryrefslogtreecommitdiffstats
path: root/www/seamonkey2/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-06-01 11:34:55 +0800
committermarcus <marcus@FreeBSD.org>2003-06-01 11:34:55 +0800
commit91f2c4dc076786cffdf768f633b71fa2b53b804a (patch)
tree882b401a25ef3430bc9eb57813222dfa52a76287 /www/seamonkey2/Makefile
parent839e10ff14cbeb131bb7b0bfa7b7fd3cef246303 (diff)
downloadfreebsd-ports-gnome-91f2c4dc076786cffdf768f633b71fa2b53b804a.tar.gz
freebsd-ports-gnome-91f2c4dc076786cffdf768f633b71fa2b53b804a.tar.zst
freebsd-ports-gnome-91f2c4dc076786cffdf768f633b71fa2b53b804a.zip
* Add [untested] Alpha support [1]
* Fix some 64-bit problems in the JavaScript and nspr code [2] Submitted by: Bernd Walter <ticso@cicely.de> [1] tmm [2]
Diffstat (limited to 'www/seamonkey2/Makefile')
-rw-r--r--www/seamonkey2/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
index 8aa0e4fa8b79..5f35509a61b5 100644
--- a/www/seamonkey2/Makefile
+++ b/www/seamonkey2/Makefile
@@ -159,14 +159,12 @@ ALL_TARGET= default
CONFIGURE_ARGS+= --enable-reorder
.endif
-.if defined(WITH_OPTIMIZED_CFLAGS) && ${ARCH} != "alpha"
+.if defined(WITH_OPTIMIZED_CFLAGS)
CFLAGS+= -O2
CONFIGURE_ARGS+= --enable-optimize=-O2
.endif
-.if ${ARCH} == "alpha"
-CFLAGS+= -O0
-CONFIGURE_ARGS+= --disable-optimize
+.if ${ARCH} == "alpha" && ${OSVERSION} < 500035
BROKEN= "core dumps on alpha during post-build"
.endif
@@ -253,7 +251,7 @@ do-install:
${MKDIR} ${PREFIX}/lib/browser_plugins ; \
fi
if [ ! -L ${PREFIX}/lib/browser_plugins/libjavaplugin_oji.so ]; then \
- ${LN} -sf ${LOCALBASE}/jdk1.3.1/jre/plugin/i386/ns600/libjavaplugin_oji.so \
+ ${LN} -sf ${LOCALBASE}/jdk1.3.1/jre/plugin/${ARCH}/ns600/libjavaplugin_oji.so \
${PREFIX}/lib/browser_plugins/libjavaplugin_oji.so ; \
fi
.if defined(WITH_GTK2)