aboutsummaryrefslogtreecommitdiffstats
path: root/www/seamonkey2
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2007-10-10 08:15:33 +0800
committermarcus <marcus@FreeBSD.org>2007-10-10 08:15:33 +0800
commitb304f162056e71b361cf48421f3f2fdf286b9a0e (patch)
tree2c1f081be8d8bf46d45820b6c6d354feead5b2a7 /www/seamonkey2
parent0e9ac39a589d9bfe30ecffa1b498377288966ee6 (diff)
downloadfreebsd-ports-gnome-b304f162056e71b361cf48421f3f2fdf286b9a0e.tar.gz
freebsd-ports-gnome-b304f162056e71b361cf48421f3f2fdf286b9a0e.tar.zst
freebsd-ports-gnome-b304f162056e71b361cf48421f3f2fdf286b9a0e.zip
* Workaround a bug which can cause applications embedding Gecko to crash
on exit [1] * Use the correct size for a JavaScript object on 64-bit platforms which will help get the Java plug-in working on those platforms [2] Test by: mezz [1] Submitted by: jkim [2] Obtained from: Firefox trunk [2]
Diffstat (limited to 'www/seamonkey2')
-rw-r--r--www/seamonkey2/Makefile1
-rw-r--r--www/seamonkey2/files/patch-embedding_base_nsEmbedAPI.cpp16
-rw-r--r--www/seamonkey2/files/patch-js_src_liveconnect_nsISecureLiveconnect.h14
3 files changed, 31 insertions, 0 deletions
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
index c28561bacef9..2c98ba2ac702 100644
--- a/www/seamonkey2/Makefile
+++ b/www/seamonkey2/Makefile
@@ -8,6 +8,7 @@
PORTNAME= seamonkey
DISTVERSION= 1.1.4
+PORTREVISION= 1
CATEGORIES?= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
MASTER_SITE_SUBDIR= seamonkey/releases/${DISTVERSION}
diff --git a/www/seamonkey2/files/patch-embedding_base_nsEmbedAPI.cpp b/www/seamonkey2/files/patch-embedding_base_nsEmbedAPI.cpp
new file mode 100644
index 000000000000..2cc9823fed1c
--- /dev/null
+++ b/www/seamonkey2/files/patch-embedding_base_nsEmbedAPI.cpp
@@ -0,0 +1,16 @@
+--- embedding/base/nsEmbedAPI.cpp.orig 2007-10-09 20:00:30.000000000 -0400
++++ embedding/base/nsEmbedAPI.cpp 2007-10-09 20:01:45.000000000 -0400
+@@ -53,7 +53,12 @@ static PRBool sRegistryIniti
+ static PRUint32 sInitCounter = 0;
+
+ #define HACK_AROUND_THREADING_ISSUES
+-//#define HACK_AROUND_NONREENTRANT_INITXPCOM
++#ifdef __FreeBSD__
++#include <sys/param.h>
++#if __FreeBSD_version < 700042
++#define HACK_AROUND_NONREENTRANT_INITXPCOM
++#endif
++#endif
+
+ #ifdef HACK_AROUND_NONREENTRANT_INITXPCOM
+ // XXX hack class to clean up XPCOM when this module is unloaded
diff --git a/www/seamonkey2/files/patch-js_src_liveconnect_nsISecureLiveconnect.h b/www/seamonkey2/files/patch-js_src_liveconnect_nsISecureLiveconnect.h
new file mode 100644
index 000000000000..a672de913dd6
--- /dev/null
+++ b/www/seamonkey2/files/patch-js_src_liveconnect_nsISecureLiveconnect.h
@@ -0,0 +1,14 @@
+--- js/src/liveconnect/nsISecureLiveconnect.h.orig 2007-10-09 20:03:00.000000000 -0400
++++ js/src/liveconnect/nsISecureLiveconnect.h 2007-10-09 20:03:50.000000000 -0400
+@@ -51,7 +51,11 @@
+ #include "nsIFactory.h"
+ #include "jni.h"
+
++#if JS_BYTES_PER_WORD == 8
++typedef jlong jsobject;
++#else
+ typedef jint jsobject;
++#endif
+
+ class nsISecureLiveconnect : public nsISupports {
+ public: