aboutsummaryrefslogtreecommitdiffstats
path: root/www/seamonkey
diff options
context:
space:
mode:
authorbeat <beat@FreeBSD.org>2014-02-19 17:25:23 +0800
committerbeat <beat@FreeBSD.org>2014-02-19 17:25:23 +0800
commitb4076110e98c2d256b78c211ad72f77f698728e8 (patch)
tree7525a79d607872c0adb1560d9ecdb99a3eed17f3 /www/seamonkey
parentb70089c14d7f12d55a6580cb9bf6882e37533ea8 (diff)
downloadfreebsd-ports-gnome-b4076110e98c2d256b78c211ad72f77f698728e8.tar.gz
freebsd-ports-gnome-b4076110e98c2d256b78c211ad72f77f698728e8.tar.zst
freebsd-ports-gnome-b4076110e98c2d256b78c211ad72f77f698728e8.zip
Update to 2.24
Submitted by: Jan Beich Security: http://www.vuxml.org/freebsd/1753f0ff-8dd5-11e3-9b45-b4b52fce4ce8.html
Diffstat (limited to 'www/seamonkey')
-rw-r--r--www/seamonkey/Makefile47
-rw-r--r--www/seamonkey/distinfo8
-rw-r--r--www/seamonkey/files/extra-patch-mailnews-extensions-enigmail-config-getOsTarget.pl43
-rw-r--r--www/seamonkey/files/patch-bug87879118
-rw-r--r--www/seamonkey/files/patch-bug8933972
-rw-r--r--www/seamonkey/files/patch-bug94504650
-rw-r--r--www/seamonkey/files/patch-bug94656030
-rw-r--r--www/seamonkey/files/patch-bug94786231
-rw-r--r--www/seamonkey/files/patch-config__config.mk13
9 files changed, 151 insertions, 91 deletions
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index 12941aa033f5..47089609a0c7 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= seamonkey
-DISTVERSION= 2.23
-PORTREVISION= 2
+DISTVERSION= 2.24
CATEGORIES?= www mail news editors irc ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
https://ftp.mozilla.org/pub/mozilla.org/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source/
@@ -14,15 +13,17 @@ MAINTAINER= gecko@FreeBSD.org
COMMENT= The open source, standards compliant web browser
BUILD_DEPENDS= nspr>=4.10.2:${PORTSDIR}/devel/nspr \
- nss>=3.15:${PORTSDIR}/security/nss \
- sqlite3>=3.7.17:${PORTSDIR}/databases/sqlite3 \
+ nss>=3.15.4:${PORTSDIR}/security/nss \
+ sqlite3>=3.8.0.2:${PORTSDIR}/databases/sqlite3 \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
v4l_compat>0:${PORTSDIR}/multimedia/v4l_compat \
unzip:${PORTSDIR}/archivers/unzip
+# cairo>=1.12.16,2:${PORTSDIR}/graphics/cairo \
+
LIB_DEPENDS= libv4l2.so:${PORTSDIR}/multimedia/libv4l
-EM_VERSION= 1.6
-L_VERSION= 2.8b1
+EM_VERSION= 1.6.1_pre20140112
+L_VERSION= 2.9b1
SSP_UNSAFE= yes
USE_AUTOTOOLS= autoconf213:env
@@ -36,14 +37,15 @@ QT_NONSTANDARD= yes
WANT_PERL= yes
ALL_TARGET= default
USE_GL= gl
-USE_DOS2UNIX= mozilla/media/webrtc/trunk/webrtc/system_wrappers/source/spreadsortlib/spreadsort.hpp
+USES= dos2unix
+DOS2UNIX_FILES= mozilla/media/webrtc/trunk/webrtc/system_wrappers/source/spreadsortlib/spreadsort.hpp
MOZ_PIS_SCRIPTS= moz_pis_S50cleanhome
MOZ_EXTENSIONS= default
MOZ_OPTIONS+= --program-transform-name='s/seamonkey/${MOZILLA}/' \
--enable-application=suite
-USE_MOZILLA= # empty
+USE_MOZILLA= -cairo
MOZ_PKGCONFIG_FILES=
NOT_FOR_ARCHS= ia64
@@ -76,6 +78,10 @@ MOZSRC:= ${WRKSRC}/mozilla
XPI_LIBDIR= ${PREFIX}/lib/xpi
+.if ${PORT_OPTIONS:MALSA}
+BUILD_DEPENDS+= alsa-lib>=1.0.27.2_1:${PORTSDIR}/audio/alsa-lib
+.endif
+
.if ! ${PORT_OPTIONS:MMAILNEWS}
MOZ_OPTIONS+= --disable-ldap --disable-mailnews
.else
@@ -86,17 +92,19 @@ MOZ_OPTIONS+= --disable-ldap --enable-mailnews
MOZ_OPTIONS+= --enable-ldap --enable-mailnews
.endif
.if ${PORT_OPTIONS:MENIGMAIL}
-MASTER_SITES+= https://www.enigmail.net/download/source/:enigmail
+#MASTER_SITES+= https://www.enigmail.net/download/source/:enigmail
+MASTER_SITES+= https://dev.gentoo.org/~polynomial-c/mozilla/:enigmail
DISTFILES+= ${EM_DISTFILE}:enigmail
RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
EM_DISTNAME= enigmail-${EM_VERSION}
-EM_DISTFILE= ${EM_DISTNAME}.tar.gz
-EM_XPI_FILE= ${MOZ_OBJDIR}/mozilla/dist/bin/${EM_DISTNAME}-${OPSYS:L}-${ARCH:S/amd64/x86_64/}.xpi
+EM_DISTFILE= ${EM_DISTNAME}.tar.xz
+EM_XPI_FILE= ${WRKSRC}/mailnews/extensions/enigmail/build/${EM_DISTNAME}-${OPSYS:L}-${ARCH:S/amd64/x86_64/:S/i386/x86/}-gcc3.xpi
EM_ORIG_ID= {847b3a00-7ab1-11d4-8f02-006008948af5}
EM_ID= ${PORTNAME}@mozilla-enigmail.org
EM_ID_RFILES= ${XPI_LIBDIR}/${EM_ID}/install.rdf \
${XPI_LIBDIR}/${EM_ID}/components/enigmail.js \
${XPI_LIBDIR}/${EM_ID}/modules/enigmailCommon.jsm
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-mailnews-extensions-enigmail-config-getOsTarget.pl
.endif
.endif
@@ -108,7 +116,7 @@ MOZ_OPTIONS+= --disable-composer
MOZ_OPTIONS+= --enable-calendar
MOZ_MK_OPTIONS+= MOZ_CO_PROJECT=calendar
LIGHTNING_DIR= share/lightning
-XPI_FILE= ${MOZ_OBJDIR}/mozilla/dist/xpi-stage/lightning-${L_VERSION}.en-US.${OPSYS:L}${OSREL}-${ARCH:S/amd64/x86_64/}.xpi
+XPI_FILE= ${MOZ_OBJDIR}/mozilla/dist/xpi-stage/lightning-${L_VERSION}.en-US.${OPSYS:L}${OSREL}-${ARCH:S/x86/i386/:S/amd64/x86_64/}.xpi
XPI_ORIG_ID= {e2fda1a4-762b-4020-b5ad-a41df1933103}
XPI_ID= lightning@seamonkey.mozilla.org
.else
@@ -133,10 +141,11 @@ post-patch:
${WRKDIR}/${MOZILLA}.desktop
.if ${PORT_OPTIONS:MMAILNEWS} && ${PORT_OPTIONS:MENIGMAIL}
@${REINPLACE_CMD} -e 's,/usr/bin/perl,${PERL},' \
- ${WRKSRC}/mailnews/extensions/enigmail/makemake
+ ${WRKSRC}/mailnews/extensions/enigmail/util/fixlang.pl \
+ ${WRKSRC}/mailnews/extensions/enigmail/util/make-lang-xpi.pl
@${REINPLACE_CMD} -e '/^xpi/s/$$/ all/' \
-e '/^XPI_MODULE_VERS/s/= .*/= ${EM_VERSION}/' \
- ${WRKSRC}/mailnews/extensions/enigmail/Makefile.in
+ ${WRKSRC}/mailnews/extensions/enigmail/Makefile
@${REINPLACE_CMD} -e '/em:version/s,>[^<]*<,>${EM_VERSION}<,' \
-e '/em:maxVersion/s/pre//' \
${WRKSRC}/mailnews/extensions/enigmail/package/install.rdf
@@ -148,11 +157,15 @@ pre-configure:
(cd ${MOZSRC}/js/src/ && ${AUTOCONF})
.if ${PORT_OPTIONS:MMAILNEWS} && ${PORT_OPTIONS:MENIGMAIL}
+post-configure:
+ cd ${WRKSRC}/mailnews/extensions/enigmail/ && \
+ ${SETENV} ${MAKE_ENV} ./configure
+.endif
+
+.if ${PORT_OPTIONS:MMAILNEWS} && ${PORT_OPTIONS:MENIGMAIL}
post-build:
- cd ${WRKSRC}/mailnews/extensions/enigmail && \
- ./makemake -r -o ${MOZ_OBJDIR}
${SETENV} ${MAKE_ENV} ${GMAKE} -j${MAKE_JOBS_NUMBER} all xpi \
- -C ${MOZ_OBJDIR}/mailnews/extensions/enigmail
+ -C ${WRKSRC}/mailnews/extensions/enigmail
.endif
port-pre-install:
diff --git a/www/seamonkey/distinfo b/www/seamonkey/distinfo
index 5498fae97a96..fa0381f1d79e 100644
--- a/www/seamonkey/distinfo
+++ b/www/seamonkey/distinfo
@@ -1,4 +1,4 @@
-SHA256 (seamonkey-2.23.source.tar.bz2) = 45f8fd527981148ad96bc5d90eea6eb76d83f1e1b87262122ec4928127f01de1
-SIZE (seamonkey-2.23.source.tar.bz2) = 148268011
-SHA256 (enigmail-1.6.tar.gz) = 10d5eb7ba364b9b6e6275aae8bba1d0e4321ed7d55a715337d566ccf2a56ea4d
-SIZE (enigmail-1.6.tar.gz) = 1231111
+SHA256 (seamonkey-2.24.source.tar.bz2) = 63855265b4754dd056af8d611b50219577a592466cdf1d3865028d86ed680474
+SIZE (seamonkey-2.24.source.tar.bz2) = 149845514
+SHA256 (enigmail-1.6.1_pre20140112.tar.xz) = 2d89a9186c3ccfc9397c933c6f63c0518224fea0096d7a292dba3765de088149
+SIZE (enigmail-1.6.1_pre20140112.tar.xz) = 916028
diff --git a/www/seamonkey/files/extra-patch-mailnews-extensions-enigmail-config-getOsTarget.pl b/www/seamonkey/files/extra-patch-mailnews-extensions-enigmail-config-getOsTarget.pl
new file mode 100644
index 000000000000..c96f7ee2063d
--- /dev/null
+++ b/www/seamonkey/files/extra-patch-mailnews-extensions-enigmail-config-getOsTarget.pl
@@ -0,0 +1,43 @@
+commit 49a1daf
+Author: Patrick Brunschwig <patrick@enigmail.net>
+Date: Tue Jan 28 18:10:54 2014 +0100
+
+ fixed detection of compiler type for better supporting cross-compilers
+---
+ config/getOsTarget.pl | 8 +++++---
+ 1 file changed, 5 insertions(+), 3 deletions(-)
+
+diff --git config/getOsTarget.pl config/getOsTarget.pl
+index 91285cd..cf4a233 100755
+--- mailnews/extensions/enigmail/config/getOsTarget.pl
++++ mailnews/extensions/enigmail/config/getOsTarget.pl
+@@ -9,13 +9,15 @@
+ # -c : CPU and compiler type
+ # -o : OS type
+
++use File::Basename;
++
+ if ($#ARGV != 3) {
+ exit (1);
+ }
+
+ my $srcOs = $ARGV[1];
+ my $srcCpu = $ARGV[2];
+-my $srcComp = $ARGV[3];
++my $srcComp = basename($ARGV[3]);
+
+ my $targetOs = "";
+ my $targetCpu = "";
+@@ -95,10 +97,10 @@ else {
+ if ($targetOs eq "WINNT") {
+ $targetComp = "msvc";
+ }
+-if ($srcComp =~ /^gcc/) {
++elsif ($srcComp =~ /gcc/ || $srcComp =~ /clang/) {
+ $targetComp = "gcc3";
+ }
+-elsif ($srcComp =~ /^cc/) {
++elsif ($srcComp =~ /cc/) {
+ if ($targetOs eq "SunOS") {
+ $targetComp = "sunc";
+ }
diff --git a/www/seamonkey/files/patch-bug878791 b/www/seamonkey/files/patch-bug878791
index d888521e20e0..bcdd5e9bfea4 100644
--- a/www/seamonkey/files/patch-bug878791
+++ b/www/seamonkey/files/patch-bug878791
@@ -1,11 +1,11 @@
--- mozilla/toolkit/components/osfile/modules/osfile_unix_allthreads.jsm.orig 2013-05-11 21:19:53.000000000 +0200
+++ mozilla/toolkit/components/osfile/modules/osfile_unix_allthreads.jsm 2013-06-02 17:15:05.000000000 +0200
-@@ -40,7 +40,7 @@ if (typeof Components != "undefined") {
- // Open libc
- let libc;
- let libc_candidates = [ "libSystem.B.dylib",
-- "libc.so.6",
-+ "libc.so.7",
- "libc.so" ];
- for (let i = 0; i < libc_candidates.length; ++i) {
- try {
+@@ -41,7 +41,7 @@ let Const = SharedAll.Constants.libc;
+ // Open libc
+ let libc;
+ let libc_candidates = [ "libSystem.B.dylib",
+- "libc.so.6",
++ "libc.so.7",
+ "libc.so" ];
+ for (let i = 0; i < libc_candidates.length; ++i) {
+ try {
diff --git a/www/seamonkey/files/patch-bug893397 b/www/seamonkey/files/patch-bug893397
index 091d15fb41e5..0815e8ba400f 100644
--- a/www/seamonkey/files/patch-bug893397
+++ b/www/seamonkey/files/patch-bug893397
@@ -20,7 +20,7 @@ index 07b01de..11706af 100644
'osx_corewlan.mm',
]
+elif CONFIG['OS_ARCH'] == 'FreeBSD':
-+ CPP_SOURCES += [
++ SOURCES += [
+ 'nsWifiScannerFreeBSD.cpp',
+ ]
elif CONFIG['OS_ARCH'] == 'WINNT':
diff --git a/www/seamonkey/files/patch-bug945046 b/www/seamonkey/files/patch-bug945046
index 134c06e1590b..51ea60ea499f 100644
--- a/www/seamonkey/files/patch-bug945046
+++ b/www/seamonkey/files/patch-bug945046
@@ -35,15 +35,16 @@ diff --git xpcom/base/nsMemoryReporterManager.cpp xpcom/base/nsMemoryReporterMan
index b8147c8..0ffb34e 100644
--- mozilla/xpcom/base/nsMemoryReporterManager.cpp
+++ mozilla/xpcom/base/nsMemoryReporterManager.cpp
-@@ -196,6 +196,43 @@ static nsresult GetResidentFast(int64_t*
- return GetResident(aN);
+@@ -204,6 +204,61 @@ ResidentFastDistinguishedAmount(int64_t* aN)
+ return ResidentDistinguishedAmount(aN);
}
+#ifdef __FreeBSD__
+#include <libutil.h>
++#include <algorithm>
+
+static nsresult
-+GetKinfoVmentrySelf(int64_t* prss)
++GetKinfoVmentrySelf(int64_t* prss, uint64_t* maxreg)
+{
+ int cnt;
+ struct kinfo_vmentry *vmmap, *kve;
@@ -52,11 +53,16 @@ index b8147c8..0ffb34e 100644
+
+ if (prss)
+ *prss = 0;
++ if (maxreg)
++ *maxreg = 0;
+
+ for (int i = 0; i < cnt; i++) {
+ kve = &vmmap[i];
+ if (prss)
+ *prss += kve->kve_private_resident;
++ if (maxreg)
++ *maxreg = std::max(*maxreg,
++ kve->kve_end - kve->kve_start);
+ }
+
+ free(vmmap);
@@ -65,26 +71,39 @@ index b8147c8..0ffb34e 100644
+
+#define HAVE_PRIVATE_REPORTER
+static nsresult
-+GetPrivate(int64_t* aN)
++PrivateDistinguishedAmount(int64_t* aN)
+{
+ int64_t priv;
-+ nsresult rv = GetKinfoVmentrySelf(&priv);
++ nsresult rv = GetKinfoVmentrySelf(&priv, NULL);
+ if (NS_SUCCEEDED(rv))
+ *aN = priv * getpagesize();
+
+ return NS_OK;
+}
++
++#define HAVE_VSIZE_MAX_CONTIGUOUS_REPORTER 1
++static nsresult
++VsizeMaxContiguousDistinguishedAmount(int64_t* aN)
++{
++ uint64_t biggestRegion;
++ nsresult rv = GetKinfoVmentrySelf(NULL, &biggestRegion);
++ if (NS_SUCCEEDED(rv))
++ *aN = biggestRegion;
++
++ return NS_OK;
++}
+#endif // FreeBSD
+
#elif defined(SOLARIS)
#include <procfs.h>
-@@ -370,6 +407,24 @@ static nsresult GetResidentFast(int64_t*
+@@ -416,6 +470,25 @@ VsizeMaxContiguousDistinguishedAmount(int64_t* aN)
+ return NS_OK;
}
- #define HAVE_PRIVATE_REPORTER
++#define HAVE_PRIVATE_REPORTER
+static nsresult
-+GetPrivate(int64_t* aN)
++PrivateDistinguishedAmount(int64_t* aN)
+{
+ PROCESS_MEMORY_COUNTERS_EX pmcex;
+ pmcex.cb = sizeof(PROCESS_MEMORY_COUNTERS_EX);
@@ -100,11 +119,22 @@ index b8147c8..0ffb34e 100644
+}
+#endif // XP_<PLATFORM>
+
++#ifdef HAVE_VSIZE_MAX_CONTIGUOUS_REPORTER
+ class VsizeMaxContiguousReporter MOZ_FINAL : public MemoryUniReporter
+ {
+ public:
+@@ -429,8 +502,9 @@ public:
+ return VsizeMaxContiguousDistinguishedAmount(aAmount);
+ }
+ };
++#endif
+
+-#define HAVE_PRIVATE_REPORTER
+#ifdef HAVE_PRIVATE_REPORTER
class PrivateReporter MOZ_FINAL : public MemoryUniReporter
{
public:
-@@ -382,21 +437,10 @@ public:
+@@ -443,21 +517,10 @@ public:
NS_IMETHOD GetAmount(int64_t* aAmount)
{
@@ -119,7 +149,7 @@ index b8147c8..0ffb34e 100644
-
- *aAmount = pmcex.PrivateUsage;
- return NS_OK;
-+ return GetPrivate(aAmount);
++ return PrivateDistinguishedAmount(aAmount);
}
};
-
diff --git a/www/seamonkey/files/patch-bug946560 b/www/seamonkey/files/patch-bug946560
index f1ab78af9cce..7ef52a57a6b7 100644
--- a/www/seamonkey/files/patch-bug946560
+++ b/www/seamonkey/files/patch-bug946560
@@ -2,7 +2,16 @@ diff --git xpcom/base/nsMemoryInfoDumper.cpp xpcom/base/nsMemoryInfoDumper.cpp
index 0b2f78c..d857374 100644
--- mozilla/xpcom/base/nsMemoryInfoDumper.cpp
+++ mozilla/xpcom/base/nsMemoryInfoDumper.cpp
-@@ -30,7 +30,7 @@
+@@ -6,7 +6,7 @@
+
+ #include "mozilla/nsMemoryInfoDumper.h"
+
+-#ifdef XP_LINUX
++#if defined(XP_LINUX) || defined(__FreeBSD__)
+ #include "mozilla/Preferences.h"
+ #endif
+ #include "mozilla/unused.h"
+@@ -31,7 +31,7 @@
#include <unistd.h>
#endif
@@ -11,7 +20,7 @@ index 0b2f78c..d857374 100644
#include <fcntl.h>
#include <sys/types.h>
#include <sys/stat.h>
-@@ -109,7 +109,7 @@ private:
+@@ -110,7 +110,7 @@ private:
} // anonymous namespace
@@ -20,7 +29,7 @@ index 0b2f78c..d857374 100644
namespace {
/*
-@@ -548,7 +548,7 @@ nsMemoryInfoDumper::~nsMemoryInfoDumper(
+@@ -552,7 +552,7 @@ nsMemoryInfoDumper::~nsMemoryInfoDumper()
/* static */ void
nsMemoryInfoDumper::Initialize()
{
@@ -30,11 +39,20 @@ index 0b2f78c..d857374 100644
FifoWatcher::MaybeCreate();
#endif
diff --git xpcom/base/nsMemoryReporterManager.cpp xpcom/base/nsMemoryReporterManager.cpp
-index 8c65665..8f6d0e9 100644
+index 1252e27..6f22093 100644
--- mozilla/xpcom/base/nsMemoryReporterManager.cpp
+++ mozilla/xpcom/base/nsMemoryReporterManager.cpp
-@@ -824,7 +824,7 @@ nsMemoryReporterManager::Init()
- RegisterReporter(new mozilla::dmd::DMDReporter);
+@@ -17,7 +17,7 @@
+ #include "nsPIDOMWindow.h"
+ #include "nsIObserverService.h"
+ #include "nsIGlobalObject.h"
+-#if defined(XP_LINUX)
++#if defined(XP_LINUX) || defined(__FreeBSD__)
+ #include "nsMemoryInfoDumper.h"
+ #endif
+ #include "mozilla/Attributes.h"
+@@ -898,7 +898,7 @@ nsMemoryReporterManager::Init()
+ RegisterStrongReporter(new mozilla::dmd::DMDReporter());
#endif
-#if defined(XP_LINUX)
diff --git a/www/seamonkey/files/patch-bug947862 b/www/seamonkey/files/patch-bug947862
deleted file mode 100644
index 3dcb47036a2f..000000000000
--- a/www/seamonkey/files/patch-bug947862
+++ /dev/null
@@ -1,31 +0,0 @@
-diff --git media/webrtc/trunk/webrtc/system_wrappers/source/clock.cc media/webrtc/trunk/webrtc/system_wrappers/source/clock.cc
-index 7ef6c66..6ae1e97 100644
---- mozilla/media/webrtc/trunk/webrtc/system_wrappers/source/clock.cc
-+++ mozilla/media/webrtc/trunk/webrtc/system_wrappers/source/clock.cc
-@@ -15,7 +15,7 @@
- #include <Windows.h>
- #include <WinSock.h>
- #include <MMSystem.h>
--#elif ((defined WEBRTC_LINUX) || (defined WEBRTC_MAC))
-+#elif ((defined WEBRTC_LINUX) || (defined WEBRTC_BSD) || (defined WEBRTC_MAC))
- #include <sys/time.h>
- #include <time.h>
- #endif
-@@ -209,7 +209,7 @@ class WindowsRealTimeClock : public RealTimeClock {
- WindowsHelpTimer* _helpTimer;
- };
-
--#elif ((defined WEBRTC_LINUX) || (defined WEBRTC_MAC))
-+#elif ((defined WEBRTC_LINUX) || (defined WEBRTC_BSD) || (defined WEBRTC_MAC))
- class UnixRealTimeClock : public RealTimeClock {
- public:
- UnixRealTimeClock() {}
-@@ -240,7 +240,7 @@ Clock* Clock::GetRealTimeClock() {
- #if defined(_WIN32)
- static WindowsRealTimeClock clock(&global_help_timer);
- return &clock;
--#elif defined(WEBRTC_LINUX) || defined(WEBRTC_MAC)
-+#elif ((defined WEBRTC_LINUX) || (defined WEBRTC_BSD) || (defined WEBRTC_MAC))
- static UnixRealTimeClock clock;
- return &clock;
- #else
diff --git a/www/seamonkey/files/patch-config__config.mk b/www/seamonkey/files/patch-config__config.mk
deleted file mode 100644
index 8eb805bf6afd..000000000000
--- a/www/seamonkey/files/patch-config__config.mk
+++ /dev/null
@@ -1,13 +0,0 @@
-Fix fallout from http://hg.mozilla.org/releases/comm-release/rev/a6ab55f00e21
-XPIDL_LINK being undefined breaks enigmail build
---- config/config.mk.orig Tue Dec 10 10:22:36 2013
-+++ config/config.mk Tue Dec 10 10:22:57 2013
-@@ -325,6 +325,7 @@ MY_RULES := $(DEPTH)/config/myrules.mk
- # Default command macros; can be overridden in <arch>.mk.
- #
- CCC = $(CXX)
-+XPIDL_LINK = $(PYTHON) $(LIBXUL_DIST)/sdk/bin/xpt.py link
-
- OS_INCLUDES += $(NSPR_CFLAGS) $(NSS_CFLAGS) $(MOZ_JPEG_CFLAGS) $(MOZ_PNG_CFLAGS) $(MOZ_ZLIB_CFLAGS)
-
-