aboutsummaryrefslogtreecommitdiffstats
path: root/www/skytemplate
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-09-16 07:40:04 +0800
committerpav <pav@FreeBSD.org>2005-09-16 07:40:04 +0800
commit41675fe59e0cf61bf6f1b0eceb226f6ae37841d2 (patch)
tree5dd156f752157b8cbdaad548d7396761ca46d4e2 /www/skytemplate
parent03bc28f9b730cd80839839d70c4e8c3a7fedfaef (diff)
downloadfreebsd-ports-gnome-41675fe59e0cf61bf6f1b0eceb226f6ae37841d2.tar.gz
freebsd-ports-gnome-41675fe59e0cf61bf6f1b0eceb226f6ae37841d2.tar.zst
freebsd-ports-gnome-41675fe59e0cf61bf6f1b0eceb226f6ae37841d2.zip
SkyTemplate is a LGPL-ed fast template engine for PHP.
PR: ports/84223 Submitted by: Mun-Kyo Seo <munggo@gmail.com>
Diffstat (limited to 'www/skytemplate')
-rw-r--r--www/skytemplate/Makefile37
-rw-r--r--www/skytemplate/distinfo2
-rw-r--r--www/skytemplate/files/pkg-message.in8
-rw-r--r--www/skytemplate/pkg-descr3
-rw-r--r--www/skytemplate/pkg-plist10
5 files changed, 60 insertions, 0 deletions
diff --git a/www/skytemplate/Makefile b/www/skytemplate/Makefile
new file mode 100644
index 000000000000..ba5a359b4d44
--- /dev/null
+++ b/www/skytemplate/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: skytemplate
+# Date created: 28 Jul 2005
+# Whom: Mun-Kyo Seo <munggo@gmail.com>
+#
+# $FreeBSD$
+
+PORTNAME= skytemplate
+PORTVERSION= 1.3.1
+CATEGORIES= www
+MASTER_SITES= http://daddy.withsky.net/SkyTemplate/download/ \
+ http://mirror.pmy.lv/SkyTemplate/download/
+DISTNAME= SkyTemplate.v131
+
+MAINTAINER= munggo@gmail.com
+COMMENT= Yet another PHP compiling template engine
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
+
+USE_PHP= yes
+WANT_PHP_WEB= yes
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+SUB_FILES= pkg-message
+
+do-install:
+ ${MKDIR} ${DATADIR}
+.for f in class.SkyTemplate.php class.SkyTemplate_withDaddy.php
+ ${INSTALL_DATA} ${WRKSRC}/$f ${DATADIR}
+ ${MKDIR} ${DATADIR}/SkyTpl
+ ${INSTALL_DATA} ${WRKSRC}/SkyTpl/* ${DATADIR}/SkyTpl
+.endfor
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/skytemplate/distinfo b/www/skytemplate/distinfo
new file mode 100644
index 000000000000..c6769f658ce7
--- /dev/null
+++ b/www/skytemplate/distinfo
@@ -0,0 +1,2 @@
+MD5 (SkyTemplate.v131.tar.gz) = 0c9b9fc92ac5ef6f1c9fcc2046864579
+SIZE (SkyTemplate.v130p2.tgz) = 21470
diff --git a/www/skytemplate/files/pkg-message.in b/www/skytemplate/files/pkg-message.in
new file mode 100644
index 000000000000..b56ba8cc091e
--- /dev/null
+++ b/www/skytemplate/files/pkg-message.in
@@ -0,0 +1,8 @@
+****************************************************************
+
+To use SkyTemplate you have to add the correct include path into
+your %%LOCALBASE%%/etc/php.ini configuration file, like:
+
+include_path = ".:%%PREFIX%%/share/skytemplate"
+
+****************************************************************
diff --git a/www/skytemplate/pkg-descr b/www/skytemplate/pkg-descr
new file mode 100644
index 000000000000..fdab17c58c98
--- /dev/null
+++ b/www/skytemplate/pkg-descr
@@ -0,0 +1,3 @@
+SkyTemplate is a LGPL-ed fast template engine for PHP.
+
+WWW: http://daddy.withsky.net/SkyTemplate/
diff --git a/www/skytemplate/pkg-plist b/www/skytemplate/pkg-plist
new file mode 100644
index 000000000000..ae1578b2db04
--- /dev/null
+++ b/www/skytemplate/pkg-plist
@@ -0,0 +1,10 @@
+%%DATADIR%%/SkyTpl/batch.TplCompiler.php
+%%DATADIR%%/SkyTpl/class.DefaultCacheHandler.php
+%%DATADIR%%/SkyTpl/plugin.post.PathRewrite.php
+%%DATADIR%%/SkyTpl/plugin.pre.BearTemplateSyntax.php
+%%DATADIR%%/SkyTpl/plugin.pre.TagComment.php
+%%DATADIR%%/SkyTpl/setup.ini.Master.php
+%%DATADIR%%/class.SkyTemplate.php
+%%DATADIR%%/class.SkyTemplate_withDaddy.php
+@dirrm %%DATADIR%%/SkyTpl
+@dirrm %%DATADIR%%