aboutsummaryrefslogtreecommitdiffstats
path: root/www/snownews
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2005-05-27 10:25:18 +0800
committerleeym <leeym@FreeBSD.org>2005-05-27 10:25:18 +0800
commit8017f6fc760312103abd4b45b2f208db3e6f58b1 (patch)
tree4a503e36e17c190232ab884dc2e2bfc491f3dd33 /www/snownews
parent2d1b06a0bee0d6fc57f973ddfea5283b5d380db1 (diff)
downloadfreebsd-ports-gnome-8017f6fc760312103abd4b45b2f208db3e6f58b1.tar.gz
freebsd-ports-gnome-8017f6fc760312103abd4b45b2f208db3e6f58b1.tar.zst
freebsd-ports-gnome-8017f6fc760312103abd4b45b2f208db3e6f58b1.zip
- relocate all REINPLACE stuff to post-patch target
- respect WITHOUT_NLS PR: 79906 Submitted by: leeym Approved by: maintainer-timeout
Diffstat (limited to 'www/snownews')
-rw-r--r--www/snownews/Makefile20
-rw-r--r--www/snownews/pkg-plist18
2 files changed, 22 insertions, 16 deletions
diff --git a/www/snownews/Makefile b/www/snownews/Makefile
index 94c58709bc48..54c3f2cdd311 100644
--- a/www/snownews/Makefile
+++ b/www/snownews/Makefile
@@ -16,7 +16,6 @@ MAINTAINER= clsung@FreeBSD.org
COMMENT= A text mode RSS newsreader
USE_PERL5_BUILD=yes
-USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= libxml2
USE_REINPLACE= yes
@@ -30,6 +29,13 @@ post-configure:
.endif
.endif
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
+.endif
+
MAN1= snownews.1
MANLANG= "" de nl fr it ru_RU.KOI8-R
@@ -40,14 +46,14 @@ pre-everything::
@${ECHO_MSG} " Default is ISO-8859-1."
@${ECHO_MSG} " "
-pre-configure:
- @${REINPLACE_CMD} -e 's|#!/usr/bin/perl|#!/usr/bin/env perl|g' ${WRKSRC}/configure
-
post-patch:
+ @${REINPLACE_CMD} -e 's|#!/usr/bin/perl|#!${PERL}|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|CFLAGS=|CFLAGS+=|g' ${WRKSRC}/platform_settings
- @${REINPLACE_CMD} -e 's|gcc|${CC}|' ${WRKSRC}/Makefile
-
-pre-build:
@${REINPLACE_CMD} -e 's|^PREFIX|#PREFIX|' ${WRKSRC}/platform_settings
+ @${REINPLACE_CMD} -e 's|gcc|${CC}|' ${WRKSRC}/Makefile
+.if defined(WITHOUT_NLS)
+ ${REINPLACE_CMD} -e 's/ install-locales / /g' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's/ locales$$//g' ${WRKSRC}/Makefile
+.endif
.include <bsd.port.mk>
diff --git a/www/snownews/pkg-plist b/www/snownews/pkg-plist
index 1c28e7c4318d..772ff04eeef5 100644
--- a/www/snownews/pkg-plist
+++ b/www/snownews/pkg-plist
@@ -1,15 +1,15 @@
bin/opml2snow
bin/snownews
bin/snowsync
-share/locale/de/LC_MESSAGES/snownews.mo
-share/locale/fr/LC_MESSAGES/snownews.mo
-share/locale/nl/LC_MESSAGES/snownews.mo
-share/locale/sl/LC_MESSAGES/snownews.mo
-share/locale/es/LC_MESSAGES/snownews.mo
-share/locale/it/LC_MESSAGES/snownews.mo
-share/locale/ru/LC_MESSAGES/snownews.mo
-share/locale/pt_BR/LC_MESSAGES/snownews.mo
-share/locale/zh_TW/LC_MESSAGES/snownews.mo
+%%NLS%%share/locale/de/LC_MESSAGES/snownews.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/snownews.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/snownews.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/snownews.mo
+%%NLS%%share/locale/es/LC_MESSAGES/snownews.mo
+%%NLS%%share/locale/it/LC_MESSAGES/snownews.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/snownews.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/snownews.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/snownews.mo
@unexec rmdir %D/man/fr/man1 2>/dev/null || true
@unexec rmdir %D/man/fr 2>/dev/null || true
@unexec rmdir %D/man/de/man1 2>/dev/null || true