aboutsummaryrefslogtreecommitdiffstats
path: root/www/squid25/Makefile
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2006-02-04 19:45:40 +0800
committersem <sem@FreeBSD.org>2006-02-04 19:45:40 +0800
commitb512579f5734ad1964615b9037f3f68c7d64f7d5 (patch)
treedd5db7152e6e7bff8c99c6ca1f3d300f6dfdc3a5 /www/squid25/Makefile
parentff8a2ddaa1771e2291981c79aea53933941123aa (diff)
downloadfreebsd-ports-gnome-b512579f5734ad1964615b9037f3f68c7d64f7d5.tar.gz
freebsd-ports-gnome-b512579f5734ad1964615b9037f3f68c7d64f7d5.tar.zst
freebsd-ports-gnome-b512579f5734ad1964615b9037f3f68c7d64f7d5.zip
Implemented custom log format patch, providing similar functionality
to that of Apache LogFormat and CustomLog configuration directives. This also allows for output in multiple formats to different log files. See http://devel.squid-cache.org/customlog/ for more information. PR: ports/92522 Submitted by: Matthew Will <mwill@spingen.com> Approved by: maintainer
Diffstat (limited to 'www/squid25/Makefile')
-rw-r--r--www/squid25/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/www/squid25/Makefile b/www/squid25/Makefile
index 195e0938355c..22ba826aa36e 100644
--- a/www/squid25/Makefile
+++ b/www/squid25/Makefile
@@ -123,6 +123,7 @@ OPTIONS= SQUID_LDAP_AUTH "Install LDAP authentication helpers" off \
SQUID_STRICT_HTTP "Be strictly HTTP compliant" off \
SQUID_IDENT "Enable ident (RFC 931) lookups" on \
SQUID_USERAGENT_LOG "Enable User-Agent-header logging" off \
+ SQUID_CUSTOM_LOG "Enable custom log format" off \
SQUID_ARP_ACL "Enable ACLs based on ethernet address" off \
SQUID_PF "Enable transparent proxying with PF" off \
SQUID_IPFILTER "Enable transp. proxying with IPFilter" off \
@@ -274,6 +275,9 @@ CONFIGURE_ARGS+= --disable-ident-lookups
.if defined(WITH_SQUID_USERAGENT_LOG)
CONFIGURE_ARGS+= --enable-useragent-log
.endif
+.if defined(WITH_SQUID_CUSTOM_LOG)
+EXTRA_PATCHES+= ${PATCHDIR}/customlog-2.5.patch
+.endif
.if defined(WITH_SQUID_ARP_ACL)
CONFIGURE_ARGS+= --enable-arp-acl
.endif